Results 1 to 2 of 2

Thread: Package glib-2.0 was not found in the pkg-config search path. Perhaps you should add

  1. #1
    Join Date
    Sep 2007
    Beans
    9

    Package glib-2.0 was not found in the pkg-config search path. Perhaps you should add

    Now I am trying to install mono2.4 from its source so I have downloaded the source and while I tried to install it I got the error as below . Please help me hwo to install it as already I had failed to install it from my repo the mono2.0 version .Error I got is as following -


    checking for pkg-config... /usr/bin/pkg-config
    Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found
    Package gthread-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gthread-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gthread-2.0' found
    Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found
    Package gthread-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gthread-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gthread-2.0' found
    checking pkg-config is at least version 0.9.0... yes
    checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 1.3.11) were not met:

    No package 'glib-2.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
    and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.

  2. #2
    Join Date
    Jan 2007
    Location
    Melbourne, Australia
    Beans
    5,096

    Re: Package glib-2.0 was not found in the pkg-config search path. Perhaps you should

    Hi, you need to install the libglib2.0-dev package
    Code:
    sudo apt-get install libglib2.0-dev

    Ubuntu Newbie Help: irc: #beginners-help on network irc.freenode.net
    Help others, mark your threads solved.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •