Results 1 to 9 of 9

Thread: configure lxde desktop wallpaper and menus?

  1. #1
    Join Date
    Apr 2009
    Location
    none of your business
    Beans
    49
    Distro
    Ubuntu 11.04 Natty Narwhal

    Question configure lxde desktop wallpaper and menus?

    I know I tend to ramble, so I'll try to make this concise. I've got lxde and ubuntu on my old computer and have accidentally lost access to the menu that allows you to change the desktop wallpaper and change the right-click desktop options. could I launch the thing from the command line somehow? Can't find the command.

    Post #2 helped. And it gave me an idea to make my system better. thanks.
    Last edited by user sam; August 22nd, 2009 at 11:06 PM.

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: configure lxde desktop wallpaper and menus?

    You can access the same menu through the file manager's settings (since it's the PCManFM file manager that handles the desktop wallpaper & icons in LXDE).

    Just open the file manager and go to Edit/Preferences.

    edit: to launch the same dialog from command line you can run "pcmanfm --show-pref=2"
    Last edited by mcduck; August 19th, 2009 at 08:20 AM.

  3. #3
    Join Date
    Apr 2009
    Location
    Hyper-Cyberspace
    Beans
    Hidden!
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: configure lxde desktop wallpaper and menus?

    In LXDE, just right-click the desktop. It opens up a menu, choose Desktop Settings and select your wallpaper from there.

    You can add any wallpaper you like by putting it in usr/share/lxde/wallpaper.

    -Robin

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: configure lxde desktop wallpaper and menus?

    Quote Originally Posted by dixiedancer View Post
    In LXDE, just right-click the desktop. It opens up a menu, choose Desktop Settings and select your wallpaper from there.

    You can add any wallpaper you like by putting it in usr/share/lxde/wallpaper.

    -Robin
    The OP just said he has lost the access to that menu, probably by either disabling PCManFM from drawing the desktop, or by setting it to show the window manager's menu instead of the PCmanFM menu..

    (and the wallpapers can be in any directory)

  5. #5
    Join Date
    Apr 2009
    Location
    Hyper-Cyberspace
    Beans
    Hidden!
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: configure lxde desktop wallpaper and menus?

    Quote Originally Posted by mcduck View Post
    The OP just said he has lost the access to that menu, probably by either disabling PCManFM from drawing the desktop, or by setting it to show the window manager's menu instead of the PCmanFM menu..

    (and the wallpapers can be in any directory)
    Ooopsie, you're right! I'm sorry...

    The only quick and easy way I know to do it is to use Synaptic again, UNINSTALL LXDE, then Re-install it. It might restore whatever got lost.

    If you still have your wallpapers, place in a separate folder so you can restore them to usr/share/lxde/wallpaper afterwards.

    I've actually done that myself once, so I know it works if all else fails.

    Let us know...

    -Robin

  6. #6
    Join Date
    Feb 2010
    Beans
    3

    Re: configure lxde desktop wallpaper and menus?

    Quote Originally Posted by mcduck View Post
    You can access the same menu through the file manager's settings (since it's the PCManFM file manager that handles the desktop wallpaper & icons in LXDE).

    Just open the file manager and go to Edit/Preferences.

    edit: to launch the same dialog from command line you can run "pcmanfm --show-pref=2"
    Thanx Bro , this is works in my PC.My right click mouse on desktop have back to normal. Once again Thanx a lot

  7. #7
    Join Date
    May 2007
    Location
    Winnipeg, Canada
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: configure lxde desktop wallpaper and menus?

    Running LXDE remotely, it works for me as follows.

    In LXDE .. PCFileMan/Edit/Preferences/Desktop/ .. under "General" .. unset "show menus provided by WM when desktop is clicked".

    This is the reverse action?

    Is that a bug or because I am running remotely?

    Thanks,

  8. #8
    Join Date
    Nov 2011
    Beans
    4

    Re: configure lxde desktop wallpaper and menus?

    Hello!

    I've just had the same problem, but the menu id pcmanfm did not show "Desktop" tab. I found out, that it suffices to manually edit the following file, in case anyone has the same problem.

    ~/.config/pcmanfm/lubuntu/pcmanfm.conf

    and change the one in
    show_wm_menu=1
    to 0.

    I hope this helps, without having to reinstall the lxde manually.

    Regards,
    Mcudrc

  9. #9
    Join Date
    Nov 2008
    Beans
    12

    Re: configure lxde desktop wallpaper and menus?

    For others who stumble on this thread:

    I can confirm that in PCManFM 0.9.9 under Edit > Preferences, there is no "Desktop" tab. However, in another thread I found the following pcmanfm argument that brings up the display configuration:

    Code:
    pcmanfm --desktop-pref
    Thanks to http://ubuntuforums.org/showthread.php?t=1884082

    Update: Attached is a shortcut for the lxde menu. Simply remove the ".txt" from the end of the filename, and copy this to /usr/share/applications. You'll then find it in Menu > Preferences > Desktop Preferences.
    Attached Files Attached Files
    Last edited by raztus; December 13th, 2011 at 06:09 AM. Reason: Correcting tab name

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •