Results 1 to 5 of 5

Thread: Can't use apt-get

  1. #1
    Join Date
    Nov 2012
    Beans
    2

    Can't use apt-get

    When I use apt-get I get this error: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. I want to install GD for my web server. I used sudo apt-get install php5-gd This happens with all apt-get commands. Thanks

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't use apt-get

    You do not say if you followed the instructions in that error message. Did you run?

    Code:
    sudo dpkg --configure -a
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Apr 2006
    Location
    Ubuntuland
    Beans
    2,124
    Distro
    Ubuntu 13.10 Saucy Salamander

    Exclamation Re: Can't use apt-get

    Quote Originally Posted by CharlyZA View Post
    When I use apt-get I get this error: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. I want to install GD for my web server. I used sudo apt-get install php5-gd This happens with all apt-get commands. Thanks
    That message is there for a reason.
    24 beers in a case, 24 hours in a day. Coincidence? I think not!

    Trusty Tahr 64 bit, AMD Phenom II 955 Quad Core 3.2GHz, GeForce 9600 GT
    16G PC2-6400 RAM, 128 GB SSD, Twin 1TB SATA 7200 RPM RAID0

  4. #4
    Join Date
    Nov 2012
    Beans
    2

    Re: Can't use apt-get

    I have tried. I get this error:
    Code:
    root@CFP:~# sudo dpkg --configure -a
    Setting up proftpd-basic (1.3.4~rc2-4) ...
    cp: cannot create regular file `/etc/proftpd/proftpd.conf.proftpd-new': No such file or directory
    dpkg: error processing proftpd-basic (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     proftpd-basic

  5. #5
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: Can't use apt-get

    You say that it happens with apt-get commands. Makes me wonder if you need to update.

    sudo apt-get update

    Then try an install

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •