Page 331 of 543 FirstFirst ... 231281321329330331332333341381431 ... LastLast
Results 3,301 to 3,310 of 5425

Thread: Guide to Get the Best Performace from the GMA 500

  1. #3301
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by jbernardo View Post
    Looks like we have to remove the patch that enables ExaNoComposite by default...
    I've searched in sources but haven't found any interesting reference to exanocomposite,
    only the xorg option in poulsbo-config but it is no more used.

    Code:
    grep -iR exanocomposite *
    poulsbo-config/bin/xorgconfig.py:	#self.xorg_conf.addOption('Device', 'ExaNoComposite', 'True', optiontype='Option', position=0)
    poulsbo-config/debian/changelog:  * removed exanocomposite in xorg.conf
    poulsbo-config/debian/changelog:  * added exanocomposite in xorg.conf

  2. #3302
    Join Date
    Jun 2006
    Location
    Parma, Italy
    Beans
    679
    Distro
    Kubuntu

    Re: Guide to Get the Best Performace from the GMA 500

    I found that we still have "psb_xvtempfix.patch" in xserver-xorg-video-psb, which probably should be removed now, but haven't found where the default for ExaNoComposite changed, possibly in the main trunk.

  3. #3303
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by jbernardo View Post
    I found that we still have "psb_xvtempfix.patch" in xserver-xorg-video-psb, which probably should be removed now, but haven't found where the default for ExaNoComposite changed, possibly in the main trunk.
    I've replaced psb_xvtempfix.patch content with the latest patch from Yves but haven't changed the name of the patch

    about ExaNoComposite i don't know where was modified or added, searched everywhere!

  4. #3304
    Join Date
    Jun 2010
    Beans
    121

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by lucazade View Post
    I've replaced psb_xvtempfix.patch content with the latest patch from Yves but haven't changed the name of the patch

    about ExaNoComposite i don't know where was modified or added, searched everywhere!
    Please test toroughly, maybe ubuntu made a patch to xorg enabling the option by default, disabling again might introduce the driver-bug again. It might be better to fix the bug and gain performance.

    -Yves

  5. #3305
    Join Date
    Jun 2006
    Location
    Parma, Italy
    Beans
    679
    Distro
    Kubuntu

    Re: Guide to Get the Best Performace from the GMA 500

    One small problem is that disabling ExaNoComposite breaks kwin compositing, so no desktop effects on kde.

    PS: Just a thought. maybe enabling ExaNoComposite when using emgd drivers brings back kwin compositing for that, like it does for psb.

  6. #3306
    Join Date
    Jun 2010
    Beans
    121

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by jbernardo View Post
    One small problem is that disabling ExaNoComposite breaks kwin compositing, so no desktop effects on kde.

    PS: Just a thought. maybe enabling ExaNoComposite when using emgd drivers brings back kwin compositing for that, like it does for psb.
    Do you have an idea why it breaks kwin compositing? Wrong detection or has something changed within Xorg and is ExaCompositing no longer supported (eg no longer doing compositing) ?

    -Yves

  7. #3307
    Join Date
    Jun 2006
    Location
    Parma, Italy
    Beans
    679
    Distro
    Kubuntu

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by yvesdm3000 View Post
    Do you have an idea why it breaks kwin compositing? Wrong detection or has something changed within Xorg and is ExaCompositing no longer supported (eg no longer doing compositing) ?

    -Yves
    Unfortunately, all I get is a message at the "Screen Effects" configuration stating that effects are disabled due to technical reasons. When I posted that on kdebugs for the emgd driver, it was immediately closed with a simple comment - driver bug. And that is all, unfortunately.

  8. #3308
    Join Date
    Jun 2010
    Beans
    121

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by jbernardo View Post
    Unfortunately, all I get is a message at the "Screen Effects" configuration stating that effects are disabled due to technical reasons. When I posted that on kdebugs for the emgd driver, it was immediately closed with a simple comment - driver bug. And that is all, unfortunately.
    You can always check if there is a difference in extensions using xdpyinfo. That is generally the place where software checks if something is supported or not.

    (I'm not anywhere near my tablet so I cannot do the check)

    -Yves

  9. #3309
    Join Date
    Jun 2006
    Location
    Parma, Italy
    Beans
    679
    Distro
    Kubuntu

    Re: Guide to Get the Best Performace from the GMA 500

    Quote Originally Posted by yvesdm3000 View Post
    You can always check if there is a difference in extensions using xdpyinfo. That is generally the place where software checks if something is supported or not.

    (I'm not anywhere near my tablet so I cannot do the check)

    -Yves
    I'll check what is the difference between them with the psb driver and post it here later.

  10. #3310
    Join Date
    Mar 2007
    Beans
    387

    Re: Guide to Get the Best Performace from the GMA 500

    Oh, fun - lucazade etc, here's something you may run into with 2.6.38:

    /builddir/build/BUILD/psb-kmod-4.41.1/_kmod_build_2.6.38-0.rc5.git1.1.fc15.i686
    /drm_agpsupport.c: In function 'drm_agp_flush_chipset':
    /builddir/build/BUILD/psb-kmod-4.41.1/_kmod_build_2.6.38-0.rc5.git1.1.fc15.i686/drm_agpsupport.c:647:2: error: implicit declaration of function 'agp_flush_chipset' [-Werror=implicit-function-declaration]
    cc1: some warnings being treated as errors
    make[2]: *** [/builddir/build/BUILD/psb-kmod-4.41.1/_kmod_build_2.6.38-0.rc5.git1.1.fc15.i686/drm_agpsupport.o] Error 1

    I suspect this is a result of:

    http://www.mail-archive.com/intel-gf.../msg02089.html

    "kill agp_flush_chipset and corresponding ioctl"

    I don't have the chops to fix this, but thought I'd let you lot know about it...
    Adam Williamson | http://www.happyassassin.net
    Fedora QA Community Monkey

Page 331 of 543 FirstFirst ... 231281321329330331332333341381431 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •