Results 1 to 5 of 5

Thread: Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

  1. #1
    Join Date
    Feb 2006
    Location
    USA
    Beans
    39
    Distro
    Ubuntu 9.10 Karmic Koala

    Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

    Hi all, I need some help. I have a Gateway MD2614U laptop and it has an Atheros AR5B91 wifi chipset. This is a Draft-N chipset. I am using Ubuntu 9.04 x64. I am connecting to a Belkin F5D8236-4v1 wireless N router. I don't think this is a router issue because I don't have any problems in Windows.

    The problem is, when I boot Ubuntu my wifi will connect and all will work fine... for about ten minutes. After that, it's frequent disconnects and I have to force it to reconnect each time. After doing this a few times it won't reconnect at all and I have to reboot to get it to connect again... and then I do the whole process over. For now I'm just booting into Vista since I can't figure this thing out.

    Any ideas? Anyone know what driver this chipset uses by default, and if so, can I try another driver? Thanks for the help!

    EDIT: The complete specs of the laptop in case you think it could be a hardware conflict:

    AMD Turion x2 x64 @ 2.1ghz
    3GB DDR2-667
    250GB SATA3.0 5400RPM HDD
    ATi Mobility Radeon HD3200
    Conexant HD audio
    Conexant modem
    Marvell Yukon 88E8057 PCI-E Gigabit lan
    Atheros AR5B91 b/g/Draft-n
    Last edited by DarkED; July 30th, 2009 at 02:10 AM.
    Got another blue screen? Here's what you should do:
    1. format c:
    2. mkdir /usr/var/linux

  2. #2
    Join Date
    Feb 2008
    Beans
    15

    Re: Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

    I had this same problem and resolved it by installing:
    linux-backports-modules-karmic
    Last edited by lawhorne; November 9th, 2009 at 03:15 AM. Reason: solution

  3. #3
    Join Date
    Oct 2007
    Beans
    6

    Smile Re: Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

    Thanks a tonne for this solution..was going mad with this problem! Have passed on this solution to one other friend of mine Thanks again!!

  4. #4
    Join Date
    Feb 2009
    Beans
    3

    Re: Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

    Quote Originally Posted by lawhorne View Post
    I had this same problem and resolved it by installing:
    linux-backports-modules-karmic
    This worked for me! Thank you!

  5. #5
    Join Date
    May 2009
    Beans
    3

    Re: Atheros AR5B91 in Ubuntu 9.04 x64 - frequent disconnects

    Were you able to get the N-channel router running @ 40 Mhz wide band to work with the ARB591 client/laptop?

    For some reason it won't connect to N-channel (works on wireless G) & i'm not sure how to move forward to a resolution. My N-network (LinkSys 600N Router) does not have any security & it controlled by MAC access list. Tried the linux-backports-modules & the mad-wifi driver Ath5k

    I would highly appreciate if someone could send me specific instruction to have it work. I'm running Karmic Koala on 2.6.31-16 kernel
    Last edited by crazi2k; February 23rd, 2010 at 03:17 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •