Results 1 to 10 of 63

Thread: Gens/GS r7_pre2 - Preview Release

Hybrid View

  1. #1
    Join Date
    Oct 2008

    Gens/GS r7_pre5 - Preview Release

    I finally got the new plugin system in Gens/GS to a point where I can call it v1.0. However, I'm not quite done with Gens/GS r7. So, I'm releasing an almost-done preview release, r7_pre2.

    Gens/GS r7_pre3 is out now, with fixes for some bugs that crashed the emulator in some situations. (Also, I added a page for mdp_error.h in the MDP documentation.)

    Gens/GS r7_pre4 is out now. Release 7 won't be out until I finish the documentation, but there's a ton of useful bug fixes in r7_pre4, including a fix for an SRAM regression introduced in r7_pre2 and proper POV hat support on Linux. (I have no idea why the Ubuntu developers decided to use POV hats on 9.04, but whatever.)

    Gens/GS r7_pre5 is out now. I really didn't want to do another prerelease, but this has a ton of changes, including fixes for inverted axes in Controller Configuration on the Linux version, plus a fix with POV hats on the Linux version. Additionally, RGB color scaling is now supported, so, for example, an MD CRAM color 0xEEE is scaled to RGB(255,255,255) instead of RGB(224,224,224). This results in brighter images, and is more accurate to how the actual hardware works. (0xEEE tells the VDP to output maximum brightness for all three color components.) [This can be turned off in Graphics, Color Adjust.]

    Please test it and report any bugs you may find.

    Changes from m6 to r7_pre5: http://gs_server.gerbilsoft.ddns.inf...release-7_pre5


    EDIT: Release 7, Preview 5 is out.
    Last edited by GerbilSoft; October 11th, 2009 at 11:37 PM. Reason: Gens/GS r7_pre5 release.

  2. #2
    Join Date
    Sep 2006

    Re: Gens/GS r7_pre2 - Preview Release

    Do you still use the site I just happened to come across this post by accident but was always trying to follow the development of gens at the sonicretro site.

  3. #3
    Join Date
    Oct 2007
    Canuck Land
    Ubuntu 12.10 Quantal Quetzal

    Arrow Re: Gens/GS r7_pre2 - Preview Release

    Nice to see you continue work on this emulator.

    Anyway, I tried it and the first thing that happened on start up was that it crashed, giving me this error message:

    b66bb000-b66bc000 rw-gens:1:gens_sighandler(): Signal 6 (SIGABRT) received. Shutting down.
    But this issue was solved simply by deleting my .gens directory for Gens/GS milestone 6.

    The second time it crashed on me was when I tried to change the OpenGL custom resolution settings. It gave me the following error message:

    *** stack smashing detected ***: gens terminated
    ======= Backtrace: =========
    ======= Memory map: ========
    08048000-08238000 r-xp 00000000 08:11 26271      /usr/bin/gens
    08238000-0824d000 rw-p 001f0000 08:11 26271      /usr/bin/gens
    0824d000-0930d000 rw-p 0824d000 00:00 0 
    0a459000-0a8df000 rw-p 0a459000 00:00 0          [heap]
    b47b6000-b48eb000 r-xp 00000000 08:11 10338      /usr/lib/
    b48eb000-b48ec000 ---p 00135000 08:11 10338      /usr/lib/
    b48ec000-b48f0000 r--p 00135000 08:11 10338      /usr/lib/
    b48f0000-b48f1000 rw-p 00139000 08:11 10338      /usr/lib/
    b48f1000-b48f2000 rw-p b48f1000 00:00 0 
    b48f2000-b4923000 r-xp 00000000 08:11 9527       /usr/lib/
    b4923000-b4926000 rw-p 00030000 08:11 9527       /usr/lib/
    b4926000-b4959000 r-xp 00000000 08:11 9804       /usr/lib/
    b4959000-b495a000 ---p 00033000 08:11 9804       /usr/lib/
    b495a000-b495c000 r--p 00033000 08:11 9804       /usr/lib/
    b495c000-b495d000 rw-p 00035000 08:11 9804       /usr/lib/
    b495d000-b495e000 rw-p b495d000 00:00 0 
    b495e000-b498f000 r-xp 00000000 08:11 10182      /usr/lib/
    b498f000-b4990000 r--p 00031000 08:11 10182      /usr/lib/
    b4990000-b4991000 rw-p 00032000 08:11 10182      /usr/lib/
    b49a6000-b49c0000 r--s 00000000 08:11 28246      /usr/share/mime/mime.cache
    b49c0000-b49da000 r-xp 00000000 08:11 50788      /usr/lib/gio/modules/
    b49da000-b49db000 r--p 00019000 08:11 50788      /usr/lib/gio/modules/
    b49db000-b49dc000 rw-p 0001a000 08:11 50788      /usr/lib/gio/modules/
    b49dc000-b4a12000 r-xp 00000000 08:11 137181     /lib/
    b4a12000-b4a13000 r--p 00035000 08:11 137181     /lib/
    b4a13000-b4a14000 rw-p 00036000 08:11 137181     /lib/
    b4a14000-b4a26000 r-xp 00000000 08:11 30294      /usr/lib/
    b4a26000-b4a27000 r--p 00012000 08:11 30294      /usr/lib/
    b4a27000-b4a28000 rw-p 00013000 08:11 30294      /usr/lib/
    b4a29000-b4a38000 r-xp 00000000 08:11 2579       /lib/
    b4a38000-b4a39000 r--p 0000f000 08:11 2579       /lib/
    b4a39000-b4a3a000 rw-p 00010000 08:11 2579       /lib/
    b4a3a000-b4a3b000 r-xp 00000000 08:11 12704      /usr/lib/gtk-2.0/2.10.0/loaders/
    b4a3b000-b4a3c000 r--p 00000000 08:11 12704      /usr/lib/gtk-2.0/2.10.0/loaders/
    b4a3c000-b4a3d000 rw-p 00001000 08:11 12704      /usr/lib/gtk-2.0/2.10.0/loaders/
    b4a3d000-b4a4c000 r-xp 00000000 08:11 34819      /usr/lib/gio/modules/
    b4a4c000-b4a4d000 r--p 0000e000 08:11 34819      /usr/lib/gio/modules/
    b4a4d000-b4a4e000 rw-p 0000f000 08:11 34819      /usr/lib/gio/modules/
    b4a4e000-b4df5000 r--p 00000000 08:11 11611      /usr/share/icons/hicolor/icon-theme.cache
    b4df5000-b4f75000 rw-s d3e08000 00:0f 7754       /dev/nvidia0
    b4f75000-b50f5000 rw-s d3e08000 00:0f 7754       /dev/nvidia0
    b50f5000-b5275000 rw-s d043c000 00:0f 7754       /dev/nvidia0
    b5275000-b52d5000 rw-s 00000000 00:09 11993115   /SYSV00000000 (deleted)
    b5326000-b53a7000 rw-p b5326000 00:00 0 
    b53a7000-b53a8000 rw-s 00000000 00:09 11960346   /SYSV00000000 (deleted)
    b53a8000-b53a9000 rw-s 00000000 00:09 11927577   /SYSV00000000 (deleted)
    b53ab000-b53ac000 r--s 00000000 08:11 26119      /home/kev/.local/share/mime/mime.cache
    b53ac000-b53ad000 rw-s 00000000 00:09 11894808   /SYSV00000000 (deleted)
    b53ad000-b54ad000 rw-s e0114000 00:0f 7754       /dev/nvidia0
    b54ad000-b54ae000 rw-s d3f8c000 00:0f 7754       /dev/nvidia0
    b54ae000-b54af000 rw-s 1eaee000 00:0f 7754       /dev/nvidia0
    b54af000-b54b0000 rw-s 1eaed000 00:0f 7754       /dev/nvidia0
    b54b0000-b54b1000 rw-s de820000 00:0f 7754       /dev/nvidia0
    b54b1000-b55b3000 rw-s e0011000 00:0f 7754       /dev/nvidia0
    b55f4000-b5657000 rw-p 00000000 00:0f 743        /dev/zero
    b5657000-b5a8f000 rw-s d0000000 00:0f 7754       /dev/nvidia0
    b5a8f000-b5ab9000 rw-s 00000000 00:09 0          /SYSV00000000 (deleted)
    b5ab9000-b5b19000 rw-s 00000000 00:09 11862039   /SYSV00000000 (deleted)
    b5b19000-b5bb1000 r--p 00000000 08:11 42100      /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
    b5bb1000-b5bb3000 r-xp 00000000 08:11 18012      /usr/lib/pango/1.6.0/modules/
    b5bb3000-b5bb4000 r--p 00001000 08:11 18012      /usr/lib/pango/1.6.0/modules/
    b5bb4000-b5bb5000 rw-p 00002000 08:11 18012      /usr/lib/pango/1.6.0/modules/
    b5bb5000-b5bbb000 r--s 00000000 08:11 107224     /var/cache/fontconfig/945677eb7aeaf62f1d50efc3fb3ec7d8-x86.cache-2
    b5bbb000-b5bbe000 r--s 00000000 08:11 107233     /var/cache/fontconfig/e383d7ea5fbe662a33d9b44caf393297-x86.cache-2
    b5bbe000-b5bc1000 r--s 00000000 08:11 117703     /var/cache/fontconfig/6eb3985aa4124903f6ff08ba781cd364-x86.cache-2
    b5bc1000-b5bc2000 r--s 00000000 08:11 107219     /var/cache/fontconfig/4c73fe0c47614734b17d736dbde7580a-x86.cache-2
    b5bc2000-b5bc5000 r--s 00000000 08:11 107225     /var/cache/fontconfig/a755afe4a08bf5b97852ceb7400b47bc-x86.cache-2
    b5bc5000-b5bcc000 r--s 00000000 08:11 126177     /var/cache/fontconfig/6d41288fd70b0be22e8c3a91e032eec0-x86.cache-2
    b5bcc000-b5bcf000 r--s 00000000 08:11 107231     /var/cache/fontconfig/de156ccd2eddbdc19d37a45b8b2aac9c-x86.cache-2
    b5bcf000-b5bd7000 r--s 00000000 08:11 107234     /var/cache/fontconfig/e3de0de479f42330eadf588a55fb5bf4-x86.cache-2
    b5bd7000-b5be2000 r--s 00000000 08:11 107214     /var/cache/fontconfig/0f34bcd4b6ee430af32735b75db7f02b-x86.cache-2
    b5be2000-b5be4000 r--s 00000000 08:11 107230     /var/cache/fontconfig/ddd4086aec35a5275babba44bb759c3c-x86.cache-2
    b5be4000-b5be5000 r--s 00000000 08:11 107217     /var/cache/fontconfig/4794a0821666d79190d59a36cb4f44b5-x86.cache-2
    b5be5000-b5c07000 r--s 00000000 08:11 122586     /var/cache/fontconfig/365b55f210c0a22e9a19e35191240f32-x86.cache-2
    b5c07000-b5c0e000 r--s 00000000 08:11 107228     /var/cache/fontconfig/d52a8644073d54c13679302ca1180695-x86.cache-2
    b5c0e000-b5c14000 r--s 00000000 08:11 107213     /var/cache/fontconfig/089dead882dea3570ffc31a9898cfb69-x86.cache-2
    b5c14000-b5c1b000 r--s 00000000 08:11 120311     /var/cache/fontconfig/e13b20fdb08344e0e664864cc2ede53d-x86.cache-2
    b5c1b000-b5c1d000 r--s 00000000 08:11 122587     /var/cache/fontconfig/7ef2298fde41cc6eeb7af42e48b7d293-x86.cache-2
    b5c1d000-b5c21000 r--s 00000000 08:11 35395      /home/kev/.fontconfig/7d19654197fba6a1bdf14444e1602296-x86.cache-2
    b5c21000-b5c22000 r-xp 00000000 08:11 28280      /usr/lib/mdp/
    b5c22000-b5c23000 rw-p 00000000 08:11 28280      /usr/lib/mdp/
    b5c23000-b5c24000 r-xp 00000000 08:11 28284      /usr/lib/mdp/
    b5c24000-b5c25000 rw-p 00001000 08:11 28284      /usr/lib/mdp/
    b5c25000-b5c26000 r-xp 00000000 08:11 28278      /usr/lib/mdp/
    b5c26000-b5c27000 rw-p 00000000 08:11 28278      /usr/lib/mdp/
    b5c27000-b5c28000 r-xp 00000000 08:11 28301      /usr/lib/mdp/
    b5c28000-b5c29000 rw-p 00001000 08:11 28301      /usr/lib/mdp/
    b5c29000-b5c2a000 r-xp 00000000 08:11 26928      /usr/lib/mdp/
    b5c2a000-b5c2b000 rw-p 00000000 08:11 26928      /usr/lib/mdp/
    b5c2b000-b5c2e000 r-xp 00000000 08:11 26292      /usr/lib/mdp/
    b5c2e000-b5c2f000 rw-p 00002000 08:11 26292      /usr/lib/mdp/
    b5c2f000-b5c31000 r-xp 00000000 08:11 26861      /usr/lib/mdp/
    b5c31000-b5c32000 rw-p 00001000 08:11 26861      /usr/lib/mdp/
    b5c32000-b5c34000 r-xp 00000000 08:11 27260      /usr/lib/mdp/
    b5c34000-b5c35000 rw-p 00001000 08:11 27260      /usr/lib/mdp/
    b5c35000-b5c36000 r-xp 00000000 08:11 28275      /usr/lib/mdp/
    b5c36000-b5c37000 rw-p 00001000 08:11 28275      /usr/lib/mgens:1:gens_sighandler(): Signal 6 (SIGABRT) received. Shutting down.
    The custom resolution settings worked fine for me in milestone 6. But here it crashes if I put in anything other than the pre-defined OpenGL resolutions that are already listed in the options menu.

    Other than those two problems, everything else seems to be working pretty well so far.

  4. #4
    Join Date
    Oct 2008

    Re: Gens/GS r7_pre2 - Preview Release

    Quote Originally Posted by mocha View Post
    Do you still use the site I just happened to come across this post by accident but was always trying to follow the development of gens at the sonicretro site.
    I haven't updated the Gens/GS page on Sonic Retro yet, since this is a preview release. It will probably be updated sometime later this week.

    Quote Originally Posted by mister_k81 View Post
    *** stack smashing detected ***: gens terminated
    I reproduced this on my local system using the debug build, which has stack smashing prevention enabled. Seems like something's wrong with the OpenGL resolution dialog. I'll take a look at it and try to fix it.

    EDIT: Fixed in commit 2d86a7ff4a1cdc594c6deaa961a9bdd56eb82402: http://gs_server.gerbilsoft.ddns.inf...de785849b66c80
    Last edited by GerbilSoft; July 29th, 2009 at 09:28 AM. Reason: Fixed a stack-smash bug.

  5. #5
    Join Date
    May 2007
    Sheffield, UK

    Re: Gens/GS r7_pre2 - Preview Release

    Same here. First I deleted the .gens folder as mentioned above, then tried to set a custom resolution of 1440x900 for my monitor, but it crashed with

    Gens/GS has crashed with Signal 6.
    SIGABRT: Aborted.
    And now I get that whenever I start it. Hope this helps.
    AMD Phenom X4 945, 4Gb Crucial 800Mhz DDR2 RAM, 1Tb SATA III HDD, AMD Radeon R7 250X

  6. #6
    Join Date
    Jun 2007
    Rio de Janeiro - Brasil
    Kubuntu Development Release

    Re: Gens/GS r7_pre2 - Preview Release

    Thank you very much!! =)

  7. #7
    Join Date
    Oct 2008

    Re: Gens/GS r7_pre2 - Preview Release

    I fixed the problem. If you're compiling from source, you can apply this patch:

    commit 2d86a7ff4a1cdc594c6deaa961a9bdd56eb82402
    Author: David Korth <>
    Date:   Wed Jul 29 04:18:21 2009 -0400
        [GTK+] gens_window_sync.cpp: Fixed an off-by-one in Sync_Gens_Window_GraphicsMenu().
        If a custom resolution was set, the custom resolution code ended up writing
        past the end of sCustomRes[], resulting in a stack smash.
        This bug was reported by mister_k81 on the Ubuntu Forums:
    diff --git a/src/gens/ui/gtk/gens/gens_window_sync.cpp b/src/gens/ui/gtk/gens/gens_window_sync.cpp
    index e89bda1..7924169 100644
    --- a/src/gens/ui/gtk/gens/gens_window_sync.cpp
    +++ b/src/gens/ui/gtk/gens/gens_window_sync.cpp
    @@ -303,7 +303,7 @@ void Sync_Gens_Window_GraphicsMenu(void)
     		// Custom resolution. Set the text.
     		char sCustomRes[32];
     		snprintf(sCustomRes, sizeof(sCustomRes), "Custom... (%dx%d)", Video.GL.width, Video.GL.height);
    -		sCustomRes[sizeof(sCustomRes)] = 0x00;
    +		sCustomRes[sizeof(sCustomRes)-1] = 0x00;
     		gtk_label_set_text(GTK_LABEL(gtk_bin_get_child(GTK_BIN(mnuGLResCustom))), sCustomRes);

  8. #8
    Join Date
    Jun 2007
    Rio de Janeiro - Brasil
    Kubuntu Development Release

    Re: Gens/GS r7_pre2 - Preview Release

    It crashes on my system when I switch to fullscreen while using the sdl+opengl backend. When I switch to the SDL backend it runs just fine but I can't get any filter to work on fullscreen =/

    Here's the error message:

    Gens/GS has crashed with Signal 11.
    SIGSEGV: Segmentation fault.
    I'm running it on Ubuntu Jaunty 32bit, nVIDIA 8800GS card with the latest beta drivers installed and compiz-fusion running.

  9. #9
    Join Date
    Oct 2007
    Canuck Land
    Ubuntu 12.10 Quantal Quetzal

    Arrow Re: Gens/GS r7_pre2 - Preview Release

    Quote Originally Posted by GerbilSoft View Post
    I fixed the problem. If you're compiling from source, you can apply this patch:
    It took me a while to figure out how to patch this (I have very limited experience with compiling code), but I eventually did manage to get both patches to work ...

    Anyway, I built it from source and installed with checkinstall, and the custom resolution bug seems to be fixed now. Also, this version of GensGS doesn't crash anymore if I use my old .gens config folder (from release 6). I'm guessing that the custom resolution listed in the gens.cfg file was making it crash on start up.

    However, I also noticed another issue... while running in a custom resolution, Genesis games only seem to run at 30fps. But this only happens if I run in either 15 or 32 bits per pixel mode with "full stretch" turned on. Turning off full stretch will make games run at 60fps again. But, using full stretch in 16bpp mode has little to no effect to the framerate at all. This problem wasn't there for me in milestone 6.


    OK, I should also add something else, that the frame rate issue seems to happen when I have VSync and "Full Stretch" on at the same time while running in either 15bpp or 32bpp with a custom resolution.
    Last edited by mister_k81; July 30th, 2009 at 04:09 AM.

  10. #10
    Join Date
    Jan 2007

    Re: Gens/GS r7_pre2 - Preview Release

    lots of really great updates in this one. i'll have to try it out.
    Linux User #440528
    openSUSE 12.1 x86_64/KDE 4.8.4


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts