Results 1 to 10 of 10

Thread: Need help changing metric

Threaded View

  1. #1
    Join Date
    Jul 2009

    Question Need help changing metric

    I am trying out Ubuntu 9.04 and am new to the linux sceen. I have been able to get it connected to my wireless router (didn't work out of the box), and even now have it working with my usb EVDO aircard. My problem is that I can't get internet though the usb modem when the wireless is connected to my local network. I have had similar problems before with windows and solved the problem by manually changing the metric of the network adaptors. Below is what I have tried so far without success.

    From the terminal- "sudo ifconfig wlan0 metric 20"
    Result- "SIOCSIFMETRIC: Operation not supported"
    I get the same result when trying to change the metric on any interface.

    Added this to the etc/network/interfaces file-
    auto wlan0
    iface inet wlan0 static
    metric 20

    Result- wlan0 remains in dhcp mode and gets its ip address from the router and the metric remains at 1. It doesn't seem to look at the interfaces file.

    I would really like to be able to change the metric from the command line if possible, so that way I could put it in a .sh file and run it when I want to use the usb modem (since I have to start the modem manually anyway). But I would be happy if I could get the interfaces file to work too.
    Last edited by maximus57; July 27th, 2009 at 04:49 AM. Reason: changed wording


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts