Page 53 of 64 FirstFirst ... 343515253545563 ... LastLast
Results 521 to 530 of 637

Thread: HOWTO: Set up VNC server with resumable sessions

  1. #521
    Join Date
    Sep 2008
    Beans
    3

    Re: HOWTO: Set up VNC server with resumable sessions

    i am trying to set up ubuntu as a headless server, and i am having trouble accessing it remotely via vnc. i remember before i ran through the setup, vnc would work through vino, however, without a monitor plugged in, i could not change the resolution. anyways, i ran though the guide here, and when i try to access the server from my windows box, i get this error.

    Code:
    connection failed - error reading protocol version
    
    possible causes:
    
    - you've forgotten to select a DSMPlugin and the server uses a DSMPlugin
    - Viewer and server are not compatible (they use different RFB protocoles)
    - bad connection
    if it is indeed that my viewer (ultraVNC) is not compatible, do you guys know of a windows viewer that is compatible?

    thanks in advance for any help

  2. #522
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: HOWTO: Set up VNC server with resumable sessions

    How do you enable the loopback for vnc4server? It's needed when connecting over ssh.

    Thanks.

  3. #523
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: HOWTO: Set up VNC server with resumable sessions

    Hi,

    following some advice earlier to test this thing I am getting this error

    Code:
    Xvnc Free Edition 4.1.1
    Copyright (C) 2002-2005 RealVNC Ltd.
    See http://www.realvnc.com for information on VNC.
    Underlying X server release 70000000, The X.Org Foundation
    
    
    Wed Sep  3 00:24:12 2008
     vncext:      VNC extension running!
     vncext:      Listening for VNC connections on port 5902
     vncext:      created VNC server for screen 0
    Could not init font path element /usr/share/X11/fonts/misc, removing from list!
    
    Fatal server error:
    could not open default font 'fixed'
    pokeymon@pokeymon:~$

    This is the command I run

    Code:
     sudo /usr/bin/Xvnc :2 -query localhost -geometry 1024x768 -depth 16 -once -fp /usr/share/X11/fonts/misc -DisconnectClients=0 -NeverShared passwordFile=/root/.vncpasswd
    I am also getting lots of those errors in syslog
    Code:
    Sep  3 00:02:23 pokeymon xinetd[12445]: warning: can't get client address: Transport endpoint is not connected
    Sep  3 00:02:23 pokeymon xinetd[12446]: warning: can't get client address: Transport endpoint is not connected
    Sep  3 00:02:23 pokeymon xinetd[12447]: warning: can't get client address: Transport endpoint is not connected
    Sep  3 00:02:23 pokeymon xinetd[12448]: warning: can't get client address: Transport endpoint is not connected
    Sep  3 00:02:23 pokeymon xinetd[12449]: warning: can't get client address: Transport endpoint is not connected
    How can i solve this.


    Edit:

    following this link http://www.movingtofreedom.org/2007/...dgy-gnu-linux/

    in /etc/xinetd.d/Xvnc

    I changed this line...

    Code:
    server_args = -inetd :1 -query localhost -geometry 1024x768 -depth 16 -once -fp /usr/share/X11/fonts/misc -DisconnectClients=0 -NeverShared passwordFile=/root/.vncpasswd
    to this

    Code:
    server_args = -inetd :1 -query localhost -geometry 1024x768 -depth 16 -once -fp /usr/share/fonts/X11/misc -DisconnectClients=0 -NeverShared passwordFile=/root/.vncpasswd -extension XFIXES
    NB: the -extension XFIXES at the end... i could not get it to work without that.
    As well as the font path...there is a subtle change there as well.
    Last edited by sefs; September 3rd, 2008 at 06:53 AM.

  4. #524
    Join Date
    May 2005
    Beans
    75
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set up VNC server with resumable sessions

    Your fonts path is incorrect. See post #458 in this thread for updated setup instructions.

    The font path should be: /usr/share/fonts/X11/misc
    Last edited by popie; September 3rd, 2008 at 06:21 AM.

  5. #525
    Join Date
    Dec 2005
    Beans
    113

    Re: HOWTO: Set up VNC server with resumable sessions

    @jon.breakdesign

    Thanks for your post. I had the same error messages. I tried a series of policy changes, but could not get it working.

    However, I found this easy solution:
    Code:
    sudo adduser USER netdev
    sudo /etc/init.d/dbus restart
    http://www.mail-archive.com/debian-b...msg102963.html

    Which I think essentially has the same effect (setting the user's policies correctly).

    Thanks

    Quote Originally Posted by jon.breakdesign View Post
    Hi Guys

    Finally got vnc working nicely in hardy.

    I also had the theme change errors.

    When i looked in ~/.xsession-errors i see....

    ** (nm-applet:15671): WARNING **: <WARN> nma_dbus_init(): could not acquire its service. dbus_bus_acquire_service() says: 'Connection ":1.314" is not allowed to own the service "org.freedesktop.NetworkManagerInfo" due to security policies in the configuration file'


    Now I'm not sure if I'm talking rubbish here but authorizations [system->administration->auhorizations] generally isn't set up to allow certain stuff to happen when you are not logged in on a local terminal....which you don't have when you are logged in via Xvnc....its remote...so..

    anyway to cut a long story short I messed around in the authorizations tab [system->administration->auhorizations] (you are going to need to do this for stuff like HAL too otherwise you won't be able to mount usb drives in gnome over vnc) and also under the gnome tab in there..you should change the settings to change system settings to allow anyone with admin authentication if you want the policykit unlock boxes not to be grayed out over vnc

    and then i also installed the .debs for vnc4server from this url as mentioned on the previous page..

    http://www.francescosantini.com/inde...=linux&lang=en


    and that was it..everything worked from there....so for me changing authorization policies and installing those debs sorted out performance and also that theme and usb mount problems...


    Notes: My /etc/xinetd.d/Xvnc file has the following lines to it:

    service Xvnc
    {
    type = UNLISTED
    disable = no
    socket_type = stream
    protocol = tcp
    wait = yes
    user = root
    server = /usr/bin/Xvnc
    server_args = -inetd :1 -query localhost -geometry 1024x768 -depth 16 -once -fp /usr/share/fonts/X11/misc -DisconnectClients=0 -NeverShared passwordFile=/root/.vncpasswd -extension XFIXES
    port = 5901
    }

    @mediajunkie I know this is a really n00b silly question but on hardy you are allowing the port your vnc service is to run on through your firewall?

    oh lastly if you don't feel like plugging the monitor back in and logging in on the local console again, and want to change a bunch of stuff under authorizations that you are not authorized to change under your account on a non local terminal (even if you are an admin) then very briefly enable the root account log in as root over vnc change what you have to and disable the account again.

  6. #526
    Join Date
    May 2007
    Beans
    5

    Re: HOWTO: Set up VNC server with resumable sessions

    I am getting the common problem, when I enter

    Code:
    vncviewer localhost:1
    I get the output:

    "VNC Viewer Free Edition 4.1.1 for X - built Apr 16 2008 13:02:40
    Copyright (C) 2002-2005 RealVNC Ltd.
    See http://www.realvnc.com for information on VNC.

    Sat Sep 6 03:18:07 2008
    CConn: connected to host localhost port 5901
    main: read: Connection reset by peer (104)"

    And get a pop up error message saying "read: Connection reset by peer (104)".

    I followed the instructions exactly and I'm getting really frustrated because I can't figured this out. Also I am running 8.04 Hardy Heron if that helps. Any help is GREATLY appreciated, thanks!

  7. #527
    Join Date
    Feb 2008
    Beans
    12

    Re: HOWTO: Set up VNC server with resumable sessions

    Same problem as above, have followed this guide to the letter and the box is just refusing connections. I can VNC to it just fine when it's logged in but not to GDM

    I've tried several different things from around the net with no success, I also noticed that when you enable XDMCP through the menu's it is still set as "enabled = false" in /etc/gdm/gdm.conf

    Any help would be greatly appreciated, this is basically a fresh install and it's the last thing I need to get working!

  8. #528
    Join Date
    May 2005
    Beans
    75
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set up VNC server with resumable sessions

    @Dethecus, If you followed the first post in this thread, it won't work. Many things have changed since this thread began.

    I listed the entire process, step by step, that works for me (every time) in the following post in this thread:

    http://ubuntuforums.org/showpost.php...&postcount=458

  9. #529
    Join Date
    Feb 2008
    Beans
    12

    Re: HOWTO: Set up VNC server with resumable sessions

    Quote Originally Posted by popie View Post
    @Dethecus, If you followed the first post in this thread, it won't work. Many things have changed since this thread began.

    I listed the entire process, step by step, that works for me (every time) in the following post in this thread:

    http://ubuntuforums.org/showpost.php...&postcount=458
    Well I just tried those steps of yours exactly on both my Ubuntu computers and it didn't work on either =\

    Still getting connection refused.

  10. #530
    Join Date
    Sep 2008
    Beans
    1

    Re: HOWTO: Set up VNC server with resumable sessions

    @popie - thank you so much for the tutorial, it works like a charm!

    however is there a way to have concurrent VNC connections? like multiple connections with the same username so people share the desktop without having to log off, right now when i try to login again with the same username it says "VNC authentication faild!"
    thank you!

Page 53 of 64 FirstFirst ... 343515253545563 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •