Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Trouble installing FF 3.5 - script causes an error

  1. #1
    Join Date
    Aug 2006
    Beans
    3

    Trouble installing FF 3.5 - script causes an error

    here's my output for the area in question:

    Resolving releases.mozilla.org... 155.98.64.83, 204.246.0.136, 64.50.236.52, ...
    Connecting to releases.mozilla.org|155.98.64.83|:21... connected.
    Logging in as anonymous ... Logged in!
    ==> SYST ... done. ==> PWD ... done.
    ==> TYPE I ... done. ==> CWD /pub/mozilla.org/firefox/releases/3.5.1/linux-i686/en-US ...
    No such directory `pub/mozilla.org/firefox/releases/3.5.1/linux-i686/en-US'.

    wget -c --tries=5 --read-timeout=20 --waitretry=10 ftp://releases.mozilla.org/pub/mozil...-3.5.1.tar.bz2
    Previous command has failed to complete successfully. Exiting.
    Process returned code 1
    Traceback (most recent call last):
    File "/usr/local/bin/ubuntuzilla.py", line 1151, in <module>
    bs.start()
    File "/usr/local/bin/ubuntuzilla.py", line 211, in start
    fi.start()
    File "/usr/local/bin/ubuntuzilla.py", line 238, in start
    self.install()
    File "/usr/local/bin/ubuntuzilla.py", line 604, in install
    self.downloadPackage()
    File "/usr/local/bin/ubuntuzilla.py", line 773, in downloadPackage
    self.util.robustDownload(argsdict={'executionstrin g':"wget -c --tries=5 --read-timeout=20 --waitretry=10 ftp://" + "%mirror%" + self.options.package + "/releases/" + self.releaseVersion + "/linux-i686/"+ self.locList[self.locChoice] + "/" + self.packageFilename, 'includewithtest':True})
    File "/usr/local/bin/ubuntuzilla.py", line 155, in robustDownload
    self.execSystemCommand(**argsdict)
    File "/usr/local/bin/ubuntuzilla.py", line 141, in execSystemCommand
    print >>sys.stderr, result
    NameError: global name 'result' is not defined

    Any ideas?

  2. #2
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble installing FF 3.5 - script causes an error

    Hi

    thanks for reporting this!

    yes, ideas - made a stupid mistake in my last revision

    here, grab this latest version from this bug tracker thread:
    https://sourceforge.net/tracker/?fun...89&atid=982990

    (.deb listed under file attachments)

    it fixes this bug, as well as a couple of others.

  3. #3
    Join Date
    Jul 2008
    Location
    Wichita, KS, USA
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Trouble installing FF 3.5 - script causes an error

    I was unable to open the new .deb file. "ubuntuzilla-4.6.2-0ubuntu1-i386.deb" still works just fine, but 4.6.3 gave me an error in gdebi. Archive Manager handled it fine though.

  4. #4
    Join Date
    Jan 2009
    Location
    UK and Netherlands
    Beans
    15
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Trouble installing FF 3.5 - script causes an error

    I get the same problem with Gdebi installer, but I haven't managed to work around it using archive manager, can anyone suggest how to get it to install with GDebi? I have changed the permissions on the file but no luck.

    I get the following notice...

    "The package may be corrupted or you are not allowed to open the file. Check the permissions of the file"

    Thanks

  5. #5
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble installing FF 3.5 - script causes an error

    hmm, maybe the bug tracker has corrupted the file on upload...
    you could grab the latest source snapshot from the git repository, unzip it, and from within that directory run "python build-distribution.py", which will build a .deb for you from the sources.

    not at my comp right now, but will try to do the same in a bit and attach the .deb here.

  6. #6
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Trouble installing FF 3.5 - script causes an error

    Ok, it does look like the packages attached to that bug tracker are corrupted.

    Here are some fresh-built uncorrupted packages, attached, along with their md5sums.

  7. #7
    Join Date
    Jul 2009
    Beans
    1

    Re: Trouble installing FF 3.5 - script causes an error

    Thanks, I was having the same issue but this update worked perfectly. I'm posting this using FF 3.5.1 now!

  8. #8
    Join Date
    Apr 2007
    Beans
    5
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Talking Re: Trouble installing FF 3.5 - script causes an error

    Thanks, i had the same problem and 4.6.3 worked great

  9. #9
    Join Date
    Jul 2008
    Location
    Wichita, KS, USA
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Trouble installing FF 3.5 - script causes an error

    Worked perfectly, thanks very much!

  10. #10
    Join Date
    Jan 2009
    Location
    UK and Netherlands
    Beans
    15
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Trouble installing FF 3.5 - script causes an error

    Worked perfectly for me too, many thanks.

    I still have Shiretoko but I can cope with that for a few months until the next Ubuntu comes out.


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •