Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Error while installing graphics driver: ./default_policy.sh does not support version

  1. #1
    Join Date
    Apr 2007
    Beans
    8

    Error while installing graphics driver: ./default_policy.sh does not support version

    Hi,
    I installed 9.04 on a HP t5730 Thin Client.

    As soon as I'm logged in to the OS I have graphic errors.
    This Thin Client has a ATI X1250 graphics chip.

    Therefore I tried to install the ATI driver which I downloaded from the web.
    But during the installation via the Gnome terminal I'm getting this error:



    user@ubuntu:~/Desktop$ sh ./ati-driver-installer-9-3-x86.x86_64.run
    Created directory fglrx-install.FoFMJW
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.593............................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..........................................
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================

    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.28-13-generic; make sure that the version is being
    correctly set by --iscurrentdistro


    Removing temporary directory: fglrx-install.FoFMJW
    user@ubuntu:~/Desktop$ --iscurrentdistro
    bash: --iscurrentdistro: command not found
    user@ubuntu:~/Desktop$ iscurrentdistro
    bash: iscurrentdistro: command not found
    user@ubuntu:~/Desktop$ -iscurrentdistro
    bash: -iscurrentdistro: command not found
    user@ubuntu:~/Desktop$




    What can I do?

  2. #2
    Join Date
    Jun 2009
    Location
    i live in the location
    Beans
    116
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    have the same prob right now :S

  3. #3
    Join Date
    Apr 2007
    Beans
    8

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    I've found this thread on the german Ubuntu forums:
    http://forum.ubuntuusers.de/topic/at...st-sich-nicht/

    According to this thread It seems like the Kernel and the XServer of Ubuntu 9.04 are too new for this ATI driver.
    Only ATI Catalyst 9.5 will support the Kernel and XServer of Ubuntu 9.04.


    So does that mean we could only use an older version of Ubuntu?

    Would be good if somebody can confirm this as I'm a Linux beginner...

  4. #4
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    Yes, you need to use and older version of ubuntu to use a driver from ati that will work with the x1250. But....many people are very happy using the open source ati and raden drivers with that card so you should try them out before doing anything drastic.
    PMs will be ignored.

  5. #5
    Join Date
    Oct 2009
    Beans
    1

    Lightbulb Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    I don't remember where i read this but i think u can just downgrade xorg to allow for proper install w/o errors, I know i wouldnt want to to sacrafice my 9.04 installation. That would make me .

  6. #6
    Join Date
    May 2007
    Location
    Virginia, USA
    Beans
    13,298
    Distro
    Ubuntu Mate Development Release

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    Couple of points of interest ...

    You CAN downgrade the Xorg to allow installation of ATI restricted Linux drivers -- but when you do that, you have to "lock" a whole bunch of files to prevent them ever getting updated again. This prevents you from benefiting from any Xorg updates after that.

    Also, the latest Catalyst version that works with the discontinued cards is "legacy 9.8" -- for MS Windows. That superceded v9.3 with some critical patches. But last time I checked, Catalyst 9.3 for Linux had not been updated for legacy cards.

    Nothing newer than Catalyst 9.3 (except for the "Legacy 9.8") will work with the default Xorg in Ubuntu 9.04 -- and newer. Downloading and forcing a newer driver version will only render the display unusable and you will have to manually remove the driver and restore the open source driver to get your desktop back.
    Ubuntu 17.10 Mate, Mint 18.3 Mate; MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  7. #7
    Join Date
    Apr 2008
    Beans
    8

    Red face Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    WTF i can't believe that??? Why the f**** hast ATI support been (factical) dropped with Karmic?

  8. #8
    Join Date
    Jun 2010
    Beans
    1

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    Try a 'compapibility mode':

    ./ati-driver-installer-9-3-x86.x86_64.run --listpkg

    then, chose one and try:

    ./ati-driver-installer-9-3-x86.x86_64.run --buildpkg Ubuntu/8.10

    Bruno Lemos

  9. #9
    Join Date
    May 2007
    Location
    Virginia, USA
    Beans
    13,298
    Distro
    Ubuntu Mate Development Release

    Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    Bruno Lemos:

    Why are you resurrecting a six-month-old thread?

    Also, your advice specified Ubuntu 8.10 -- but the OP specifically mentioned using 9.04.

    Have you actually tried this hack and confirmed it works in 9.04?
    Ubuntu 17.10 Mate, Mint 18.3 Mate; MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  10. #10
    Join Date
    Aug 2010
    Location
    Banja Luka
    Beans
    19
    Distro
    Ubuntu 10.04 Lucid Lynx

    Wink Re: Error while installing graphics driver: ./default_policy.sh does not support vers

    Quote Originally Posted by brunolemos View Post
    Try a 'compapibility mode':

    ./ati-driver-installer-9-3-x86.x86_64.run --listpkg

    then, chose one and try:

    ./ati-driver-installer-9-3-x86.x86_64.run --buildpkg Ubuntu/8.10

    Bruno Lemos
    Thanks Dude!!! Its working on my pc ...

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •