Results 1 to 3 of 3

Thread: sensors in xfce premission issue

  1. #1
    Join Date
    Jul 2009
    Beans
    5
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Exclamation sensors in xfce premission issue

    since i came to a conclusion the shutdown i experienced occurred due to overheating i decided to add the sensors toolbar, yet to no avail:
    i got this error while adding it to me toolbar:

    "hddtemp" was not executed correctly, although it is executable. This is most probably due to the disks requiring root privileges to read their temperatures, and "hddtemp" not being setuid root.

    An easy but dirty solution is to run "chmod u+s /usr/sbin/hddtemp" as root user and restart this plugin or its panel.

    Calling "/usr/sbin/hddtemp -n -q /dev/sda" gave the following error:
    /dev/sda: Permission denied

    with a return value of 0.

  2. #2
    Join Date
    Jun 2009
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: sensors in xfce premission issue

    You can run
    Code:
    sudo chmod u+s /usr/sbin/hddtemp
    and then restart. Like the error says it's crude but works. This is what I ended up doing for my sensors applet. You may also want to run sensors-detect with sudo to get all the sensors information if you haven't already.

  3. #3
    Join Date
    Jul 2009
    Beans
    5
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: sensors in xfce premission issue

    i ran that cmd, and eventually after running detect i found out there are no drivers for my cpu sensors and i cannot see the cpu temp although vista did show these stats...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •