Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

  1. #1
    Join Date
    Oct 2008
    Location
    Rochester, NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Question Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    I Googled around a fair amount, and dug through various settings before posting this, so forgive me if this has already been asked.
    Here's what happens:
    I have Firefox open with a number of tabs, and/or windows. Without closing Firefox, I logout of(or shutdown) Ubuntu(which automatically closes Firefox). I then log back in, and click the Firefox icon. It opens up with the tabs and windows I had open when I previously logged out. This is in contrast to when Firefox crashes or is killed forcefully, as it will prompt me whether or not I want to restore the previous tabs/windows. It is also different from when I manually close Firefox with multiple tabs open, as it gives me an option of saving the tabs.

    Put simply, when I logout of Ubuntu while Firefox is open, it automatically acts as though the "Save and Quit" option has been chosen. I have verified that this is the default behavior on a clean install of Ubuntu, and not the result anything settings I have changed.

    What I would like to do, is have it, on logout/shutdown, act as though the "Quit" option had been chosen.

  2. #2
    Join Date
    Dec 2007
    Location
    Philadelphia
    Beans
    75
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    If it isn't broken, let's fix it anyways. What else are we going to do, seriously?

  3. #3
    Join Date
    Oct 2008
    Location
    Rochester, NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    Quote Originally Posted by yeaitsdark View Post
    Sorry, it did not. Under preferences, "When Firefox starts:" is already set to "Show my Home Page", on both my regular computer, and the clean install on a spare computer.

    To clarify, I'm wanting to change what is apparently a default behavior of Ubuntu.
    Last edited by LucasHenderson; July 12th, 2009 at 02:45 AM.

  4. #4
    Join Date
    Dec 2007
    Location
    Philadelphia
    Beans
    75
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    All right. I just underwent the process to be in your position.

    I have resolved it by doing the following. In a new tab, open the address
    Code:
    about:config
    Accept "I'll be careful I promise"

    We will change 3 values here. There is a filter bar to make this easy.

    First type, "warnon". Double click these two lines line to make them say TRUE. (If already True, leave them)
    Code:
    browser.tabs.warnOnClose: true
    Code:
    browser.warnOnQuit: true
    Second, clear the filter and type: startup.page. Change this value to 1.
    Code:
    browser.startup.page: 1
    If it isn't broken, let's fix it anyways. What else are we going to do, seriously?

  5. #5
    Join Date
    Oct 2008
    Location
    Rochester, NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown





    Thanks, but I just checked(and double-checked) about:config; the preferences you mentioned are all already set set to their default values, the ones you posted.

    Here's the steps to replicate the behavior I'm speaking of:
    1. Login to Ubuntu.
    2. Open Firefox.
    3. Open a few tabs. For testing, I used Google, Yahoo, and MSN.
    4. Go to the upper-right corner of the screen, where it has your name, drag down the menu, and choose "Log Out".
    5. Login to Ubuntu.
    6. Open Firefox.
    7. Observe as Firefox opens with the same tabs from before, in this case, Google, Yahoo, and MSN.

  6. #6
    Join Date
    Dec 2007
    Location
    Philadelphia
    Beans
    75
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    Humm... I will do more research. For details, which version of Ubuntu are you using? Which version of Firefox are you using?

    (Help > About)

    Mine is 3.0.11

    Also, just a guess - try setting the
    Code:
    browser.startup.page: 1
    to 2 (3 was what was forcing the save on close, hence 1 was working for me but the site suggested 1 or 2).

    Also, close Firefox after this change, and it should prompt you to "Quit/Save and Close/Cancel". You would chose "Quit" and if the check mark is checked, this would become the new default action.

    Instead of logging out of your user account, simply close and re-open only Firefox. (File > Exit). Logging out completely vs closing the application will often cause the new values not to come into play because it has a sort of safety switch for crashes.

    I believe that has something to do with it. In the mean time I'll look into it more, I'm only surprised because I just tested that and it worked rather nicely.

    However, I was playing around setting the options to "false" then closing Firefox. Then setting them back to "true", which MAY have had something to do with "resetting" the values in some way. (I doubt this but worth a shot ya?)

    Try these things, and then yea get back to me. In the meantime however I will do more searching.
    If it isn't broken, let's fix it anyways. What else are we going to do, seriously?

  7. #7
    Join Date
    Oct 2008
    Location
    Rochester, NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    I'm having no problem when closing firefox regularly. It's always prompted me then, just as it should. I wasn't logging out because of any changes I've made. I was logging out because the problem I'm talking about only occurs when I'm logging out. Follow the steps I provided earlier, and you'll see what I mean.

    Rather than continue trying to explain myself. I made a video explaining exactly what I'm talking about.
    http://www.youtube.com/watch?v=AGu_tZFUjKw (You may have to turn your volume up a bunch to hear the audio, sorry)
    Last edited by LucasHenderson; July 12th, 2009 at 01:38 PM.

  8. #8
    Join Date
    Dec 2007
    Location
    Philadelphia
    Beans
    75
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    I watched the video. I do understand what you mean. Simply exiting the Firefox application does not exhibit the same behavior as logging out?

    To be honest I'm quite unsure how to proceed with this one. Perhaps deleting the data for Firefox in your /home folder may remove some persistent setting that is causing this trouble.

    You could accomplish this by issue this command. Do note that this would be all of your personal data associated with your Firefox profile. Bookmarks, cookies etc.
    Code:
    rm -rfd .mozilla/firefox/
    It's all I can really think of, sorry I can't be of more help to you.
    If it isn't broken, let's fix it anyways. What else are we going to do, seriously?

  9. #9
    Join Date
    Oct 2008
    Location
    Rochester, NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    There are no persistent settings. What you saw in the video was a clean install. Prior to me launching firefox in the video, there was no profile.
    It might not even be a setting on Firefox that's causing this. It's some Ubuntu feature, which, when you log out, automatically saves the Firefox tabs that are currently open.
    If I log out of Ubuntu, it saves my tabs, regardless of the settings on Firefox.
    I'm tired of turning on my computer, logging in, starting firefox, and seeing every web page I had open when I last logged out. I've been using Ubuntu and other Linux distros for years. I know many of the ins and outs of Linux. This is just a simple feature that has come to annoy me over the past few months.

    Anyway. I solved the problem, sort of. Not so much solved as circumvented. I couldn't figure out a way to disable the automatic saving while retaining manual saving, which was my original goal, so I just added the following to /etc/gdm/PostSession/Default:
    rm /home/lucas/.mozilla/firefox/[profile folder]/sessionstore.js
    So, basically, if the session save is present on logout, it gets rid of it. The only downside is if I actually want it to save my tabs prior to logging out, then too bad. This is better than just disabling session saving entirely, as at least I will be able to save manually...so long as I don't log out.

  10. #10
    Join Date
    Dec 2008
    Beans
    426

    Re: Disable Automatic Saving of Firefox Tabs on Logout/Shutdown

    Your solution may have more to do with session restore feature than with browser start up pages and warning dialog boxes. In about:config, type "session" into filter and change this value:

    browser.sessionstore.resume_from_crash to false.
    See if that helps.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •