Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 9.04 Dell XPS m1530 Wireless Fix

  1. #1
    Join Date
    Jul 2008
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    9.04 Dell XPS m1530 Wireless Fix

    I have a Dell XPS m1530 with this wireless card:

    Broadcom Corporation BCM4328 802.11a/b/g/n

    I was having terrible trouble getting the wireless card to even be recognized and operational. There is a switch on the side of the computer which, in Vista, controlled both wireless and bluetooth, but in Ubuntu 9.04 only seemed to control bluetooth.

    After scouring the forums and trying a number of different things I found this web page which has, so far, been the solution to my inability to connect. I've copy/pasted here for clarity.

    Mark Rijckenberg said on 2009-06-14:

    Hi,

    Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

    Then please follow this procedure:

    Step 1: Open Terminal from "Applications->Accessories->
    Terminal"

    Step 2: Run the following commands (copy-paste the lines below into a Terminal, press enter after each line)

    sudo aptitude update
    sudo aptitude dist-upgrade
    sudo aptitude install linux-backports-modules-jaunty

    Step 3: Run the following command

    gksudo gedit /etc/modprobe.d/blacklist.conf

    # Add the following line to /etc/modprobe.d/blacklist.conf:

    blacklist ssb

    Step 4: Run the following command

    gksudo gedit /etc/modules

    # Add the following 2 lines to the /etc/modules file:

    wl
    wl0

    Step 5: Save changes, reboot pc and retest wireless

    Step 6: If wireless still does not work after this reboot, please resend output of the following command:

    sudo lshw -C network; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; uname -a; dmesg | grep ound; dmesg | grep b43; iwconfig

    Regards,

    Mark
    I have no idea if this is the appropriate place for this or not, so please forgive if it isn't. I just wanted to post what worked for me after a tireless search. If, however, I encounter problems with this method I'll let you know in the future.

    Also, if others who actually understand what the commands listed are doing (I don't) and there are problems with this method please do post below.

  2. #2
    Join Date
    Jan 2007
    Beans
    5,549

    Re: 9.04 Dell XPS m1530 Wireless Fix

    post output of the following from the terminal
    1)lshw -C network
    2)iwconfig
    3)sudo iwlist scanning

  3. #3
    Join Date
    Mar 2009
    Location
    Chester, UK
    Beans
    3
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Smile Re: 9.04 Dell XPS m1530 Wireless Fix

    Wow I'm a noob and I managed to get it working. Great post. Thanks

  4. #4
    Join Date
    Jul 2008
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.04 Dell XPS m1530 Wireless Fix

    Dell XPS M1530
    Dual Boot Vista 64-bit / Ubuntu 9.04 64-bit
    Intel Core 2 Duo
    6 GB ram

    There seems to be a problem – perhaps unrelated but I offer it here just in case.

    Wireless had been working flawlessly until this morning. I boot up, no wireless. I reboot and get the following message:

    Could not start the X server (your graphical environment) due to some internal error.
    Please contact your system administrator or check your syslog to diagnose.
    In the meantime this display will be disabled.
    Please restart GDM when the problem is corrected.
    Logging in through recovery and running “fsck” seemed to do the trick, however I'm without wireless access again (and was immediately prior to rebooting and finding the X server problem).

    Below is the requested output (though it's not working anymore):

    1)lshw -C network

    *-network

    description: Ethernet interface

    product: 88E8040 PCI-E Fast Ethernet Controller

    vendor: Marvell Technology Group Ltd.

    physical id: 0

    bus info: pci@0000:09:00.0

    logical name: eth0

    version: 12

    serial: 00:23:ae:00:27:41

    size: 100MB/s

    capacity: 100MB/s

    width: 64 bits

    clock: 33MHz

    capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation

    configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.22 duplex=full firmware=N/A ip=192.168.1.74 latency=0 link=yes module=sky2 multicast=yes port=twisted pair speed=100MB/s

    *-network UNCLAIMED

    description: Network controller

    product: BCM4328 802.11a/b/g/n

    vendor: Broadcom Corporation

    physical id: 0

    bus info: pci@0000:0b:00.0

    version: 03

    width: 64 bits

    clock: 33MHz

    capabilities: pm msi pciexpress bus_master cap_list

    configuration: latency=0

    *-network DISABLED

    description: Ethernet interface

    physical id: 2

    logical name: pan0

    serial: e2:28:0e:cf:ca:bb

    capabilities: ethernet physical

    configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes


    2)iwconfig

    lo no wireless extensions.



    eth0 no wireless extensions.



    pan0 no wireless extensions.


    3)sudo iwlist scanning

    lo Interface doesn't support scanning.



    eth0 Interface doesn't support scanning.



    pan0 Interface doesn't support scanning.
    Any help sincerely appreciated. Not sure if the X server and wireless fix above are related but I have no other theories to entertain. Thanks in advance! KYLE

  5. #5
    Join Date
    May 2008
    Location
    Netherlands
    Beans
    505
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: 9.04 Dell XPS m1530 Wireless Fix

    First thing to do is check if your driver is loaded:

    lsmod | grep wl

    If it isn't do a sudo modprobe wl to load the driver

    If this is the problem you can try find /etc/modprobe.d/ -exec cat {} \; | grep wl to see if the modules is blacklisted (prevented from loading automatically)

  6. #6
    Join Date
    Jul 2008
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.04 Dell XPS m1530 Wireless Fix

    Quote Originally Posted by martinbaselier View Post
    First thing to do is check if your driver is loaded:

    lsmod | grep wl

    If it isn't do a sudo modprobe wl to load the driver

    If this is the problem you can try find /etc/modprobe.d/ -exec cat {} \; | grep wl to see if the modules is blacklisted (prevented from loading automatically)
    lsmod | grep wl produces nothing for output in the terminal

    sudo modprobe wl produces:
    FATAL: Could not open '/lib/modules/2.6.28-13-generic/volatile/wl.ko': No such file or directory

    find /etc/modprobe.d/ -exec cat {} \; | grep wl produces:
    cat: /etc/modprobe.d/: Is a directory

    See 1st post to see what I did in the past to get things working. Thanks very much for your help. KYLE

  7. #7
    Join Date
    Jan 2007
    Beans
    5,549

    Re: 9.04 Dell XPS m1530 Wireless Fix

    have you looked at system->admin->hardware drivers ? if you dont find any try this https://help.ubuntu.com/community/Wi...eisty_No-Fluff

  8. #8
    Join Date
    Jul 2008
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.04 Dell XPS m1530 Wireless Fix

    Shows "Broadcom STA Wireless Driver" but when I activate it it won't turn green and actually activate. Can I do this from the terminal?

    Thanks!

  9. #9
    Join Date
    Jan 2007
    Beans
    5,549

    Re: 9.04 Dell XPS m1530 Wireless Fix

    you may require a wired internet connection for this , it may require you to download some packages

  10. #10
    Join Date
    Aug 2006
    Beans
    Hidden!

    Smile Re: 9.04 Dell XPS m1530 Wireless Fix

    Worked perfectly on my friend's XPS M1530 without any of the later problems. Noted that the dist-upgrade step was essential (and probably a good idea anyway) since I tried it without before just to test. Thank you!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •