Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: HOWTO: Get your Iomega Zip Drive to work

  1. #1
    Join Date
    Dec 2004
    Location
    LV-426
    Beans
    616
    Distro
    Ubuntu 9.10 Karmic Koala

    HOWTO: Get your Iomega Zip Drive to work

    Going through zip drive hell? Unfortunately these devices don't always work 'out-of-the-box' on some Linux systems, but it's nothing a little manual configuration can't fix. Here's a detailed (and substantially revised) how-to for mounting your zip disks in Ubuntu Warty (for Hoary there are a couple of different steps. If you are using Ubuntu Hoary visit the Hoary Tips & Tricks forum). First off, the basics -

    1. Create a mountpoint. The default is /media/zip0. Open up a terminal and type sudo mkdir /media/zip0 . This is the directory which will eventually contain your drive's contents.

    2. (optional) Create a symbolic link '/media/zip' - sudo ln -s /media/zip0 /media/zip . Not strictly necessary, but gives your drive a slightly shorter name to be referenced by.

    3. Establish your drive's device name. This depends on where it is connected. In Linux, IDE devices are named according to the following pattern-

    /dev/hda Primary IDE Controller Master (usually your hard drive)
    /dev/hdb Primary IDE Controller Slave
    /dev/hdc Secondary IDE Controller Master (usually your CD-ROM)
    /dev/hdd Secondary IDE Controller Slave

    Look in Computer>System Configuration>Device Manager. Scroll down to your zip drive and click the 'Advanced' tab. Next to 'block.device' should appear your drive's device name. This will most likely be '/dev/hd*4' (where '*' depends on where your drive is connected according to the above scheme). The '4' here is the partition number. For some reason, Iomega disks formatted with the stock FAT16 filesystem use partition number 4. You can reformat them if you wish (see below), although I don't recommend using any filesystem type other than FAT16 or FAT32. Always use partition 4 on the zip disk for any FAT filesystem, however.

    5. Once you know the device name, edit /etc/fstab - sudo gedit /etc/fstab . This file controls how all your drives are mounted. You need to add a line which looks like this (my drive is the secondary slave, therefore 'hdd') -

    /dev/hdd4 /media/zip0 auto rw,user,noauto,sync 0 0

    (you will notice in Device Manager that the filesystem 'policy' for zip drives is 'auto'. Specifying the actual filesystem used usually produces an error on mounting).

    6. Refresh /etc/fstab - sudo mount -a . A zip drive icon should now appear in Computer>Disks.

    You now need to create a device node for your zip drive in the /dev directory. If you look here you will see a node for device block 'hd*' (your actual zip drive , but not for the partition 'hd*4' (unlike your hard drive(s)). This node is needed in order to mount your disk. It's normally the job of the module 'ide_floppy' (your zip drive's Linux device driver) to create it, but this will only get done if there is a zip disk inserted at boot-up, when the kernel loads all the modules (I don't know if this is a bug, but it's just the way it is). You can, of course, insert one each time before switching your computer on, but if you'd rather not there are a few simple steps you can do to get around this -

    7. To ensure the 'ide_floppy' module is loaded at boot-up add a line 'ide-floppy' (without quotes) to /etc/modules (if you don't mind inserting a zip disk before booting up, skip to step 10 after rebooting at this point).

    8. Tell Ubuntu to create a device node manually during each boot-up by hacking another file - sudo gedit /etc/udev/links.conf . You will need to add a line that looks similar to this -

    # Manually create a zip device.
    M hdd4 b 22 64

    What this line stands for is ' M(ake) hdd4 (a) b(lock device with major number) 22 (and minor number) 64' (your device name, major and minor numbers may differ from mine, of course) . The major and minor numbers for hd*4 are listed under your zip drive's entry in Device Manager (Advanced tab). Once you have the details, insert your line in /etc/udev/links.conf using the syntax above.

    9. Save, exit, and reboot (you will see a message in the 'Loading Modules...' section about a disk not being in a drive. Ignore it. It is of no consequence). Now if you look in /dev you will notice a device node 'hd*4' has magically appeared!

    10. Now insert a zip disk and type mount /dev/hd*4 or mount <your mountpoint>. You will likely get an error message, but don't sweat it - Ubuntu is just 'getting used to' the device that you created manually. You may have to run the 'mount' command a couple of times before you succeed. It's messy, but it works.

    This how-to will work for ATAPI/IDE zip 100 drives (and probably zip 250). The procedure is slightly different for parallel port, SCSI etc., but there are other threads around which cover those. You will also note that your disks won't automount and open a browser window, even if other removable media is set to do so. I don't know why this is so but solutions to this are more than welcome!

    REFORMATTING ZIP DISKS -

    The following is an excellent guide on how to do this using fdisk -

    http://wls.wwco.com/lqh/iomega.php

    Follow it to the point where you write the new partition table to the disk (option 'w') then quit fdisk (and the above guide). Format it to FAT32 by running sudo mkfs -t vfat /dev/hdd4 , or, if possible, use Windows to do this. Using Linux tools to format disk partitions with Windows filesystems can be a bit buggy sometimes. It should work fine, but Windows will often read the filesystem as FAT rather than FAT32 - your call as to whether this is a problem for you.

    You can use Linux filesystems if you want but you are likely to run into problems with the file permissions and be unable to write to your zip disk. Of course, you can try changing them with chmod, but they have a curious habit of returning to their original root user state. It also chops 10MB off the disk's capacity. To avoid these headaches, just use FAT32.

    If you do choose Linux formatting, use ext2, and remember to use partition 1, otherwise your disk won't moun99t. Adjust accordingly for all the above instructions.

    Hope this helps!

    UNMOUNTING YOUR DISK -

    If you have problems ejecting your zip disk make sure you are following the correct procedure for doing so. First off, you need to unmount it -

    umount <YOUR DEVICE NAME> or <MOUNTPOINT>

    Properly unmounting removable media in Linux is necessary to avoid the risk of data loss.

    If you find the above still doesn't work, do what's known as a 'lazy' unmount -

    umount -l <YOUR DEVICE NAME> or <MOUNTPOINT>

    You should now be able to use the 'eject <YOUR DEVICE NAME> or <MOUNTPOINT>' command (or just press the button on your zip drive) and have it do exactly that.
    Last edited by pseudonym; April 27th, 2005 at 05:16 AM.

  2. #2
    Join Date
    Jan 2005
    Beans
    76
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get your Iomega Zip Drive to work

    Hello:

    I followed your instructions to the note, including manually creating the zip device; now I have a hdd4 in my /dev/ list, I have the following line in fstab:

    /dev/hdd4 /media/zip0 auto rw,user,noauto 0 0

    and have rebooted a couple of times. Each time I try to mount the zip drive I get the following error message:

    mount: I could not determine the filesystem type, and none was specified

    I've tried changing the fstab entrey from /dev/hdd4 to /dev/hdd and still doesnt work. In my Disks Folder, I have an entry for "Zip Disk 1" is that one (1) normal? Do I need to change something in the fstab? Include vfat as the only filetype? Please help...

    Camp

  3. #3
    Join Date
    Dec 2004
    Location
    LV-426
    Beans
    616
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Get your Iomega Zip Drive to work

    Hi. The 'Zip Disk 1' entry in Computer > Disks is as it should be. Using 'hdd' as the device name won't do anything, as this refers to the block for your device (like 'hda' for your hard disk). You must always have a partition number for the entry to be valid. Have you checked if you have another device block listed in /dev , such as 'hdb'?

    Assuming you have your device name correct ('hdd4'), your suggestion of manually specifying the filesystem in /etc/fstab sounds like a good one...

  4. #4
    Join Date
    Jan 2005
    Beans
    76
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get your Iomega Zip Drive to work

    Quote Originally Posted by pseudonym
    Hi. The 'Zip Disk 1' entry in Computer > Disks is as it should be. Using 'hdd' as the device name won't do anything, as this refers to the block for your device (like 'hda' for your hard disk). You must always have a partition number for the entry to be valid. Have you checked if you have another device block listed in /dev , such as 'hdb'?

    Assuming you have your device name correct ('hdd4'), your suggestion of manually specifying the filesystem in /etc/fstab sounds like a good one...
    Hi:

    I changed my /etc/fstab entry to include only vfat as the filesystem. My Zip drive is close to working perfectly: it mounts correctly, I can access the files, and I can unmount. the problem comes when I try to eject the Zip-disk. For some bizarre reason, my drive will not eject the zip-disk. If I do a right-click and select "Eject" the drive starts spinning, but will not eject the disk. If I go into a terminal and type:

    eject -v /dev/hdd4

    It will let me know that the drive was unmounted, and the eject CD-Rom process ended successfully, but no Zip disk on sight. Additionally, if I press the botton on the Zip-drive itself, I cant get the disk to eject. I have to restart the computer in order to get the disk.

    Do I have to load any module that will eject the Zip-disK? Is there anything I can twick or modify in order for eject the disk? to answer your question, I do have another Hard-drive which was asssinged the hdb1 partition.

    Thanks, Camp.

  5. #5
    Join Date
    Oct 2004
    Location
    Germany
    Beans
    71

    Re: HOWTO: Get your Iomega Zip Drive to work

    ok.

    now who can tell me how this works for a parallelport ZIP-drive?

    not that I want to use this regularly, but I have one and some ZIP-discs that hold data that I need.

    thanks and regards,
    Carsten

  6. #6
    Join Date
    Dec 2004
    Location
    LV-426
    Beans
    616
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Get your Iomega Zip Drive to work

    Quote Originally Posted by Poldi
    ok.

    now who can tell me how this works for a parallelport ZIP-drive?

    not that I want to use this regularly, but I have one and some ZIP-discs that hold data that I need.

    thanks and regards,
    Carsten
    Hallo,

    I haven't got such a drive but I might still be able to help you a little. I've read that the module you need to add to /etc/modules is 'ppa'. I've also read that parallel port devices (other than printers) have device names which start with 's' (eg. 'sg', 'sd'), and that they always like to use the number 4. Is the drive already connected to your machine? If so, look in your /dev folder for an icon (eg. 'sd4').

    Other than that my howto is probably not much use to you, seeing as we're talking about parallel port now and not ATAPI/IDE. Let us know how you go anyway...
    Last edited by pseudonym; January 27th, 2005 at 07:50 PM.
    AMD Athlon64 X2 5600 on Abit KN9 Ultra nForce 570
    2GB Corsair TwinX DDR2-800
    Gigabyte ATI HD4850 1GB on ASUS PW201 20" WS LCD
    Ubuntu 9.10 64-bit / Wintendo

  7. #7
    Join Date
    Mar 2005
    Beans
    17

    Re: HOWTO: Get your Iomega Zip Drive to work

    I've followed these instrucitons, and I'm still having a bit of trouble. When I go to the computer folder, I have a Zip drive icon. When I click on it, I get the following message:

    mount: I could not determine the filesystem type, and none was specified

    Anyone know how I might be able to correct this?

  8. #8
    Join Date
    Oct 2004
    Location
    Nederland
    Beans
    17

    Re: HOWTO: Get your Iomega Zip Drive to work

    Quote Originally Posted by whell
    I've followed these instrucitons, and I'm still having a bit of trouble. When I go to the computer folder, I have a Zip drive icon. When I click on it, I get the following message:

    mount: I could not determine the filesystem type, and none was specified

    Anyone know how I might be able to correct this?
    Hello,
    Try "sudo modprobe ppa" (for parallel zipdrive's) in a terminal before you mount the zipdrive.
    Try "sudo fdisk -l" in a terminal to see wich device it is, ( /dev/sda1 ?? )
    Install "jazip"
    Run jazip, it wil make an mount directory for you. With jazip you can mount and unmount the zipdrive. If that's working put "ppa" als last line in /etc/modules.
    Go to /system/preferences/sessions and put jazip in it.
    From now on jazip is running everytime you reboot your'e computer, and asking what to do when you have rebooted.
    Wim
    Last edited by WimVriend; March 14th, 2005 at 07:44 PM.

  9. #9
    Join Date
    Dec 2004
    Location
    LV-426
    Beans
    616
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Get your Iomega Zip Drive to work

    Quote Originally Posted by whell
    I've followed these instrucitons, and I'm still having a bit of trouble. When I go to the computer folder, I have a Zip drive icon. When I click on it, I get the following message:

    mount: I could not determine the filesystem type, and none was specified

    Anyone know how I might be able to correct this?
    Is 'auto' listed as the filesystem type in the fstab entry for your zip drive? If that doesn;t work try manually specifying the fs eg. 'vfat'. I don't know why, but some systmes prefer this instead of 'auto'.

    If you are able to mount the drive but still get this message, then don't worry about it. It pops up on my machine sometimes but the drive is still mounted and can be used without problem. One thing I've noticed is that if you mount the zip drive using the mountpoint instead of the device name (especially on the first use during a session) it is less likely to report messages. At least this is the case on my system.

    All this sounds pretty unscientific but the good news is that these problems should no longer exist in Ubuntu's next stable release due in early April. I read somewhere here that support for zip devices will b e better implemented then (at least I hope this is true! )
    AMD Athlon64 X2 5600 on Abit KN9 Ultra nForce 570
    2GB Corsair TwinX DDR2-800
    Gigabyte ATI HD4850 1GB on ASUS PW201 20" WS LCD
    Ubuntu 9.10 64-bit / Wintendo

  10. #10
    Join Date
    Jan 2005
    Location
    Philippines
    Beans
    746

    Re: HOWTO: Get your Iomega Zip Drive to work

    I don't want to troll, but I'm surprised zip drives are still available; the last zip drive i ever used was a 250MB model after that, I switched to flash drives.
    Jerome G.
    Twitter: JeromeGotangco

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •