Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: What version of Firefox should I have?

  1. #1
    oxf is offline Extra Foam Sugar Free Ubuntu
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    What version of Firefox should I have?

    Hi,

    What version of Firefox do I have and what version should I have? About 10 day ago I downloaded and burned a new 9.04 Live CD and installed it.

    It was my impression (wrongly perhaps?) that 9.04 came with FF 3.5? Now looking through Synaptic PKG MGR I see I have various FF 3.0 bits installed but anything to do with 3.5 is not installed.

    Finally to install 3.5 do I need to uninstall 3.0 ones first or will they be upgraded automatically if I install 3.5. Any reason why I should not install 3.5 at this point?

    Thanks

  2. #2
    Join Date
    Jan 2009
    Location
    South Carolina
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: What version of Firefox should I have?

    You should have 3.0.11 I think.

  3. #3
    Join Date
    Sep 2008
    Beans
    164
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: What version of Firefox should I have?

    Any reason why I should not install 3.5 at this point?


    Well I have found firefox 3.5 is kinda buggy. For example when I try to play stuff on like Hulu and try to play full screen, it crashes. Its up to you if you think you should install it.

  4. #4
    Join Date
    Jan 2009
    Location
    South Carolina
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: What version of Firefox should I have?

    I have 3.0.11 and it runs perfectly.

  5. #5
    oxf is offline Extra Foam Sugar Free Ubuntu
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: What version of Firefox should I have?

    Quote Originally Posted by linux_lover69 View Post
    Well I have found firefox 3.5 is kinda buggy. For example when I try to play stuff on like Hulu and try to play full screen, it crashes. Its up to you if you think you should install it.
    Thats one of the things I wmdered about! I know theres a way of checking the version but it escapes me right now.

  6. #6
    oxf is offline Extra Foam Sugar Free Ubuntu
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: What version of Firefox should I have?

    Quote Originally Posted by ubudog View Post
    I have 3.0.11 and it runs perfectly.
    Mine does too so maybe I should leave well alone for now!

    Also what do all these packages mean? eg Branding, Dummy packages, etc etc. Is there a tutorial explaining this stuff?

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: What version of Firefox should I have?

    Quote Originally Posted by oxf View Post
    What version of Firefox do I have and what version should I have? About 10 day ago I downloaded and burned a new 9.04 Live CD and installed it.

    It was my impression (wrongly perhaps?) that 9.04 came with FF 3.5? Now looking through Synaptic PKG MGR I see I have various FF 3.0 bits installed but anything to do with 3.5 is not installed.
    If your system is updated, then you have version 3.0.11. Whenever you need to check this open Firefox, click the "Help" menu and then "About Mozilla Firefox". It will show the version info. Most applications display version info the same way.

    Quote Originally Posted by oxf View Post
    Finally to install 3.5 do I need to uninstall 3.0 ones first or will they be upgraded automatically if I install 3.5. Any reason why I should not install 3.5 at this point?
    No. You don't need and you shouldn't uninstall firefox-3.0, because firefox-3.5 is installed side-by-side with it and copy your current profiles to another location. So, your Firefox 3.0 packages will not be updated automatically until the official 3.5 updates reaches the repositories. If you install the package firefox-3.5 from synaptic you will get the Beta version, while the final release is already on Mozilla web site or through alternative repositories. There are 3 methods of installing firefox 3.5 in my tutorial Firefox optimization and troubleshooting thread. Scroll down to the "Installing Other Versions" section.

    Quote Originally Posted by oxf View Post
    Any reason why I should not install 3.5 at this point?Thanks
    Well, if you check my benchmarks you will see that Firefox 3.5 is much faster and responsive than 3.0.11. Since the packages are installed side-by-side, I would test the Beta version if I were you. Just install it through Synapti and open it through "Applications >> Internet >> Shiretoko Web Browser". You will still be able to use Firefox 3.0 and it won't be affected, so give it a go. If you like it, then you can follow the instructions on my tutorial to update to the final version or newer versions. You could also wait for updates on the official repository, then uninstall Shiretoko when Firefox 3.0.11 gets updated (if it will be).


    Quote Originally Posted by linux_lover69 View Post
    Well I have found firefox 3.5 is kinda buggy. For example when I try to play stuff on like Hulu and try to play full screen, it crashes. Its up to you if you think you should install it.
    Quote Originally Posted by oxf View Post
    Mine does too so maybe I should leave well alone for now!

    Also what do all these packages mean? eg Branding, Dummy packages, etc etc. Is there a tutorial explaining this stuff?
    To fix the fullscreen video issue visit this post and this.
    Last edited by lovinglinux; July 6th, 2009 at 05:48 AM.

  8. #8
    oxf is offline Extra Foam Sugar Free Ubuntu
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: What version of Firefox should I have?

    Quote Originally Posted by lovinglinux View Post
    If your system is updated, then you have version 3.0.11. Whenever you need to check this open Firefox, click the "Help" menu and then "About Mozilla Firefox". It will show the version info. Most applications display version info the same way.



    No. You don't need and you shouldn't uninstall firefox-3.0, because firefox-3.5 is installed side-by-side with it and copy your current profiles to another location. So, your Firefox 3.0 packages will not be updated automatically until the official 3.5 updates reaches the repositories. If you install the package firefox-3.5 from synaptic you will get the Beta version, while the final release is already on Mozilla web site or through alternative repositories. There are 3 methods of installing firefox 3.5 in my tutorial Firefox optimization and troubleshooting thread. Scroll down to the "Firefox Alternatives & Newer Versions" section.



    Well, if you check my benchmarks you will see that Firefox 3.5 is much faster and responsive than 3.0.11. Since the packages are installed side-by-side, I would test the Beta version if I were you. Just install it through Synapti and open it through "Applications >> Internet >> Shiretoko Web Browser". You will still be able to use Firefox 3.0 and it won't be affected, so give it a go. If you like it, then you can follow the instructions on my tutorial to update to the final version or newer versions. You could also wait for updates on the official repository, then uninstall Shiretoko when Firefox 3.0.11 gets updated (if it will be).






    To fix the fullscreen video issue visit this post and this.
    Well it appears I have Version 3.08 installed right now so looks like I have some updating to do!

    Thanks for the tutorial and info!

  9. #9
    Join Date
    Jun 2009
    Location
    Corvallis, OR
    Beans
    18
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: What version of Firefox should I have?

    I have 3.5 on my vista laptop and it works perfect, tonight I am going to upgrade to 3.5 on my Ubuntu desktop.

  10. #10
    Join Date
    Sep 2007
    Beans
    584
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: What version of Firefox should I have?

    Quote Originally Posted by linux_lover69 View Post
    Well I have found firefox 3.5 is kinda buggy. For example when I try to play stuff on like Hulu and try to play full screen, it crashes. Its up to you if you think you should install it.
    Ditto. 3.011 didn't do this. I'm super annoyed.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •