Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Monitor doesn't go to sleep

  1. #1
    Join Date
    Jul 2009
    Beans
    12

    Question Monitor doesn't go to sleep

    I spent lots of time trying to figure this out, but no advice seems to fix it for me.
    I have a motherboard with Intel 945G video on board.
    Initially, after Ubuntu install, setting in power management to shut down monitor after 5 minutes of inactivity worked like a charm.
    Now for whatever reason it's not happening at all. No amount of tinkering works.
    Even if I adjust values in GNOME-Power_Manager in Configuration Editor monitor will not shut down.
    Please suggest a solution to this.

  2. #2
    Join Date
    Mar 2008
    Beans
    4,714
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Monitor doesn't go to sleep

    What is the output of

    Code:
    xset q

  3. #3
    Join Date
    Jul 2009
    Beans
    12

    Re: Monitor doesn't go to sleep

    Keyboard Control:
    auto repeat: on key click percent: 0 LED mask: 00000002
    auto repeat delay: 500 repeat rate: 30
    auto repeating keys: 00ffffffdffffbbf
    fadfffefffedffff
    9fffffffffffffff
    fff7ffffffffffff
    bell percent: 50 bell pitch: 400 bell duration: 100
    Pointer Control:
    acceleration: 2/1 threshold: 4
    Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 0
    Colors:
    default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
    Font Path:
    /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,built-ins
    DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 0
    DPMS is Enabled
    Monitor is On

  4. #4
    Join Date
    Mar 2008
    Beans
    4,714
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Monitor doesn't go to sleep

    Try:
    Code:
    xset dpms 300 600
    This should put your monitor in standby after 5 minutes of inactivity, and suspend the monitor after 10 minutes. (Assuming the monitor is DPMS compliant).

  5. #5
    Join Date
    Jan 2009
    Beans
    161

    Re: Monitor doesn't go to sleep

    Quote Originally Posted by unutbu View Post
    Try:
    Code:
    xset dpms 300 600
    This should put your monitor in standby after 5 minutes of inactivity, and suspend the monitor after 10 minutes. (Assuming the monitor is DPMS compliant).
    I'm watching this thread because I have the opposite problem. Even tho I have power management set to Never turn off my monitor, it goes to sleep after about 20 minutes anyways.
    Is there an xset command for 'never'?

    eb

    btw, if your wondering why I don't want the monitor to 'power save' I use the TV out on my vid card to my TV, which also acts as my speakers, so if I'm playing music and the monitor switches off it also kills the sound from my TV, and having to come back and whack the mouse every 20 minutes or so is a bit of a PITA.

  6. #6
    Join Date
    Mar 2008
    Beans
    4,714
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Monitor doesn't go to sleep

    Razmear, to stop Ubuntu from blanking or suspending your monitor, try
    Code:
    xset -dpms
    If it works and wish to make this change permanent,
    click System>Pref>Sessions and add the command there.

  7. #7
    Join Date
    Jul 2009
    Beans
    12

    Re: Monitor doesn't go to sleep

    Quote Originally Posted by unutbu View Post
    Try:
    Code:
    xset dpms 300 600
    This should put your monitor in standby after 5 minutes of inactivity, and suspend the monitor after 10 minutes. (Assuming the monitor is DPMS compliant).
    It did exactly what you said, but only once
    Do I have to enter this command every time I want monitor to shut down?

  8. #8
    Join Date
    Mar 2008
    Beans
    4,714
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Monitor doesn't go to sleep

    iakov, perhaps try clicking System>Pref>Sessions and adding the command there.
    That will run the command once when you log in.

    If that does not work, please do the following experiment:

    Run
    Code:
    xset dpms 10 20
    This will blank your monitor after just 10 seconds of inactivity.
    Wait for the monitor to blank.
    Press a key.
    Type
    Code:
    xset q
    Look for
    Code:
    DPMS (Energy Star):
      Standby: 10    Suspend: 20    Off: 0
      DPMS is Enabled
      Monitor is On
    Do you see this or something else?
    Wait for another 10 seconds. Does the monitor blank again?

  9. #9
    Join Date
    Jul 2009
    Beans
    12

    Re: Monitor doesn't go to sleep

    Thanks alot for your help Sir.
    I could not find Sessions, but will search to activate this.
    The experiment you suggested does exactly what it supposed to as many times as i want to and I do have this:
    DPMS (Energy Star):
    Standby: 10 Suspend: 20 Off: 0
    DPMS is Enabled
    Monitor is On

  10. #10
    Join Date
    Jul 2009
    Beans
    12

    Re: Monitor doesn't go to sleep

    Interesting.
    When I set this:

    xset dpms 300 600


    and waited 5 minutes monitor would not shut off, so I checked:
    xset q

    and this is what I got:
    DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 0
    DPMS is Enabled
    Monitor is On

    Looks like something is resetting these settings.

    I'll try to figure out what delay is a threshold shortly.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •