Results 1 to 7 of 7

Thread: [SOLVED] Facebook Video Won't Play?

  1. #1
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    [SOLVED] Facebook Video Won't Play?

    Here's a weird one for you.

    So I'm using Ubuntu 9.04 with the lpia kernel right now. I had Flash installed from the repositories, and normal Flash stuff would work (Flash websites, YouTube). But when I tried to play a video through Facebook, I got a message that I needed the latest Flash installed. I went to the Adobe website to download "the latest Flash," which actually downgraded my version, and I had to "convert" it from i386 to lpia architecture. Once that was installed, I got the same message from Facebook... but YouTube still worked fine.

    If I use the regular i386 live CD and install Flash from the Adobe website, video on Facebook works just fine.

    Is this an lpia thing? And, if so, why do other Flash websites work just fine and not Facebook? Anyone else experiencing this? Any proposed fixes, apart from ditching lpia altogether?

  2. #2
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Facebook Video Won't Play?

    Never mind. It's not an lpia thing. It's an /opt/firefox issue.

    Apparently, if you install Flash directly from the Adobe website, it goes to /usr/lib/adobe-flashplugin/libflashplayer.so instead of to the traditional plugins folders (/usr/lib/mozilla/plugins or /usr/lib/xulrunner-addons/plugins).

    So I just closed Firefox, copied /usr/lib/adobe-flashplugin/libflashplayer.so to /opt/firefox/plugins/ and restarted Firefox and it worked.

  3. #3
    Join Date
    Jul 2008
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Facebook Video Won't Play?

    Quote Originally Posted by aysiu View Post
    Never mind. It's not an lpia thing. It's an /opt/firefox issue.

    Apparently, if you install Flash directly from the Adobe website, it goes to /usr/lib/adobe-flashplugin/libflashplayer.so instead of to the traditional plugins folders (/usr/lib/mozilla/plugins or /usr/lib/xulrunner-addons/plugins).

    So I just closed Firefox, copied /usr/lib/adobe-flashplugin/libflashplayer.so to /opt/firefox/plugins/ and restarted Firefox and it worked.
    I'm having the same problem, and I'm not sure how I need to go about copying and pasting the above solution. I hope its ok to ask such a basic question.

  4. #4
    Join Date
    Jul 2007
    Location
    Connecticut USA
    Beans
    1,865
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Facebook Video Won't Play?

    I just put libflashplayer.so into ~/.mozilla/plugins

    Never had a flash problem doing that.

  5. #5
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Facebook Video Won't Play?

    Quote Originally Posted by ckunzler View Post
    I'm having the same problem, and I'm not sure how I need to go about copying and pasting the above solution. I hope its ok to ask such a basic question.
    Press Alt-F2

    A Run Application dialogue will appear

    Paste in the command
    Code:
    gksudo nautilus
    and then you can copy the plugin.

  6. #6
    Join Date
    Jul 2008
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Facebook Video Won't Play?

    Quote Originally Posted by aysiu View Post
    Press Alt-F2

    A Run Application dialogue will appear

    Paste in the command
    Code:
    gksudo nautilus
    and then you can copy the plugin.
    That just brought up a root file browser and I didn't know where to go from there.

    I'm wondering if I could solve the problem if I just uninstall flash then reinstall it from synaptic since as you say the problem was caused by downloading flash directly from Adobe's website.
    Thanks for you help.

  7. #7
    Join Date
    Nov 2008
    Beans
    3

    Re: [SOLVED] Facebook Video Won't Play?

    I too had this problem, and was able to fix it with the directions on this link.

    -- Mike

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •