Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV

  1. #41
    Join Date
    Jun 2008

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV

    Quote Originally Posted by ydo View Post
    Installing SamyGO which can mount samba, nfs and upnp/dlna as virtual usb drives gives access to these features which are disabled over normal dlna.
    AND it is way cool to be able to ssh the TV
    Would you tell me how you were able to map the samba drivers on your TV? I installed the SamyGo and wrote the script but I have these errors:
    touch $1/ScriptOK
    rm -f /mtd_rwarea/profile
    $1/SamyGO/rcSGO $1/SamyGO > $1/rcSGO_out 2>&1 &
    insmod /dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/fs/cifs/cifs.ko
    sleep 10; mount -t cifs -o -o guest // /dtv/usb/sda1/samba/
    sleep 10; mount -t cifs -o -o guest //\ Videos /dtv/usb/sda1/shares/Videos
    + /dtv/usb/sda1/SamyGO/rcSGO /dtv/usb/sda1/SamyGO
    ./etc/rc.sysinit: line 94: /dtv/usb/sda1/SamyGO/opt/privateer/sbin/depmod: not found
    insmod /dtv/usb/sda1/SamyGO/lib/modules/*.ko, this behavior is outdated modules are handled by the init scripts!
    Replace /dtv/usb/sda1/SamyGO/lib/modules/treasure/*.ko
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/video/cfbcopyarea.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/video/cfbfillrect.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/video/cfbimgblt.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/input/usbhid.ko': No such file or directory
    mkfs.vfat 2.11 (12 Mar 2005)
    real storage device at: /sys/block/sda/device/model
    found gadget at: /sys/block/sdb/device/model
    scsidev: sdb
    fuse 30900 0 - Live 0xbf736000
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/net/sunrpc/sunrpc.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/fs/lockd/lockd.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/fs/nfs_common/nfs_acl.ko': No such file or directory
    insmod: can't open '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/fs/nfs/nfs.ko': No such file or directory
    Search Shares on:
    portmap getport: RPC: Success
    which: no hid2hci in (/dtv/usb/sda1/SamyGO/opt/privateer/sbin:/dtv/usb/sda1/SamyGO/opt/privateer/bin:/dtv/usb/sda1/SamyGO/opt/privateer/usr/bin:/dtv/usb/sda1/SamyGO/opt/privateer/usr/sbin:/dtv/usb/sda1/SamyGO/sbin:/dtv/usb/sda1/SamyGO/bin:/dtv/usb/sda1/SamyGO/usr/bin:/dtv/usb/sda1/SamyGO/usr/sbin:/sbin:/bin:/usr/sbin:/usr/bin)
    Starting Bluetooth subsystem: hcidCan't get device info: No such device
     sdpd hidd.
    recorder share not mounted!

  2. #42
    Join Date
    Sep 2007

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV


    of corse I also have a problem with mediatomb. I can play a lot of Divx/Xvid movies but for example the current Breaking Bad episodes doesnt work. The file information which I get from VLC are:
    Stream 0
    Type: Video
    Codec: XVID
    Resolution: 624x352
    Display resolution: 624x352
    Frame rate: 23.976024
    Stream 1
    Type: Audio
    Codec: mpga
    Channels: Stero
    Sample rate: 48000 Hz
    Bitrate: 128kb/s

    and my config is:
    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="" xmlns:xsi="" xsi:schemaLocation="">
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          <sqlite3 enabled="yes">
          <mysql enabled="no">
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
          <add header="X-User-Agent: redsonic"/>
          <add header=" Streaming"/>
          <add header=" DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=017000 00000000000000000000000000"/>
        <!-- Uncomment the line below if you have a Telegent TG100 -->
          <ffmpegthumbnailer enabled="no">
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <virtual-layout type="builtin"/>
        <autoscan use-inotify="auto">
            <directory location="/media" mode="timed" interval="3600"
                    level="full" recursive="yes" hidden-files="no"/>
            <directory location="/home/stephan/Downloads/" mode="inotify"
                    recursive="yes" hidden-files="no"/>
          <extension-mimetype ignore-unknown="no">
    	<map from="avi" to="video/divx"/>
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/mpeg"/>
            <map from="mka" to="audio/x-matroska"/>
    	<map from="rmvb" to="application/vnd.rn-realmedia"/>
            <!-- Uncomment the line below for PS3 divx support -->
           <!-- <map from="avi" to="video/divx"/> -->
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
            <treat mimetype="video/x-matroska" as="mkv"/>
            <treat mimetype="audio/x-matroska" as="mka"/>
    	<treat mimetype="application/vnd.rn-realmedia" as="rmvb"/>
    	<treat mimetype="application/vnd" as="rmvb"/>
          <!-- Make sure to setup a transcoding profile for flv -->
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          <Weborama enabled="no" refresh="28800" update-at-start="no">
            <playlist name="Active" type="playlist" mood="active"/>
            <playlist name="Metal" type="playlist">
          <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
      <transcoding enabled="no">
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
          <profile name="oggflac2raw" enabled="no" type="external">
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          <profile name="vlcmpeg" enabled="no" type="external">
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
    As anyone a idea whats the problem? Maybe it is the sound.. ?


  3. #43
    Join Date
    Sep 2011

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV


    Just wanted to add that while I was unable to use the FF/REW buttons on the remote, the directional pad allows me to jump ahead or back a few seconds. I had it all working except this and was trying to figure out why I was getting the "Not Available" response from the Samsung TV when I hit FF/REW (pause, stop, and play worked). Didn't see it posted anywhere to try the alternate keys on the TV remote.

    Fixing the headers, video mappings, and updating the firmware got it all working with my Samsung PN51D550.

  4. #44
    Join Date
    Dec 2007
    Terni, Umbria, Italia

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV

    Hey, I found this PPA for serviio, but it's compiled with wrong dependencies (and it's also an obsolete version):


  5. #45
    Join Date
    Jul 2005
    Ubuntu 16.04 Xenial Xerus

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV

    For those who might be interested, I've just set up miniDLNA to work with a Samsung smart PVR. Seems to work flawlessly so far. Just followed these instructions:

  6. #46
    Join Date
    Aug 2009

    Re: [SOLVED] Using Ubuntu as a DLNA Media Server for Samsung TV

    I have been trying to get mediatomb working on my Samsung UN55D8000.
    From the original config file i edited the custom-header section to read

    <add header=" Streaming"/><add header=" DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=015000 00000000000000000000000000"/> Once i have done this ,AVI files play, but mkv files display the unsupported file format message. I have tried a few different changes to the file to fix this but have no luck in getting it to work.I have been reading in forums that mediatomb is dead and should be abandoned for something else.What is peoples opinion on this. I tried Serviio as well but can't get it to run.

Page 5 of 5 FirstFirst ... 345

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts