Results 1 to 2 of 2

Thread: Hardy 2.6.24-24 wireless light disabled.

  1. #1
    Join Date
    Aug 2006

    Hardy 2.6.24-24 wireless light disabled.

    Running hardy on an HP laptop with intel 3945ABG internal wireless card.
    Recently did a bunch of updates;
    Under Hardy kernel 2.6.22-26-generic (which I can still boot) the LED which shows if the wireless txmitter is enabled or not worked fine.
    Under Hardy kernel 2.6.24-24-generic the light does not work.
    The network works fine, in fact I am using it as I type, but I am now never sure if the 'wireless killswitch' has been pushed by accident or not.
    Is there a fix for this?
    I notice that under the hardware menu in the taskbar there is a device which is the 'killswitch', maybe the led is tied to that? maybe there is a file that needs editing to enable Linux to allow the LED to become active?
    (It normally blinks furiously when in use, or intermittently when trying to connect).
    the dmesg, lshw -C network, iwconfig etc cmds all look normal, as you would expect with a working interface.


  2. #2
    Join Date
    Apr 2007
    Ubuntu 8.04 Hardy Heron

    Re: Hardy 2.6.24-24 wireless light disabled.

    I just installed kernel 2.6.24-24 on aspire one. I had tried a few months ago giving me kernel panic, so i commented out this kernel in /boot/grub/menu.lst.

    This time it out worked fine. I did not even have to recompile ALSA for sound.

    only, at the first reboot, i had a dev.wifi0.ledpin error. I recompiled the madwifi drivers and rebooted. The led is now blinking.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts