Page 30 of 94 FirstFirst ... 2028293031324080 ... LastLast
Results 291 to 300 of 931

Thread: Grub 2 Basics

  1. #291
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Basics

    Quote Originally Posted by benplanet View Post
    I just installed linux on my primary drive, but I have another hard drive in my computer which originally had Windows 7 installed.

    Should I restore the windows bootloader? because when Grub loads I cannot see my windows OS in the options.

    I see 2 entries for linux (including one for safe mode) and 2 for memtest.

    Somebody help, how do I restore windows 7 to grub so I can have the option to boot to windows...

    Cheers!
    First, run "sudo update-grub" again to see if Grub 2 will see Windows 7. Sometimes update-grub has to be run once after an install to find the Windows partition.

    If that doesn't work, refer to the following link to help you restore Windows:
    How to restore the Ubuntu/XP/Vista/7 bootloader
    GRUB2

    Retired.

  2. #292
    Join Date
    Jul 2007
    Beans
    68

    Re: Grub 2 Basics

    Quote Originally Posted by drs305 View Post
    First, run "sudo update-grub" again to see if Grub 2 will see Windows 7. Sometimes update-grub has to be run once after an install to find the Windows partition.

    If that doesn't work, refer to the following link to help you restore Windows:
    How to restore the Ubuntu/XP/Vista/7 bootloader
    I did the upgrade-grub in terminal, nothing about my old windows 7 os. IT just shows linux mint and memtest entries.

    When I boot with the windows CD I don't see any existing windows installations either. But.. my files are all there, take a look at the screenshot. I used Disk manager to mount it.




    How do I make this bootable? All my work is in Windows 7! Thanks much!

    Here are the results of boot info script:
    Code:
    ============================= Boot Info Summary: ==============================
    
     => Grub 2 is installed in the MBR of /dev/sda and looks on the same drive in 
        partition #2 for /boot/grub.
     => Paragon is installed in the MBR of /dev/sdb
     => Windows is installed in the MBR of /dev/sdc
     => Windows is installed in the MBR of /dev/sdd
    sda1: _________________________________________________________________________
    
        File system:       Extended Partition
        Boot sector type:  -
        Boot sector info:  
    
    sda5: _________________________________________________________________________
    
        File system:       swap
        Boot sector type:  -
        Boot sector info:  
    
    sda2: _________________________________________________________________________
    
        File system:       ext4
        Boot sector type:  -
        Boot sector info:  
        Operating System:  Linux Mint 8 Helena - x64 
                           Edition
        Boot files/dirs:   /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img
    
    sdb1: _________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  
        Boot files/dirs:   
    
    sdb2: _________________________________________________________________________
    
        File system:       Extended Partition
        Boot sector type:  -
        Boot sector info:  
    
    sdb5: _________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7
        Boot sector info:  According to the info in the boot sector, sdb5 starts 
                           at sector 1. But according to the info from fdisk, 
                           sdb5 starts at sector 398540583.
        Operating System:  Windows 7
        Boot files/dirs:   /etc/lilo.conf /Windows/System32/winload.exe
    
    sdc1: _________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  
        Boot files/dirs:   
    
    sdd1: _________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows Vista/7
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  
        Boot files/dirs:   
    
    =========================== Drive/Partition Info: =============================
    
    Drive: sda ___________________ _____________________________________________________
    
    Disk /dev/sda: 82.3 GB, 82348277760 bytes
    255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0xa79fa79f
    
    Partition  Boot         Start           End          Size  Id System
    
    /dev/sda1         160,810,650   160,826,714        16,065   5 Extended
    /dev/sda5         160,810,713   160,826,714        16,002  82 Linux swap / Solaris
    /dev/sda2    *             63   160,810,649   160,810,587  83 Linux
    
    
    Drive: sdb ___________________ _____________________________________________________
    
    Disk /dev/sdb: 400.1 GB, 400088457216 bytes
    255 heads, 63 sectors/track, 48641 cylinders, total 781422768 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0x01030bc9
    
    Partition  Boot         Start           End          Size  Id System
    
    /dev/sdb1    *             63   398,540,519   398,540,457   7 HPFS/NTFS
    /dev/sdb2         398,540,520   781,417,664   382,877,145   f W95 Ext d (LBA)
    /dev/sdb5    *    398,540,583   781,417,664   382,877,082   7 HPFS/NTFS
    
    
    Drive: sdc ___________________ _____________________________________________________
    
    Disk /dev/sdc: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0x8e7c4595
    
    Partition  Boot         Start           End          Size  Id System
    
    /dev/sdc1                  63   488,392,064   488,392,002  42 SFS
    
    
    Drive: sdd ___________________ _____________________________________________________
    
    Disk /dev/sdd: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0x44fdfe06
    
    Partition  Boot         Start           End          Size  Id System
    
    /dev/sdd1                  63   976,768,064   976,768,002   7 HPFS/NTFS
    
    
    blkid -c /dev/null: ____________________________________________________________
    
    Device           UUID                                   TYPE       LABEL                         
    
    /dev/sda2        55ae3495-dea7-4eeb-aa32-683d75ecb031   ext4                                     
    /dev/sda5        a74f01e6-0677-4560-ae27-264a30f69964   swap                                     
    /dev/sdb1        D42AF0782AF058C6                       ntfs       File Drive 1                  
    /dev/sdb5        A64CD9AB4CD97711                       ntfs                                     
    /dev/sdc1        4EC067F4C067E0A7                       ntfs       Backup Disk                   
    /dev/sdd1        B426069F2606632A                       ntfs       My Book                       
    
    ============================ "mount | grep ^/dev  output: ===========================
    
    Device           Mount_Point              Type       Options
    
    /dev/sda2        /                        ext4       (rw,errors=remount-ro)
    /dev/sr1         /media/cdrom0            udf        (ro,nosuid,nodev,utf8,user=ben)
    /dev/sdd1        /media/My Book           fuseblk    (rw,nosuid,nodev,allow_other,default_permissions,blksize=512)
    /dev/sdb1        /media/File Drive 1      fuseblk    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdc1        /media/Backup Disk       fuseblk    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdb5        /media/A64CD9AB4CD97711  fuseblk    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    
    
    =========================== sda2/boot/grub/grub.cfg: ===========================
    
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s /boot/grub/grubenv ]; then
      have_grubenv=true
      load_env
    fi
    set default="0"
    if [ ${prev_saved_entry} ]; then
      saved_entry=${prev_saved_entry}
      save_env saved_entry
      prev_saved_entry=
      save_env prev_saved_entry
    fi
    insmod ext2
    set root=(hd0,2)
    search --no-floppy --fs-uuid --set 55ae3495-dea7-4eeb-aa32-683d75ecb031
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=640x480
      insmod gfxterm
      insmod vbe
      if terminal_output gfxterm ; then true ; else
        # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        terminal gfxterm
      fi
    fi
    if [ ${recordfail} = 1 ]; then
      set timeout=-1
    else
      set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/white
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/06_mint_theme ###
    insmod ext2
    set root=(hd0,2)
    search --no-floppy --fs-uuid --set 55ae3495-dea7-4eeb-aa32-683d75ecb031
    insmod png
    if background_image /boot/grub/linuxmint.png ; then
      set color_normal=white/black
      set color_highlight=white/light-gray
    else
      set menu_color_normal=white/black
      set menu_color_highlight=white/light-gray
    fi
    ### END /etc/grub.d/06_mint_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    menuentry "Linux Mint 8 Helena x64, linux 2.6.31-14-generic (/dev/sda2)" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
    	set quiet=1
    	insmod ext2
    	set root=(hd0,2)
    	search --no-floppy --fs-uuid --set 55ae3495-dea7-4eeb-aa32-683d75ecb031
    	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=55ae3495-dea7-4eeb-aa32-683d75ecb031 ro   quiet splash
    	initrd	/boot/initrd.img-2.6.31-14-generic
    }
    menuentry "Linux Mint 8 Helena x64, linux 2.6.31-14-generic (recovery mode)" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
    	insmod ext2
    	set root=(hd0,2)
    	search --no-floppy --fs-uuid --set 55ae3495-dea7-4eeb-aa32-683d75ecb031
    	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=55ae3495-dea7-4eeb-aa32-683d75ecb031 ro single 
    	initrd	/boot/initrd.img-2.6.31-14-generic
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    	linux16	/boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    if [ ${timeout} != -1 ]; then
      if keystatus; then
        if keystatus --shift; then
          set timeout=-1
        else
          set timeout=0
        fi
      else
        if sleep --interruptible 3 ; then
          set timeout=0
        fi
      fi
    fi
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    
    =============================== sda2/etc/fstab: ===============================
    
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda2 during installation
    UUID=55ae3495-dea7-4eeb-aa32-683d75ecb031 /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda5 during installation
    UUID=a74f01e6-0677-4560-ae27-264a30f69964 none            swap    sw              0       0
    /dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    
    ============================= sdb5/etc/lilo.conf: =============================
    
    paragon_jboot
    image=/etc/psrdisk
    label="###NdenHden"
    initrd=/etc/psr.img
    append="paragon_lang=en"
    
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################################################################################
    ################=======Devices which don't seem to have a corresponding hard drive==============
    
    sde
    If this helps here is what I did to install linux: I had an old win installation in my F drive (83GB primary drive). I couldn't format that old partition, so I used a paragon boot cd to do it from there, and I formatted to ext3.
    I then booted into linux mint CD and installed from there, I also re-formatted the fresh ext3 into ext4.
    Last edited by benplanet; February 6th, 2010 at 09:35 PM.

  3. #293
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Basics

    benplanet,

    Did you try restoring the MBR as detailed in the link I provided? If that doesn't fix things, run the boot info script and post the results within "code" tags. To do that, click on the # icon in your post, and then paste the results within.

    Here is the link to meierfra's boot info script
    GRUB2

    Retired.

  4. #294
    Join Date
    Jul 2007
    Beans
    68

    Re: Grub 2 Basics

    Quote Originally Posted by drs305 View Post
    benplanet,

    Did you try restoring the MBR as detailed in the link I provided? If that doesn't fix things, run the boot info script and post the results within "code" tags. To do that, click on the # icon in your post, and then paste the results within.

    Here is the link to meierfra's boot info script
    updated with results above.

    I hope you can interpret the results and come back with a solution, thanks much for all the help!
    Last edited by benplanet; February 6th, 2010 at 09:55 PM.

  5. #295
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Basics

    Quote Originally Posted by benplanet View Post
    updated with results. Should I give this a try? http://www.arsgeek.com/2008/01/15/ho...ubuntu-livecd/

    I hope you can interpret the results and come back with a solution, thanks much for all the help!
    Edit: I just saw you posted the results in a previous response!

    Line deleted.....

    Post removed while I review your info script results.....
    Last edited by drs305; February 6th, 2010 at 09:50 PM.
    GRUB2

    Retired.

  6. #296
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Grub 2 Basics

    Don't run the lilo command or try to fix the MBR. According to your RESULTS.txt your MBR is in perfect condition. But the boot files for Windows are missing. Just give me couple of minutes to write up instructions.

    Edit: Didn't not see drs305 edit until after I posted this.
    Last edited by meierfra.; February 6th, 2010 at 09:57 PM.

  7. #297
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Basics

    Meierfra is correct and I will defer to his advice as to how to procede as I am not a frequent Windows user.

    @ meierfra - Hehe. I just about jumped when I saw his results after I had made the post. If I'd had his phone number, I might have even called.

    Benplanet - sorry for the confusion - I expected a new post with the boot info script and didn't scroll up to the previous posts until after I posted a response asking you again for the results and providing recommendations.
    Last edited by drs305; February 6th, 2010 at 10:06 PM.
    GRUB2

    Retired.

  8. #298
    Join Date
    Jul 2007
    Beans
    68

    Re: Grub 2 Basics

    Quote Originally Posted by drs305 View Post
    Meierfra is correct and I will defer to his advice as to how to procede as I am not a frequent Windows user.

    @ meierfra - Hehe. I just about jumped when I saw his results after I had made the post. If I'd had his phone number, I might have even called.

    Benplanet - sorry for the confusion - I expected a new post with the boot info script and didn't scroll up to the previous posts until after I posted a response asking you again for the results and providing recommendations.
    Good thing you edited it in time then

    I am standing by ready to try anything that can solve this problem and preserve my windows 7, tones of important work in there

    cheers guys

  9. #299
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Grub 2 Basics

    Window always puts its boot files on a primary partition on the boot drive. You deleted that partition when you installed Ubuntu, and so the boot files for Window 7 are gone. Also since you do not have any fat/ntfs partition on the boot drive your Windows CD is not able to find any operating system.

    First I suggest to remove the boot flag from /dev/sdb5, since the two boot flags might confuse your Windows CD:

    Code:
    sudo sfdisk -A1 /dev/sdb
    Next change the boot order in the bios so that your Windows hard drive is first among all the hard drive. If your bios don't let you change the boot order you will have to physically remove the Ubuntu drive.

    Then boot from the Window 7 CD:


    At the first screen select your favorite language.
    At the second screen choose "Repair your Computer".

    If a pop up appears, offering to repair a problem with the "Startup options", click on "Repair and restart".

    Otherwise, on the next screen select "Use recovery tools ..." and click on "Next".
    Choose "Startup Repair" at the next screen.

    "Startup Repair" tends to fix one problem at the time. So you might have to run "Startup Repair" several times.


    After running startup repair, boot from the Windows drive. You should boot directly into Windows. Once you successfully booted into Windows, reboot but set your Bios to boot from the Ubuntu drive (and plug your Ubuntu drive back in, if you had to detach it)

    Once booted in Ubuntu run

    Code:
    sudo update-grub
    Hopefully, this will be all you need to do to boot Windows 7 again.

  10. #300
    Join Date
    Jul 2007
    Beans
    68

    Re: Grub 2 Basics

    Quote Originally Posted by meierfra. View Post
    Window always puts its boot files on a primary partition on the boot drive. You deleted that partition when you installed Ubuntu, and so the boot files for Window 7 are gone. Also since you do not have any fat/ntfs partition on the boot drive your Windows CD is not able to find any operating system.

    First I suggest to remove the boot flag from /dev/sdb5, since the two boot flags might confuse your Windows CD:

    Code:
    sudo sfdisk -A1 /dev/sdb
    Next change the boot order in the bios so that your Windows hard drive is first among all the hard drive. If your bios don't let you change the boot order you will have to physically remove the Ubuntu drive.

    Then boot from the Window 7 CD:


    At the first screen select your favorite language.
    At the second screen choose "Repair your Computer".

    If a pop up appears, offering to repair a problem with the "Startup options", click on "Repair and restart".

    Otherwise, on the next screen select "Use recovery tools ..." and click on "Next".
    Choose "Startup Repair" at the next screen.

    "Startup Repair" tends to fix one problem at the time. So you might have to run "Startup Repair" several times.


    After running startup repair, boot from the Windows drive. You should boot directly into Windows. Once you successfully booted into Windows, reboot but set your Bios to boot from the Ubuntu drive (and plug your Ubuntu drive back in, if you had to detach it)

    Once booted in Ubuntu run

    Code:
    sudo update-grub
    Hopefully, this will be all you need to do to boot Windows 7 again.
    this didn't work. in fact i couldn't boot to any loader, i just got an error saying: no operating system....

    so i installed ubuntu 9.10 over linux mint, same thing no signs of windows 7

    Should I be backing up my files and re-installing windows, or is there one last thing i could try?

Page 30 of 94 FirstFirst ... 2028293031324080 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •