Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Nvidia GeForce 9500 GT Driver Problems

  1. #21
    Join Date
    Apr 2008
    Location
    Sweden
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia GeForce 9500 GT Driver Problems

    Quote Originally Posted by rnestor View Post
    Check the output in the /var/log/Xorg.0.log file. If the card has multiple connections (DVI and VGA) you'll probably find that X11 is assuming all your xorg.conf settings apply to the VGA0 connection but is finding the monitor connected to the VGA2 port. The solution is to set up your xorg.conf file to map to "Monitor-VGA2". I had the same problem with the Nvidia GeForce 8500GT under 8.xx, 9.04, 9.10 and OpenSUSE. The Nvidia driver doesn't solve the problem, but setting up the right xorg.conf file did in all cases and works with the standard drivers in Ubuntu.
    Well i did that and it dident help a thing iam stuck again

  2. #22
    Join Date
    Jan 2010
    Beans
    4

    Re: Nvidia GeForce 9500 GT Driver Problems

    Quote Originally Posted by j0mpa View Post
    Well i did that and it dident help a thing iam stuck again
    Two things you need to verify. One, make sure that your Xorg.0.log file shows that X11 is using the setups in your xorg.conf file. Look for the lines that say something like "Output xxx connected" or "Output xxx disconnected" where "xxx" is the Monitor port. On my 8500GT this showed it using VGA2, on my 210 it shows using "VGA0". This, prefixed with "Monitor-" will be the Option in the Device Section. So if your log file shows it is connecting on say VGA7, then your Device Section should have an Option line mapping Monitor-VGA7 to the named Monitor you defined in the Screen section. (Clear, right?) Anyway, take a look at my example to see how the various sections of the file are connected by names.

    Second, if there's an error in the file indicating that the resolution you want isn't available because the size exceeds the vertical or horizontal limits you'll need to add a "Virtual" statement in the Screen section of xorg.conf. You'll notice I set it to 2048x1536 which is larger than I needed. On the 9500GT card a value of 1920x1200 worked, but the 210 required a bit more "real-estate" to map to 1920x1200. Here is the file that worked on my GeForce 8500GT-512P and works with my current GeForce 210 card (with the commented changes):

    Section "Monitor"
    Identifier "Configured Monitor"
    Modeline "1920x1200" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -
    HSync +Vsync
    Modeline "1920x1080" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -
    hsync +vsync
    Modeline "1600x1200" 161.00 1600 1712 1880 2160 1200 1203 1207 1245 -
    hsync +vsync
    Modeline "1600x1024" 135.50 1600 1696 1864 2128 1024 1027 1037 1063 -
    hsync +vsync
    Modeline "1400x1050" 121.75 1400 1488 1632 1864 1050 1053 1057 1089 -
    hsync +vsync
    Modeline "1360x768" 84.75 1360 1432 1568 1776 768 771 781 798 -hsync
    +vsync
    Modeline "1152x864" 81.75 1152 1216 1336 1520 864 867 871 897 -hsync
    +vsync
    Modeline "1024x768" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync
    +vsync
    # Max size for Soyo Topaz S 24" monitor
    Option "PreferredMode" "1920x1200"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    # For GF8500GT-512P
    Depth 24
    Virtual 1920 1200
    # for GeForce 210
    # Depth 32
    # Virtual 2048 1536
    #
    Modes "1920x1200" "1920x1080" "1600x1200" "1600x1024" "1400x1050
    " "1360x768" "1152x864" "1024x768"
    EndSubSection
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    # For GF8500GT-512P
    Option "Monitor-VGA2" "Configured Monitor"
    # For GeForce 210
    # Option "Monitor-VGA0" "Configured Monitor"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "True"
    EndSection

  3. #23
    Join Date
    Mar 2010
    Beans
    4

    Smile Re: Nvidia GeForce 9500 GT Driver Problems

    Sorry to post to this old thread, but after searching all day for an answer the very same issue with this same video card, I was guessing that others might be interested in what worked for me.

    After a kernal update my video stopped working. I had my PC connected to my flat screen monitor via a vga cable, which apperently was causing the problem, The log file mentioned that it could not determine the monitor model number. Appearently, this card needs to be connected via a dvi cable in order to operate properly (or at all).

    Once I connected this video card to the monitor using a dvi cable, and then rebooted, the high resolution started working perfectly. Just in case I am not the last person on Earth to upgrade to DVI, I urge everyone to upgrade to DVI cables ASAP.

    I hope this helps.

  4. #24
    Join Date
    Feb 2008
    Location
    Johannesburg, RSA
    Beans
    19

    Smile Re: Nvidia GeForce 9500 GT Driver Problems

    @geraldgrogan - Thanks so much I have been scratching my head about this issue for some weeks now and you have provided the rather obvious I guess solution. I switched to the DVI cable for my monitor and it now works perfectly, Nvidia driver can now see all the correct display settings from the monitor.

    I now got the correct resolution and all the correct screen options etc.


Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •