I noticed the release of amarok 2.1. I had tried 2.0.x, but the dealbreaker was missing support for media devices (specifically UMS). Currently, I am using the 1.x branch until that issue is fixed....so, is it yet? or should I stick with what I have?