Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: mpd with mcp, ncmcp, ncmpc++

  1. #11
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    ha, it muust be frustrating alright, I know the feeling. Ya it doesn't change. It should be playing so.

    Try closing mplayer maybe and restarting mpd again? I remember when I was using ubuntu I sometimes had a problem when using rythmbox and trying to play sound with something else at the same time.

    Before you try that actually, try "cat /etc/group | grep mpd" and make sure that mpd is listed after audio. Just to make sure mpd is a member of the audio group.

    if it's not, try "sudo usermod -a -G audio mpd"
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  2. #12
    Join Date
    Aug 2007
    Beans
    68

    Re: mpd with mcp, ncmcp, ncmpc++

    Well... when I try to do the restart, it says it successfully stops mpd, but cannot restart it because: "unable to bind port 6600: Address already in use; Maybe MPD is still running? Aborted".

    Also, I have no 'groups' director/file, only 'group', and when running the command you suggest I get no output...

    Thanks for the patience!

  3. #13
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Ya, sorry I meant to type /etc/group !

    try "ps aux | grep mpd" to check if it's still running, and if you want to force it to quit you could do "sudo killall mpd"

    The group thing could be your problem so. I think mpd should be a member of groups mpd and audio.

    try "groups mpd"
    If it's not a member of audio try "sudo usermod -a -G audio mpd" and fingers crossed it might work!

    Edit: On mine I get
    [me@arch_laptop ~]$ groups mpd
    audio mpd
    Last edited by dioltas; June 8th, 2009 at 03:53 PM.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  4. #14
    Join Date
    Aug 2007
    Beans
    68

    Re: mpd with mcp, ncmcp, ncmpc++

    Cool. mpd was still running and I killed it. "groups mpd" did return audio. I still ran the line you mention "sudo usermod -a -G audio mpd". Then running mpd or mpc gives me an error, 'problems opening file /etc/mpd.conf for reading: Permission denied' and 'problems connecto to "localhost" on port 6600' respectively. However, I did follow the steps for setting permissions on the wiki you sent me, so I have no clue why that may be!

    Actually, on mine I get
    user@usercomp$ groups mpd
    audio
    Last edited by bgc; June 8th, 2009 at 04:02 PM.

  5. #15
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    try starting it as root. I think mpd starts as user root then changes itself to user: mpd.

    If mpd was already a member of audio, then that command shouldn't make any difference...
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  6. #16
    Join Date
    Aug 2007
    Beans
    68

    Re: mpd with mcp, ncmcp, ncmpc++

    Ah ok... so it does start, but still no sound!

    Also, is it normal for it to use substantial amounts of CPU? Because while it's running it seems to do so!

  7. #17
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Ya that's weird. Mine is using 1.7% of my cpu and 1.1% of my memory at the moment. I'm trying to think why it wouldn't play any sound.

    Maybe mpd isn't detecting your settings properly at startup. There is some troubleshooting for that here
    http://wiki.archlinux.org/index.php/...tection_failed
    (Same guide).

    Is mpd also a member of mpd as well as audio? Maybe that could be something to do with it?

    Edit: After I finished typing this I checked again and it had jumped to nearly 5 % of the cpu, right now its 4%. I had it paused before I started typing.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  8. #18
    Join Date
    Aug 2007
    Beans
    68

    Re: mpd with mcp, ncmcp, ncmpc++

    I have no idea of not being part of the mpd group is an issue, nor how that can be changed!

    I followed the indications on the website, and uncommented those parts of the mpd.conf files, and started mpd again. This time a file seems to start playing but then stops. mpc status shows nothing.

    When running mpd was taking about 100% of one of two CPUs! I remember reading somewhere that it could be because it was resampling the music continuously, or something like that. So I'm hoping there's an option somewhere to change that, because otherwise the 'lightweight' goes out of the window!

  9. #19
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Just do "groups mpd" again and the output should be mpd audio.
    If it's not you could do "sudo usermod -a -G audio mpd" to add it.

    I don't know if that will make a difference tbh...
    Maybe undo those changes so from that site.

    Christ, 100% of a cpu is definitely not right! mpd is supposed to be light weight alright. Must be something wrong there!

    Maybe your best bet would be to wipe mpd from your system and start fresh. You said you installed it with synaptic and it won't let you remove it? Hope all this hassle is worth it in the end for you!
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  10. #20
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Oh ya, meant to suggest earlier try having a look at /var/log/mpd/mpd.log and /var/log/mpd/mpd.error. Maybe post them up, might clear up a few things.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •