Results 1 to 5 of 5

Thread: Korean Keyboard

  1. #1
    Join Date
    Jun 2009
    Beans
    2

    Korean Keyboard

    As a new user of ubuntu (9.04 jaunty) using gnome, I am trying to install Hangul - the Korean script - so that I can switch between English and Korean. (I don't want Korean as the default language.)

    I installed the available Korean keyboard via "System>Preferences>Keyboard>Layouts>Add>Korea , Republic of." I also installed the language software via "System>Administration>Language Support>Add/Install Languages>Korean."

    However, I notice after selecting "System>Preferences>Keyboard>Layouts>Add>Korea , Republic of," it gives me a preview of the keyboard that it will switch to. The problem is that it isn't Hangul! It's still Roman text.

    The other problem is that of swtiching between the "USA" keyboard setting and the "Korea Republic of" setting. It just does not seem to switch. Even after I hit the two "alt" keys together (the default setting for switching the language" -- or when I manually click on the Keyboard indicator to try and change it -- it still reads "USA."

    A little help?

  2. #2
    Join Date
    Jun 2009
    Beans
    2

    Re: Korean Keyboard

    Oops, nevermind the issue of switching the layout. I can just click on it, and it will switch. That's no problem.

  3. #3
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: Korean Keyboard

    bump

    I am also having trouble getting my keyboard to type in Korean. The preview picture of the keyboard is Roman letters, as Weohstan pointed out. Pressing the Hangul key does nothing.

    Ideas?

    Ubuntu 9.04 - liveCD

  4. #4
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: Korean Keyboard

    Anybody? Please? Are there no Ubuntu users who type in Hangul (Korean alphabet)? I am spending the summer in Seoul, where everybody uses IE6 and hasn't even heard of Firefox (much less Linux), and they marveled at the liveCD. But how are they supposed to take Ubuntu seriously if it cannot type the Korean alphabet?

    Thanks!

  5. #5
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: Korean Keyboard

    Oy vey,

    Well I figured it out, for those who are interested.

    1. In a terminal, type
      Code:
      sudo apt-get install nabi
    2. Open or create the file .gnomerc in your home folder
    3. Enter the following lines in /home/USER/.gnomerc
      Code:
      export XMODIFIERS="@im=nabi"
      export GTK_IM_MODULE=xim
    4. Go to System->Preferences->Startup Applications
    5. In the Startup Programs tab, click Add
    6. For the Name field, type Nabi, for the Command field, type
      Code:
      /usr/bin/nabi
    7. Log out of your session then log back in


    Thanks to tiger338 at http://ubuntuforums.org/showthread.php?t=30517#3 for the solution.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •