Results 1 to 8 of 8

Thread: NVidia settings won't stick

  1. #1
    Join Date
    Jun 2006
    Location
    Groeswen, South Wales
    Beans
    334
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    NVidia settings won't stick

    Hi,
    Just upgraded to 9.04. Everthing works except for one small irritation.
    Upon startup, the screen resolution is set too low.
    So, I go to System>Preferences>display and up pops a window that says,"It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphic driver vendor's tool instead............so I click yes even though I'm wary of using anybody else's tool.
    Up pops the NVidia Xserver window.
    It's easy to set the correct resolution and then the screen becomes wonderfully usable.
    When I click on Save to XConfiguration file it tells me that it is unable to remove the old XConfig file.
    I'm expecting that I might need a spanner to do that?

    Any ideas?

    Phil
    Most of the time, some things work.
    Some of the time, most things work .
    No matter how hard I try,
    I can't get most things working most of the time?

  2. #2
    Join Date
    Mar 2009
    Beans
    26

    Re: NVidia settings won't stick

    Same here.

    On reboot, it just keeps getting back to its low-res state.


    Anyone???

  3. #3
    Join Date
    Feb 2006
    Location
    Adelaide, South Australia
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: NVidia settings won't stick

    In Gnome:

    Alt-f2 to bring up a run prompt.

    Code:
    gksudo nvidia-settings
    Linux Mint 8 64 Bit | Intel Core 2 Duo CPU E8500 @ 3.80GHz (OC) | 4GB Kingston RAM | Asus P5Q Delux Motherboard | Asus EN9800GT (NVIDIA) | WD 120GB / WD 720GB SATA2 HDDs

  4. #4
    Join Date
    Jan 2008
    Beans
    4,311

    Re: NVidia settings won't stick

    No, it does not need root.

    If you are running GNOME, go to preferences -> Sessions, or if not it is something like Started Applications. Add an entry with this being the command.
    Code:
    /usr/bin/nvidia-settings -l
    If you are running KDE, go to the system settings, advanced, autostarted apps, and add a similar entry.

    The -l is important.

    The Nvidia settings needs to be run as your user, running as root will cause it to work for the user root. Autostarting it when you log in should cause it to take effect before all OpenGL applications.

  5. #5
    Join Date
    Jun 2006
    Location
    Groeswen, South Wales
    Beans
    334
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: NVidia settings won't stick

    Solved..........easily.
    Where it says "It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphic driver vendor's tool instead..
    Pick NO.......and a window pops up that lets you set your screen resolution. And this time it came back perfectly after shut down.
    Thanks,
    Phil
    Most of the time, some things work.
    Some of the time, most things work .
    No matter how hard I try,
    I can't get most things working most of the time?

  6. #6
    Join Date
    Feb 2006
    Location
    Adelaide, South Australia
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: NVidia settings won't stick

    Quote Originally Posted by NightwishFan View Post
    No, it does not need root.

    If you are running GNOME, go to preferences -> Sessions, or if not it is something like Started Applications. Add an entry with this being the command.
    Code:
    /usr/bin/nvidia-settings -l
    If you are running KDE, go to the system settings, advanced, autostarted apps, and add a similar entry.

    The -l is important.

    The Nvidia settings needs to be run as your user, running as root will cause it to work for the user root. Autostarting it when you log in should cause it to take effect before all OpenGL applications.
    Aha! Thanks for clearing that up. Another Nvidia trick to put up the sleeve. I was assuming root was needed in order to save the wanted config to xorg.conf.

    -l, --load-config-only
    Load the configuration file, send the values specified therein to the X server, and exit. This mode of operation is useful to
    place in your .xinitrc file, for example.
    Linux Mint 8 64 Bit | Intel Core 2 Duo CPU E8500 @ 3.80GHz (OC) | 4GB Kingston RAM | Asus P5Q Delux Motherboard | Asus EN9800GT (NVIDIA) | WD 120GB / WD 720GB SATA2 HDDs

  7. #7
    Join Date
    Feb 2006
    Location
    Adelaide, South Australia
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: NVidia settings won't stick

    Quote Originally Posted by groeswenphil View Post
    Solved..........easily.
    Where it says "It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphic driver vendor's tool instead..
    Pick NO.......and a window pops up that lets you set your screen resolution. And this time it came back perfectly after shut down.
    Thanks,
    Phil
    Glad you got it working.
    Linux Mint 8 64 Bit | Intel Core 2 Duo CPU E8500 @ 3.80GHz (OC) | 4GB Kingston RAM | Asus P5Q Delux Motherboard | Asus EN9800GT (NVIDIA) | WD 120GB / WD 720GB SATA2 HDDs

  8. #8
    Join Date
    Jan 2008
    Beans
    4,311

    Re: NVidia settings won't stick

    There is a way to get it to autostart with the xorg.conf I believe, perhaps that xinit file they mention. My way works well enough for me.

    Also, if you use a WM, such as fluxbox, they normally have their own autostart configuration file to add the command in.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •