Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: PC now starts with server login instead of Unity desktop

  1. #1
    Join Date
    Dec 2008
    Location
    Duluth, GA
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    PC now starts with server login instead of Unity desktop

    I recently made a few changes to my PC (Ubuntu 12.04 LTS Desktop):

    • Update and upgrade
    • Installed openssh-server so I could check on the computer remotely
    • Installed fail2ban


    Now when I start the computer, I get the server login screen instead of the Unity desktop. If I run startx it just locks up the computer.

    How can I get the desktop to show up again?
    Last edited by clay7; October 9th, 2012 at 08:23 PM. Reason: forgot to add the update and upgrade info

  2. #2
    Join Date
    Feb 2012
    Location
    Athens, Alabama
    Beans
    630
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: PC now starts with server login instead of Unity desktop

    What happens when you do the following...
    1. log out of your session
    2. log back in and select the icon next to your user name.
    3. Select unity
    4. Log in

    This should log you back into Unity. Try to reboot and see if it remains as your default log in (Unity that is).

  3. #3
    Join Date
    Dec 2008
    Location
    Duluth, GA
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PC now starts with server login instead of Unity desktop

    If I log out and log back in, I'm in the same situation.

    When my computer turns on, it shows the purple Ubuntu screen and then goes straight to the server-style logon (black screen, white text only, no graphics).

  4. #4
    Join Date
    Feb 2012
    Location
    Athens, Alabama
    Beans
    630
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: PC now starts with server login instead of Unity desktop

    So there is no icon next to your username at log in for you to change the theme you are logging into?

  5. #5
    Join Date
    Dec 2008
    Location
    Duluth, GA
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PC now starts with server login instead of Unity desktop

    Thanks - no, there are no graphics at all. It looks exactly like the Ubuntu server login screen.

    I've tried editing the GRUB file with "nomodeset" instead of "quiet splash" but that didn't work.

    My guess is that this is related to the ATI drivers of the graphics card. Google shows several other instances of this problem. Unfortunately, so far I haven't found the solution...

  6. #6
    Join Date
    Feb 2012
    Location
    Athens, Alabama
    Beans
    630
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: PC now starts with server login instead of Unity desktop

    What about trying

    Code:
    sudo apt-get install gnome
    Then once this is completed....reboot your system and try the log in again.

  7. #7
    Join Date
    Dec 2008
    Location
    Duluth, GA
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PC now starts with server login instead of Unity desktop

    I did

    Code:
    sudo apt-get install gnome-panel
    and rebooted, and it still went back to the server login screen. I tried "startx" and it again locked up the system.

  8. #8
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: PC now starts with server login instead of Unity desktop

    try ctrl+alt+f7 to switch to tty7 (if it doesn't say tty7). if that doesn't produce your login screen then I'd check your syslog and kern.log to see what errors it's giving you
    Code:
    less /var/log/syslog
    less /var/log/kern.log
    edit: I'd also check to see if you have a login manager running
    Code:
    ps -e | grep dm$
    it should list either lightdm or gdm if you have one up
    Last edited by HiImTye; October 9th, 2012 at 12:03 PM.

  9. #9
    Join Date
    Dec 2008
    Location
    Duluth, GA
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PC now starts with server login instead of Unity desktop

    Code:
    ps -e | grep dm$
    returned nothing. Also, tried ctrl+alt+f7 but this just froze the computer.

    /var/log/kern.log showed some interesting things:

    Code:
    fb0: VESA VGA frame buffer device
    init: gdm main process (963) killed by TERM signal
    fglrx_pci 0000:03:00:0: irq 42 for MSI/MSI-X
    [fglrx] Firegl kernel thread PID: 1076
    [fglrx] Firegl kernel thread PID: 1077
    [fglrx] Firegl kernel thread PID: 1078
    [fglrx]IRQ 42 Enabled
    [fglrx] Gart USWC size:628 M.
    [fglrx] Gart cacheable size:247 M.
    [fglrx] Reserved FB block: Shared offset:0, size:1000000
    [fglrx] Reserved FB block: Unshared offset:fb07000, size:1f9000
    [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000
    [fglrx] IRQ 42 Disabled
    init: lightdm main process (964) terminated with status 1
    ip_tables: (C) 2000-2006 Netfilter Core Team
    init: plymouth-stop pre-start process (1140) terminated with status 1
    {some lan settings}
    init: failsafe-x main process (1088) terminated with status 1
    I have both lightdm and gdm installed but it looks like neither is running. I've tried
    Code:
    sudo apt-get -f install
    and that did nothing either.

    Any thoughts?
    Last edited by clay7; October 9th, 2012 at 08:24 PM.

  10. #10
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: PC now starts with server login instead of Unity desktop

    you have both installed simultaneously? I'd try these

    Code:
    sudo /etc/init.d/lightdm stop
    sudo /etc/init.d/gdm stop
    sudo /etc/init.d/lightdm start
    if that fails then
    Code:
    sudo less /var/log/lightdm/lightdm.log

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •