Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: external hard drive now read-only

  1. #1
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Cool external hard drive now read-only

    Hi,

    I went to do my usual backup to my external hard drive and received a failure message. My external hard drive is now read-only. Could someone please post a fix?

    Cheers

    meanstreak

  2. #2
    Join Date
    May 2009
    Location
    Chennai, India
    Beans
    113
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: external hard drive now read-only

    Maybe it has overheated and so become unstable. It has happened to me twice. Let it cool down for a while. If you want it quick, put it in the freezer. After that it'll become alright. I did the same when this situation arose. If it is a software problem then you can use become root and edit it.

  3. #3
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: external hard drive now read-only

    Thanks - this is a software problem. I need instructions on how to modify the permissions on the drive so I can write to it.

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Cool Re: external hard drive now read-only

    Still no answers? Could someone please provide me with a fix - I need to urgently backup my files.

  5. #5
    Join Date
    Dec 2008
    Beans
    94

    Re: external hard drive now read-only

    How do you mount the drive? Do you just plug it in and let it automount? Or have you put a line in your fstab to mount it for you?

    I would think manually mounting the drive as read-write should fix things.

    First figure out what the drive is recognized as by the OS. My external drive is /dev/sdb1. If it's mounted now you should be able to check in the terminal with the command
    Code:
    df
    If it's not mounted you can see all drives on the system with
    Code:
    sudo fdisk -l
    If that goes ok, you know its being recognized properly and we can tell you what to do next.

    Easiest way is probably to unmount it with
    Code:
    sudo umount /path/to/disk
    Then remount it forcing it be read-write with something like
    Code:
    sudo mount -w /dev/sdb1 /where/you/want/it/mounted
    If your disk is not /dev/sdb1, replace that with what it is on your system.

    If that doesn't solve things, then you may need to modify the permissions of the directories on the drive. Something like
    Code:
    sudo chmod -R +rw /path/to/drive
    will make all files on the drive read-write for all users. This may not be what you want. With a more detailed description of what you want, you can get more precise help.
    Last edited by jowilkin; May 30th, 2009 at 07:43 AM.

  6. #6
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: external hard drive now read-only

    Hi thanks very much for the post. Okay, I unmounted the drive (/dev/sdc1) and then re-mounted it then changed the permissions using the chmod command. Still no joy.

  7. #7
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Unhappy Re: external hard drive now read-only

    It gets better - now when I turn the HDD on again - I cannot mount it at all.
    Attached Images Attached Images

  8. #8
    Join Date
    Dec 2008
    Beans
    94

    Re: external hard drive now read-only

    Never had that happen, here is another thread on that issue http://ubuntuforums.org/showthread.php?t=1048101

  9. #9
    Join Date
    May 2009
    Location
    West of the Pecos
    Beans
    36
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: external hard drive now read-only

    I used this command after I first connected a drive that had been intialized:

    chown -R username:username /media/drivelabel

    (where "username" is my login username and "drivelabel" is the actual name of the volume)

    This made the drive "mine" so I could write to it.

  10. #10
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Beans
    108
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: external hard drive now read-only

    Quote Originally Posted by rumplestilts View Post
    I used this command after I first connected a drive that had been intialized:

    chown -R username:username /media/drivelabel

    (where "username" is my login username and "drivelabel" is the actual name of the volume)

    This made the drive "mine" so I could write to it.
    Thanks. On another post I found this command

    Code:
    sudo mv /media/.hal-mtab /media/.hal-mtab.anything
    which enabled me to mount the drive. Then I ran
    Code:
    chown -R charles:charles /media/disk
    . However I still cannot write to the external drive. This is beginning to boil my blood.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •