Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Getting Jack to produce sound with Hydrogen

  1. #1
    Join Date
    Jun 2008
    Beans
    68

    Getting Jack to produce sound with Hydrogen

    I've been having problems for many months, but now I'm determined to get Jack to work. I've been using Timidity for a synth in Rosegarden, but now I need other things (such as Ardour and Hydrogen) which need Jack to synchronize.

    So first, I want to get Hydrogen to work with Jack. When I go to preferences, the only option that produces a sound is ALSA. I am using a Sound Blaster Audigy card. And like I said, Timidity works fine as a synth. And Jack isn't producing any error messages. But Hydrogen (or any other program for that matter), when using Jack drivers, doesn't produce a sound under any settings.

    Jack settings:

    http://img148.imageshack.us/img148/1...cksettings.png

    Hydrogen settings:

    http://img43.imageshack.us/img43/627...ensettings.png

  2. #2
    Join Date
    Jun 2008
    Beans
    68

    Re: Getting Jack to produce sound with Hydrogen

    Another interesting thing, when I uncheck Enable Track Outputs everything works fine, but with no audio. When I check it then Hydrogen gives me error messages. Not sure what that's all about.

  3. #3
    Join Date
    Jan 2008
    Beans
    4,757

    Re: Getting Jack to produce sound with Hydrogen

    Some nice small prerequesites I'd like to suggest:
    What kernel do you use?

    Ubuntu offers a kernel with patches/tweaks for realtime responses.
    Code:
    sudo apt-get install linux-image-2.6.28-3-rt
    Alternately, you can download the 2.6.29 kernel, apply the patches to enable realtime processing and build using make-kpkg.

    The primer being the most simplest way, of course

    Next, edit the limits.conf file:
    Code:
    gksu gedit /etc/security/limits.conf
    and put in
    Code:
    @audio - memlock 512000
    @audio - rtprio 99
    @audio - nice -10
    Near the bottom before "# End of file"

    Save and quit, then run:
    Code:
    sudo usermod -a -G audio $USER
    To ensure that you are part of the audio group, then reboot into the new realtime kernel.

    In the JACK Setup window, you can check the "Realtime" parameter now.

    To the point of your question though:
    Start the JACK Server, then run Hydrogen.
    After Hydrogen starts, switch to the JACK window and click the Connect button, and you should be able to connect up the input/output between the soundcard and application/s

    Regards
    Iain
    Last edited by ibuclaw; May 27th, 2009 at 02:29 AM.

  4. #4
    Join Date
    Jun 2008
    Beans
    68

    Re: Getting Jack to produce sound with Hydrogen

    Wow, thanks for you input, Jack works now! And so do the other Jack programs, all except for Rosegarden. Everything works as normal on Rosegarden (including the Jack transport), but there is simply no sound. I think this has to do with Timidity, since it still pops up in the connections. I'm not sure how to end Timidity. Plus, if I do, I don't know how to then get Rosegarden to use Jack as its synth. I tried going through the connections in Jack, and even if I disconnected Timidity and Rosegarden, they stayed connected.

    Anyways, here's a couple screenshots of the Rosegarden Midi settings if it's helpful:

    http://img26.imageshack.us/img26/819...eralsettin.png

    http://img245.imageshack.us/img245/5...gardenmidi.png

    Again, thank you so much for your effort.

  5. #5
    Join Date
    Mar 2008
    Beans
    241

    Re: Getting Jack to produce sound with Hydrogen

    Sorry to hijack the thread a bit, but I'm unclear on a couple of things

    Tinivole - you say

    'Next, edit the limits.conf file:
    Code:

    gksu gedit /etc/security/limits.conf

    and put in
    Code:

    @audio - memlock 512000
    @audio - rtprio 99
    @audio - nice -10

    Near the bottom before "# End of file"'

    In mine, those three lines come after '# End of file'. Everything still seems to work fine though. Does it matter? If I do

    grep audio /etc/security/limits.conf

    I get

    @audio - rtprio 99
    @audio - nice -19
    @audio - memlock unlimited

    I assume this is okay?

    The other thing is, you say to download a kernel and then apply patches. Should they all be applied or just some? If it's just some, how do I know which ones?

    Sorry for the daft questions, but I don't know the answers.

    Thanks.
    Last edited by howefield; December 23rd, 2015 at 01:41 PM.

  6. #6
    Join Date
    Jan 2008
    Beans
    4,757

    Re: Getting Jack to produce sound with Hydrogen

    Quote Originally Posted by dawiba View Post
    Sorry to hijack the thread a bit, but I'm unclear on a couple of things

    Tinivole - you say

    'Next, edit the limits.conf file:
    Code:

    gksu gedit /etc/security/limits.conf

    and put in
    Code:

    @audio - memlock 512000
    @audio - rtprio 99
    @audio - nice -10

    Near the bottom before "# End of file"'

    In mine, those three lines come after '# End of file'. Everything still seems to work fine though. Does it matter? If I do

    grep audio /etc/security/limits.conf

    I get

    @audio - rtprio 99
    @audio - nice -19
    @audio - memlock unlimited

    I assume this is okay?
    Yep, that is fine. I suppose you are already running UbuntuStudio then.

    The other thing is, you say to download a kernel and then apply patches. Should they all be applied or just some? If it's just some, how do I know which ones?

    Sorry for the daft questions, but I don't know the answers.

    Thanks.
    That was just an optional alternative, if for some unknown reason the 2.6.26-3-rt kernel was not available in the repository.
    I choose to build my own, as I build systems rather than install them.


    Regards
    Iain

  7. #7
    Join Date
    Mar 2008
    Beans
    241

    Re: Getting Jack to produce sound with Hydrogen

    Quote Originally Posted by tinivole View Post
    Yep, that is fine. I suppose you are already running UbuntuStudio then.

    That was just an optional alternative, if for some unknown reason the 2.6.26-3-rt kernel was not available in the repository.
    I choose to build my own, as I build systems rather than install them.
    I'm actually running the regular Ubuntu with just the applications I want installed from the repositories. I'm running 2.6.26-3-rt kernel for music anyway, so I guess that's fine.

    Thanks for the reply
    Last edited by howefield; December 23rd, 2015 at 01:42 PM.

  8. #8
    Join Date
    Jan 2008
    Beans
    4,757

    Re: Getting Jack to produce sound with Hydrogen

    Quote Originally Posted by emu42 View Post
    Wow, thanks for you input, Jack works now! And so do the other Jack programs, all except for Rosegarden. Everything works as normal on Rosegarden (including the Jack transport), but there is simply no sound. I think this has to do with Timidity, since it still pops up in the connections. I'm not sure how to end Timidity. Plus, if I do, I don't know how to then get Rosegarden to use Jack as its synth. I tried going through the connections in Jack, and even if I disconnected Timidity and Rosegarden, they stayed connected.

    Anyways, here's a couple screenshots of the Rosegarden Midi settings if it's helpful:

    http://img26.imageshack.us/img26/819...eralsettin.png

    http://img245.imageshack.us/img245/5...gardenmidi.png

    Again, thank you so much for your effort.
    hmm... do synths work?

    If you can find one, I'd probably suggest that you use a GM soundfont/synth instead.

    Regards
    Iain

  9. #9
    Join Date
    Jun 2008
    Beans
    68

    Re: Getting Jack to produce sound with Hydrogen

    Well when Rosegarden is running by itself with Timidity, it works fine, but when I open up Jack and use other stuff, it doesn't have any audio.
    Last edited by emu42; May 27th, 2009 at 08:57 PM.

  10. #10
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Getting Jack to produce sound with Hydrogen

    Timidity is probably not connecting to jack. You should set rosegarden to use jack and close it and then start it again after you start jack or tell rosegarden to start jack. Personally I like to start jack first and then the apps and then connect them up with patchage.

    If you use patchage you can see all your applications and midi devices etc all in one place and can change connections by clicking on them. It really makes things so much easier.
    PMs will be ignored.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •