Results 1 to 7 of 7

Thread: Wifi won't reconnect after coming back from sleep mode

  1. #1
    Join Date
    Apr 2009
    Beans
    82

    Wifi won't reconnect after coming back from sleep mode

    Pretty much exactly what the title says. I have an Asus eeepc 1000he and whenever I close the laptop then open it back up and come out of sleep mode my wifi won't reconnect. It tries to connect for a while but then says it can't connect

  2. #2
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,543

    Re: Wifi won't reconnect after coming back from sleep mode

    you need to unload the modules first.

    gksudo gedit /etc/pm/config.d/config

    put:

    SUSPEND_MODULES="your-wireless-card driver"

    example: i use a usb wireless dongle, the driver is zd1211rw.
    Last edited by kerry_s; June 19th, 2009 at 04:14 AM.

  3. #3
    Join Date
    Apr 2009
    Beans
    82

    Re: Wifi won't reconnect after coming back from sleep mode

    how do I find out what my wireless card driver is?

  4. #4
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,543

    Re: Wifi won't reconnect after coming back from sleep mode

    Quote Originally Posted by cody7002002 View Post
    how do I find out what my wireless card driver is?
    in a terminal:
    lsmod

    i think it's "ath9k" on the eee's.

    SUSPEND_MODULES="ath9k"

  5. #5
    Join Date
    Apr 2009
    Beans
    82

    Re: Wifi won't reconnect after coming back from sleep mode

    Awesome, that worked. Thanks guys =)
    Last edited by cody7002002; May 25th, 2009 at 03:24 AM.

  6. #6
    Join Date
    Jul 2010
    Location
    Natal RN Brazil
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wifi won't reconnect after coming back from sleep mode

    I can't find my wireless card driver of my dell inspiron mini 10.
    When i run "lsmod" I get the result attached

    Thanks in advance.
    Attached Files Attached Files

  7. #7
    Join Date
    Nov 2010
    Beans
    1

    Re: Wifi won't reconnect after coming back from sleep mode

    Hi,

    Just wanted to say thanks for this tip. I have a 1000HE too, with the same problem after installing Ubuntu 10.10 just now. Did a quick search and found this. So thanks again.

    So now I'm wondering why on earth this isn't default setting?!

    Kind regards

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •