Results 1 to 4 of 4

Thread: Blank screen at start, fan always on, broken charger

  1. #1
    Join Date
    Jul 2006
    Beans
    43
    Distro
    Ubuntu 10.04 Lucid Lynx

    Blank screen at start, fan always on, broken charger

    So I shut down my computer 2 nights ago and it was working fine, no updates installed either. I go to start it up the next day and the fan constantly runs and no signal is ever given to the screen. The processor light blinks more or less how it should on boot, but because there's no screen, it's hard to tell what it's really doing. I let it run for ~1.5 hours (it's current battery life) without any change.

    After letting the battery discharge, I plugged it back in for the night, only to find this morning that my charger light is out and it's making small beeping noises (indicating, I think, that my charger is broken). I'm tempted to call it related.

    Perhaps on a final note, the one I find most troubling, is that for several days now Sometimes moving my laptop, specifically in a way that shifts the DC input plug, would shutdown my computer instantly (as if the battery had been pulled out of a computer not plugged in, except that I have a battery and a plug). My next concern is that the hinge where the wires go up to the monitor and the DC input are in roughly the same spot physically....

    Are there any ideas, even to whether or not it's rescuable? It sounds like a hardware problem (it didn't do anything different when I put in my 8.04 CD) but I can't figure out what (aside from the charger) is broken.

    I'm going to try contacting System76 (I've got a 2 year old Gazelle Performance. And the monitor broke so it was replaced by Sys76 just last summer), but as always I thought I would check in with the reliable people here too.

    Thanks!

  2. #2
    Join Date
    Aug 2006
    Location
    St. Louis, MO, USA
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Blank screen at start, fan always on, broken charger

    You get absolutely no video output, the fan is running, and the laptop was really finicky when the DC plug is wiggled around a little. Sounds like your motherboard is dead or dieing.

  3. #3
    Join Date
    Jul 2006
    Beans
    43
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Blank screen at start, fan always on, broken charger

    Ouch. And I guess that's something you generally get a new computer for? :-/ This computer has been one pain in the butt after another -- I just had to get a new harddisk about 6 weeks ago.

  4. #4
    Join Date
    Aug 2006
    Location
    St. Louis, MO, USA
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Blank screen at start, fan always on, broken charger

    Quote Originally Posted by Lanky Juggler View Post
    Ouch. And I guess that's something you generally get a new computer for? :-/ This computer has been one pain in the butt after another -- I just had to get a new harddisk about 6 weeks ago.
    If it's under warranty I'd just try to get it fixed under that. If not, you might be able to get a new board for a decent price. Unfortunately most laptop motherboards also have their graphics cards, sound cards, and processors built onto them. It isn't like just buying a motherboard for a desktop and swapping all those things over. It probably isn't worth having a technician fix it outside of warranty.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •