Page 8 of 16 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 153

Thread: VirtualBox error: Kernel driver not installed (rc=-1908)

  1. #71
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    You have the kernel headers installed, right?

    Same with DKMS?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  2. #72
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    I think everyone needs to *think twice* before upgrading to a new version of Ubuntu, specially if it's not yet LTS, or if you're using it for your productivity.

    It's such a pain to see people, having troubles with a completely good and stable running system just yesterday, then it's broken all of a sudden.

    My advice: Downgrade your VirtualBox'es to older versions, if NOT, don't upgrade Ubuntu yet.

    Sorry that's all I can think of.
    It's OK, everything we know will become obsolete at some time.

  3. #73
    Join Date
    Jan 2009
    Beans
    54

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by CharlesA View Post
    You have the kernel headers installed, right?

    Same with DKMS?
    I goggled how to upgrade my kernel headers and got the following errors when I attempted this step. Please help.

    Code:
    root@data:~# sudo apt-get update
    Hit http://us.archive.ubuntu.com maverick Release.gpg
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en                
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US             
    Get:1 http://extras.ubuntu.com maverick Release.gpg [65B]                            
    Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en                            
    Get:2 http://security.ubuntu.com maverick-security Release.gpg [198B]                        
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en                 
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en           
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US               
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en                  
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US               
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en                    
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US                 
    Hit http://us.archive.ubuntu.com maverick-updates Release.gpg                                
    Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_US                         
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en                
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US             
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en          
    Get:3 http://extras.ubuntu.com maverick Release [57.3kB]                                     
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US              
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en           
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US        
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en           
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US        
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en             
    Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US          
    Get:4 http://security.ubuntu.com maverick-security Release [27.2kB]                          
    Ign http://extras.ubuntu.com maverick Release                                                
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US       
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en            
    Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US         
    Hit http://us.archive.ubuntu.com maverick Release                           
    Hit http://packages.medibuntu.org maverick Release.gpg                                       
    Ign http://packages.medibuntu.org/ maverick/free Translation-en                              
    Ign http://packages.medibuntu.org/ maverick/free Translation-en_US           
    Ign http://packages.medibuntu.org/ maverick/non-free Translation-en          
    Ign http://packages.medibuntu.org/ maverick/non-free Translation-en_US       
    Ign http://extras.ubuntu.com maverick/main i386 Packages/DiffIndex           
    Hit http://us.archive.ubuntu.com maverick-updates Release                    
    Hit http://packages.medibuntu.org maverick Release                                           
    Hit http://extras.ubuntu.com maverick/main i386 Packages                                     
    Hit http://us.archive.ubuntu.com maverick/main Sources                       
    Hit http://us.archive.ubuntu.com maverick/restricted Sources                 
    Hit http://us.archive.ubuntu.com maverick/universe Sources
    Hit http://us.archive.ubuntu.com maverick/multiverse Sources
    Hit http://us.archive.ubuntu.com maverick/main i386 Packages
    Hit http://us.archive.ubuntu.com maverick/restricted i386 Packages
    Hit http://us.archive.ubuntu.com maverick/universe i386 Packages
    Hit http://packages.medibuntu.org maverick/free i386 Packages                
    Hit http://us.archive.ubuntu.com maverick/multiverse i386 Packages
    Hit http://us.archive.ubuntu.com maverick-updates/main Sources
    Hit http://us.archive.ubuntu.com maverick-updates/restricted Sources 
    Hit http://us.archive.ubuntu.com maverick-updates/universe Sources   
    Hit http://us.archive.ubuntu.com maverick-updates/multiverse Sources
    Hit http://us.archive.ubuntu.com maverick-updates/main i386 Packages
    Get:5 http://security.ubuntu.com maverick-security/main Sources [12.7kB]
    Hit http://packages.medibuntu.org maverick/non-free i386 Packages            
    Hit http://us.archive.ubuntu.com maverick-updates/restricted i386 Packages   
    Hit http://us.archive.ubuntu.com maverick-updates/universe i386 Packages
    Hit http://us.archive.ubuntu.com maverick-updates/multiverse i386 Packages
    Get:6 http://security.ubuntu.com maverick-security/restricted Sources [14B]
    Get:7 http://security.ubuntu.com maverick-security/universe Sources [3,279B]
    Get:8 http://security.ubuntu.com maverick-security/multiverse Sources [651B]
    Get:9 http://security.ubuntu.com maverick-security/main i386 Packages [36.3kB]
    Get:10 http://security.ubuntu.com maverick-security/restricted i386 Packages [14B]
    Get:11 http://security.ubuntu.com maverick-security/universe i386 Packages [13.1kB]
    Get:12 http://security.ubuntu.com maverick-security/multiverse i386 Packages [1,660B]
    Fetched 95.2kB in 1s (58.6kB/s)     
    Reading package lists... Done
    W: GPG error: http://extras.ubuntu.com maverick Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192
    root@data:~# 
    root@data:~# 
    root@data:~# apt-cache search linux-headers-$(uname -r)
    root@data:~# 
    root@data:~# sudo apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package linux-headers-2.6.32-21-generic
    E: Couldn't find any package by regex 'linux-headers-2.6.32-21-generic'

  4. #74
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Do you have the latest kernel? Maverick should be on 2.6.35.x

    The PGP key error is probably due to having extras.ubuntu.com in yer sources.list.
    Last edited by CharlesA; November 12th, 2010 at 09:07 PM.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  5. #75
    Join Date
    Jan 2009
    Beans
    54

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by CharlesA View Post
    Do you have the latest kernel? Maverick should be on 2.6.35.x
    Hmmm... This shows 2.6.32.x....

    Code:
    root@data:~# uname -a
    Linux data 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux
    That's odd because I could swear I upgraded to Maverick. Check this out:
    Code:
    root@data:~# cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=10.10
    DISTRIB_CODENAME=maverick
    DISTRIB_DESCRIPTION="Ubuntu 10.10"
    Did I screw-up the upgrade? What can I do to fix this?

  6. #76
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Yeah, that's strange.

    I don't know how to fix it outside of just doing a clean install of maverick.

    Maybe make a thread asking about in in General Help.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  7. #77
    Join Date
    Jan 2009
    Beans
    54

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by AlexanderDGreat View Post
    I think everyone needs to *think twice* before upgrading to a new version of Ubuntu, specially if it's not yet LTS, or if you're using it for your productivity.

    It's such a pain to see people, having troubles with a completely good and stable running system just yesterday, then it's broken all of a sudden.

    My advice: Downgrade your VirtualBox'es to older versions, if NOT, don't upgrade Ubuntu yet.

    Sorry that's all I can think of.

    Yep, you're right. I had no business leaving version 10.4. I reinstalled that and then reinstalled my headers. VirtualBox works fine once again.

    Thanks for the help fellas.

  8. #78
    Join Date
    Jun 2010
    Beans
    3

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Whenever you install a new kernel, you must rebuild the kernel module for virtualbox (vboxdrv). You can do this as follows:

    1) Bust open a prompt and determine your linux version:
    uname -r

    (In my case: 2.6.32-24-preempt)

    2) Install the linux headers for your version from Synaptic:

    (In my case: linux-headers-2.6.32-24, linux-headers-2.6.32-24-preempt, and linux-headers-2.6.32-24-generic)

    3) Reinstall virtualbox from Synaptic:

    (virtualbox-ose, virtualbox-ose-dkms, virtualbox-ose-qt)

  9. #79
    Join Date
    Sep 2006
    Location
    Huddersfield
    Beans
    85
    Distro
    Ubuntu 10.04 Lucid Lynx

    Unhappy Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Lucid Lynx. 2.6.32-27-generic #49-Ubuntu SMP i686 GNU/Linux


    I seem to have the same problem.

    After installing VBox 3.2.12 for Linux from VBox's page, I couldn't find the icon on my desktop, so, in a terminal:

    ****@linux-studio:~$ VirtualBox
    WARNING: The vboxdrv kernel module is not loaded. Either there is no module
    available for the current kernel (2.6.32-27-generic) or it failed to
    load. Please recompile the kernel module and install it by

    sudo /etc/init.d/vboxdrv setup

    You will not be able to start VMs until this problem is fixed.
    Running this returned:

    Failed to create the VirtualBox COM object.
    The application will now terminate.
    Start tag expected, '<' not found.
    Location: '/home/****/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.
    /home/vbox/vbox-3.2.12/src/VBox/Main/VirtualBoxImpl.cpp[535] (nsresult VirtualBox::init()).


    Result Code:
    NS_ERROR_FAILURE (0x80004005)
    Component:
    VirtualBox
    Interface:
    IVirtualBox {3f36e024-7fed-4f20-a02c-9158a82b44e6}
    So I loaded the module, via Synaptic, re-booted, & tried:

    ****@linux-studio:~$ sudo /etc/init.d/vboxdrv setup
    which returned:

    sudo: /etc/init.d/vboxdrv: command not found
    ????Duh????
    What next? Do I need to install other kernel modules? If so, which ones?
    And where, if necessary, do I insert the [start tag '<']?
    Last edited by archolman; December 12th, 2010 at 02:29 AM.
    Peace, love & The Archers!
    WinXPHome-SP3 DAW/ Ubuntu 10.04.2LTS Surf&BOINC,
    on
    AMD Athlon64, 2GbRAM

  10. #80
    Join Date
    May 2008
    Beans
    1

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Try taking a look at the Virtualbox.xml file in you "user"/.Virtualbox directory. Mine was blank. I could only start it as root. So i copied the Virtualbox.xml from roots folder to mine and was able to start it.

Page 8 of 16 FirstFirst ... 678910 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •