Results 1 to 9 of 9

Thread: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

  1. #1
    Join Date
    Aug 2006
    Beans
    4

    Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    After I upgrade to ubuntu ,my printer (Canon PIXMA iP1700) cannot work.I try to re-install the driver but it still cannot work. Anybody can give some advice ? Thanks !

  2. #2
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    Moved to general help

  3. #3
    Join Date
    Dec 2008
    Location
    Malaysia
    Beans
    11
    Distro
    Ubuntu 8.04 Hardy Heron

    Talking Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    Hello,

    I also had the same problem, but after a few hours googling around, I found a blog that give a complete instruction on how to install the driver. It is in Bahasa Melayu/Indonesia, I translated it.
    This steps should able to run on Canon printer types of iP1880, iP1700 and iP1980


    Okay, let start!

    1) First download the zipped file that contains the drivers here iP1880 + iP1700
    put the downloaded file at your Desktop.

    2) Open the terminal and run this commands line by line.
    Code:
    cd ~/Desktop/iP1880+iP1700
    sudo dpkg -i *.deb
    3)Open System → Administration → Printing → New Printer and choose your printer type (for me Canon iP1700). Click forward.

    4) Don't choose Select Printer from Database, choose Provide PPD File instead

    5) Then choose canonip1800.ppd by navigating the windows according to this
    /usr/share/cups/model/canonip1800.ppd

    6) Give name to your printer (Such as iP1700 or iP1880) and click Apply.

    7) Restart your Linux Box.

    8. After the restart process finish, open the terminal again and run this commands line by line.
    Code:
    cd /usr/lib
    sudo ln -s ./libtiff.so.4.2.1 ./libtiff.so.3
    9) Now, you should be able to print

    Cheers!!

    acknowledgement : Install Offline

  4. #4
    Join Date
    Nov 2008
    Beans
    26

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    AHH! Thank you SO much! I switched to linux probably 10 months ago, and haven't been able to find a single method to make my printer work until now. You've just made my life so much easier <3

  5. #5
    Join Date
    Dec 2005
    Beans
    324

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    Ok i have an ip1700 & started to follow ur steps. I assumed one must unzip the file into a iP1880+iP1700 directory. However, after step 2 i have unmet dependencies. cnijfiler-common & cnijfilter-ip1800series as i remember. What do i do now? TIA
    Last edited by jtmedin; June 23rd, 2009 at 03:38 PM.

  6. #6
    Join Date
    Jul 2009
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    Quote Originally Posted by jtmedin View Post
    Ok i have an ip1700 & started to follow ur steps. I assumed one must unzip the file into a iP1880+iP1700 directory. However, after step 2 i have unmet dependencies. cnijfiler-common & cnijfilter-ip1800series as i remember. What do i do now? TIA
    jtmedin,
    most likely you need to install libcupsys2.
    when you try to install via
    Code:
    dpkg -i *.deb
    scroll through the messages.

    do a
    Code:
    sudo apt-get install libcupsys2
    and that should solve the unmet dependencies for cnijfilter-*

  7. #7
    Join Date
    Jun 2009
    Beans
    12

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    Just wanted to report that everything works as mentioned above.

    First I had to install libcupsys2, then I followed baAng's instructions to the letter.

    It works. It works. IT WORKS !!!! And here I thought I had to buy a new printer.

    Many thanks to all.


  8. #8
    Join Date
    Oct 2008
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    THANK YOU SO MUCH FOR THIS! It worked! I can PRINT! Haha

  9. #9
    Join Date
    May 2005
    Beans
    8

    Re: Canon PIXMA iP1700 printer cannot work in ubuntu 9.04

    The directions above cause a broken dependency in 9.10 "Karmic". For Karmic follow these directions:
    http://tantos.web.id/blogs/how-to-ka...-ip1800-ip1900

    and use the ip1900 ppd included with the link above.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •