Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Skype says "Problem with audio playback."

  1. #1
    Join Date
    Mar 2007
    Beans
    354
    Distro
    Ubuntu 12.04 Precise Pangolin

    Skype says "Problem with audio playback."

    Hi, I have a Dell inspiron 1525. I recently installed Skype. In Skype, when I use the Skype Test Call, it says "Problem with audio playback". What does this mean? I have inbuilt microphone in my laptop.

  2. #2
    Join Date
    Nov 2007
    Beans
    21
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Skype says "Problem with audio playback."

    Quote Originally Posted by bhishan View Post
    Hi, I have a Dell inspiron 1525. I recently installed Skype. In Skype, when I use the Skype Test Call, it says "Problem with audio playback". What does this mean? I have inbuilt microphone in my laptop.
    Have you done the setup of your audio capture device in skype ?

    Either way change your audio playback device to pulse, see if that works? (worked for me)

    I am not on my ubuntu machine right now so cant help you with details. Hope it helped !

  3. #3
    Join Date
    Mar 2009
    Location
    E.U.
    Beans
    303
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Skype says "Problem with audio playback."

    I also am trying to set up skype on a dell inspiron 1521 for my wife, but can't get the mic to work.

    Holy cow, the sound works perfectly set to pulse, but the microphone does not. Any further suggestions?

  4. #4
    Join Date
    Nov 2007
    Beans
    21
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Skype says "Problem with audio playback."

    Quote Originally Posted by kiridude View Post
    I also am trying to set up skype on a dell inspiron 1521 for my wife, but can't get the mic to work.

    Holy cow, the sound works perfectly set to pulse, but the microphone does not. Any further suggestions?
    OK, try setting all your audio options to > Pulse < it should work.

    IF that does not work then just change the > audio input settings while keeping the others on Pulse < it should work too.

    Hope it helps.

  5. #5
    Join Date
    Feb 2009
    Location
    Southwest N.H.
    Beans
    352
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Skype says "Problem with audio playback."

    Welcome to the "Skype/Microphone Dilemma Club." Have you checked the microphone using Sound Recorder? If you can't record your voice on that app, then the issue should be fixable by tweaking some settings. I received some excellent advice on adjusting the microphone on this thread: http://ubuntuforums.org/showthread.php?t=1073884

    If the suggested fixes in that thread don't work for you, try checking out the recommended fixes on this thread: http://ubuntuforums.org/showthread.php?t=1153117. Although this fix involves a KDE audio mixer, it will also work in GNOME.

    Once you've applied the fixes, test your mic in Sound Recorder. If you can record your voice, you should be able to talk in Skype. Go to the Skype Options menu (Ctrl+o). Select Sound Devices from the left pane, and set everything to Default Device. Make sure the "Allow Skype to automatically adjust my mixer levels" box is unchecked.

    Good luck!
    Dell XPS M1330, 2GB RAM, Intel Duo-Core Processor 1.5 GHz
    Ubuntu 11.04, Win XP in Virtual Box
    Proud (but inactive) Member of the Ubuntu Manual Team
    Registered Linux User #490335 / Registered Ubuntu User #27482

  6. #6
    Join Date
    Mar 2009
    Location
    E.U.
    Beans
    303
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Skype says "Problem with audio playback."

    Thanks for your replies guys.

    I got skype working now by setting all the settings to "pulse" and enabling "capture" and "+50db" Mic" in "volume control." It may be my imagination, but I think the mic is louder like this. It is also important to go to the "Recording" tab to un-mute the mic settings as it seems that they are muted by default (?).

    PHEW! what a hassle! Skype has not tried hard enough and I will be researching alternatives such as ekiga, gizmo, etc. PLUS not being open source, who knows what eavesdropping agreements they may have...

    I am a paying customer for skype by the way...

  7. #7
    Join Date
    Mar 2007
    Beans
    354
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Skype says "Problem with audio playback."

    Heres a solution that worked for me. Use the following commands in terminal:

    killall pulseaudio
    sudo apt-get remove pulseaudio
    sudo apt-get install esound
    sudo rm /etc/X11/Xsession.d/70pulseaudio

    As you can see this method uninstalls pulseaudio and installs esound instead.

  8. #8
    Join Date
    Jan 2008
    Location
    London
    Beans
    115

    Re: Skype says "Problem with audio playback."

    Tacantra's first link solved everything for me.

    It seems that audio capture is muted by default. You have to make this available in Audio Control by selecting Preferences > Capture.
    This 'unlocks' a new tab in which you can turn up the capture volume, but be careful of too much and also switch of the audio playback to avoid feedback..

  9. #9
    Join Date
    Mar 2009
    Location
    México
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Skype says "Problem with audio playback."

    hi Bhishan..
    I am thinking in doing what you said, but your reply was some months ago...
    that still works??
    ..
    I've tried Ekiga before...ummh unfortunately not everybody have an account..

    While trying Skype beta 1.0.3.0.0.93 (on my Sony Vaio vgn-nr220fe)
    ....first...I could not make or receive any calls...(click on the "start call" green button but immediately finished..saying something like --problem with audio playback-- )

    So...I Changed my sound devices:
    "default"--> "pulse"
    like Kiridude suggested
    thanks Kiridude

    Now I can make the calls, but Skype works very slowly..... well; more like If a say something, appears 5 minutes later in the Mac of my sister ...I am able to see her with no problems...but cannot listen to her.....
    also I can make the call to the "skype test call"..but I cannot hear a thing..
    uhhmmm and If I want to "end call" with somebody...Skype does not allow it..so I have to kill the process in the terminal with top
    besides that....skype uses a lot of cpu 57->84% ...that's normal?

    well I am not an expert on
    computers...
    skype
    or
    Ubuntu..

    but I think every daily problem in our life have a solution or more than one.....
    so...can I have a more..faster conversation?...and listen to everybody else?
    it's the problem Ubuntu vs Mac?..
    ...
    Haven't tried anything yet with another Ubuntu user...

    or with windows users...
    I will tell you later...


    ps.
    btw...I think I heard something...that looks like Skype but it's free like Ekiga ...I was dreaming?

    2nd ps. If I have some mistakes in my english...well sorry it is not my native language.....

  10. #10
    Join Date
    Mar 2009
    Location
    México
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Skype says "Problem with audio playback."

    again me...sorry need email notification and I dunno how to change that...but by doing a new reply and changing the option on the notification type...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •