Do you have stuttering juddering agonizingly irritating flash playback? Look no further, here is your salvation.

1. Install CompizConfig Settings-Manager (either in Softwarecenter or terminal)
- terminal:
sudo apt-get install compizconfig-settings-manager

2. Open CompizConfig Settings-Manager
and open the Composite Plugin settings:
- Uncheck "Detect Refresh Rate"
- Set the "Refresh Rate" to "180" (this is not your monitors refresh rate)

3. Listen to some dubstep

Maybe it helps, if not - post some feedback