Here's the solution.

It worked fine for me.

1A. Get a web connection (another machine, another OS, whatever) if no wifi means no web for you (like me).

1B. Go here --

1C. Pick a mirror from the page in #2 and download wicd. Save the DEB somewhere you can get to it from Ubuntu. If you are on a different machine, put it on a memory stick or something.

1D. Boot Ubuntu Jaunty.

2. Open your package manager (ie Synaptic). Mark network-manager and network-manager-gnome for complete removal.

To do this, click in the big pane on the right and start typing "network". Once you see the packages network-manager and network-manager-gnome (already installed), right click each and select "mark for complete removal". Then click apply and let it do its stuff.

3A. If you did all the steps in #1, get your DEB file of wicd. Find it and double-click it. Install it.

3B. If you have internet working okay in Ubuntu Jaunty, stay in Synaptic and install wicd from there (it's in the universe).

4. You should now have "Wicd Network Manager" somewhere on your programs menu. If not, you may have to edit the menu to find it and put it in a submenu that is visible. (I had to).

5A. Go into wicd. Find your wireless network on the list. It should have a green bar next to it. The rest is easy. Click the little down-arrow next to the network name to display more info on the network. Click advanced settings and enter your encryption info (key etc). Make sure you have this information.

5B. If your network says "<hidden>", you will need to know your ESSID. Click the down-arrow next to the big "Network" button. Click hidden network. Enter your ESSID. Do this AGAIN (for some reason). If your network still says "<hidden>", don't worry.

6. Restart Ubuntu.

7A. Go into wicd again. If you had to enter your ESSID manually, you might see two networks here: one named with your ESSID, the other "<hidden>". If you do see TWO WIFI NETWORKS: disconnect from the hidden network (you'll notice it has the same IP as the named one). Untick the automatically connect tickbox. Make sure the named network (with your ESSID) has its auto connect box ticked. Also, check the advanced settings. They should still have your encryption info.

7B. If you had two wifi nets and did #7A, restart Ubuntu again.

8. Open wicd. You should see one network, named with your ESSID. It should be connected and working.

There you go.