Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Fail to query the GLX server vendor

  1. #11
    Join Date
    Feb 2009
    Beans
    2

    Re: Fail to query the GLX server vendor

    Quote Originally Posted by Libra289 View Post
    Hi XanGabriel,
    have you tried run the nvidia-bug-report.sh and do you have the API mismatch in the nvidia-bug-report.log?
    Yessir...

    NVRM: API mismatch: the client has the version 185.18.14, but
    NVRM: this kernel module has the version 180.44. Please
    NVRM: make sure that this kernel module and all NVIDIA driver
    NVRM: components have the same version
    I made sure I downloaded the 180.44 version... I used EnvyNG and it downloaded/installed 180.44-0ubuntu1... This was after already doing the wipe of nvidia files... I did have one error that said something about a /?/tsl/ having contents, and that it wouldn't do anything (this was during the uninstall process), but as it is blatantly clear that I am still fresh meat to ubuntu, I wasn't sure how to handle that, and google turned up some confusing things...

    Sorry I'm turning a fixed thread back into a hassle :/

  2. #12
    Join Date
    Oct 2007
    Beans
    3

    Re: Fail to query the GLX server vendor

    I have had a very similar problem to this after failing to upgrade my nvidia drivers manually to 185.18.14. After realizing my mistake, I went back into the restricted drivers manager and installed 180.44 (after struggling to get back into a working desktop). However, this left me unable to use desktop effects. glxinfo gave the exact same results as seen earlier in this thread. Here's how I fixed it, after much google searching:

    I started off by purging pretty much every single package that would be nvidia related. This did not completely purge my 185.18.14 installation though, since it's not really installed via the package system.

    In /usr/lib/, there are many symbolic links to various glx-related files also located in the same folder. I noticed for each symbolic link, there were two files it could refer to, one which ended in 185.18.14, and the other ending in 180.44. Some of these pointed to the 185 file, and others pointed to the 180 file.

    I used the following command to find all the symbolic links that pointed to 185 files (and find the 185 files themselves)
    Code:
    ls -lah | grep 185
    Change around the 185 if you have a different version of driver that you don't want to use. If anything pops up, they're going to need to get changed.

    For each symbolic link pointing to a 185 file, I changed the link to instead point to the 180 version using the following:
    Code:
    sudo ln -sf [file-ending-in-180.44] [symbolic-link-currently-pointing-to-185-file]
    Try the above ls command again to ensure that it no longer points to a 185 file. Once all the symbolic links have been changed, you'll be left over with a whole bunch of unused files ending in 185.18.14. It's probably best to move these somewhere else so they don't get in the way again.

    Code:
    sudo mv `ls | grep 185` [destination-directory]
    should do the trick.

    After this, I rebooted and enabled compiz again, and everything seemed to work. Good luck to everyone else, it's quite a problem.

  3. #13
    Join Date
    May 2006
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fail to query the GLX server vendor

    Quote Originally Posted by austonst View Post
    I have had a very similar problem to this after failing to upgrade my nvidia drivers manually to 185.18.14. After realizing my mistake, I went back into the restricted drivers manager and installed 180.44 (after struggling to get back into a working desktop). However, this left me unable to use desktop effects. glxinfo gave the exact same results as seen earlier in this thread. Here's how I fixed it, after much google searching:

    I started off by purging pretty much every single package that would be nvidia related. This did not completely purge my 185.18.14 installation though, since it's not really installed via the package system.

    In /usr/lib/, there are many symbolic links to various glx-related files also located in the same folder. I noticed for each symbolic link, there were two files it could refer to, one which ended in 185.18.14, and the other ending in 180.44. Some of these pointed to the 185 file, and others pointed to the 180 file.

    I used the following command to find all the symbolic links that pointed to 185 files (and find the 185 files themselves)
    Code:
    ls -lah | grep 185
    Change around the 185 if you have a different version of driver that you don't want to use. If anything pops up, they're going to need to get changed.

    For each symbolic link pointing to a 185 file, I changed the link to instead point to the 180 version using the following:
    Code:
    sudo ln -sf [file-ending-in-180.44] [symbolic-link-currently-pointing-to-185-file]
    Try the above ls command again to ensure that it no longer points to a 185 file. Once all the symbolic links have been changed, you'll be left over with a whole bunch of unused files ending in 185.18.14. It's probably best to move these somewhere else so they don't get in the way again.

    Code:
    sudo mv `ls | grep 185` [destination-directory]
    should do the trick.

    After this, I rebooted and enabled compiz again, and everything seemed to work. Good luck to everyone else, it's quite a problem.
    Holy carp, thank you so much. I followed your info to the letter, and my settings are all back.

    I was going nuts trying to scrounge around for that info. I did the same thing you did (tried to upgrade to 185). Lesson learned: dont fix the non-broken.

    Again, thank you.

  4. #14
    Join Date
    Oct 2008
    Location
    Costa Rica
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fail to query the GLX server vendor

    Just to put it all in one place.


    1. From a shell, make a directory

      I did this:

      Code:
      $ mkdir nvidia
    2. Download the latest drivers from nvidia

      http://www.nvidia.com/object/unix.html

      in my case it was: "NVIDIA-Linux-x86-185.18.14-pkg1.run"
    3. Set up file permissions:

      Code:
      $ chmod 777 NVIDIA-Linux-x86-185.18.14-pkg1.run
      you will need to put the name of the file you download here, if it isn't the same.
    4. Optional: open a non-Gui Terminal

      If you are running your shell so far from the gui X interface, then Open up a non-Gui Terminal:

      [Control]+[Alt]+[F2] (or [F3] etc ...)
    5. Optional: Login to your non-Gui Terminal

      -- you don't need to do this if you're not running x.
    6. Clean up all the old apt based packages:

      Code:
      $ sudo apt-get remove 'nvidia*'
    7. Optional: Turn off the X server

      -- don't worry about this if you're not running x.

      Code:
      $ sudo /etc/init.d/gdm stop
    8. Install the nvidia driver

      -- this will start a text-based colorful interface that should walk you through the install process, and then offer to rebuild your xorg.conf file, I suggest letting the installer handler this.

      Code:
      $ sudo sh NVIDIA-Linux-x86-185.18.14-pkg1.run
      * Note you will use the name of your downloaded package here

      -- If you have any errors, fix them then run this command again.

      (I had a few problems in this step, until I cleaned everything out with step 6 above)

      When everything is ok the last message should be something like:

      Code:
      Your X configuration file has been successfully updated.  Installation of
         the NVIDIA Accelerated Graphics Driver for Linux-x86 (version: 185.18.14) is
         now complete.
      Though obviously with the version that you used.
    9. Restart your X server

      Code:
      $ sudo /etc/init.d/gdm start
      This should show you your regular login screen.
    10. Log in and test your driver.

      Code:
      $ glxgears
      Should show a nice mini window display with three interlocking gears rotating.

      Or if you care to:

      Code:
      $ glxinfo
    11. Welcome to your video card

      Everything should be ok at this point.




    Jefkin

  5. #15
    Join Date
    Mar 2009
    Beans
    7

    Re: Fail to query the GLX server vendor

    Thanks Gefkin.

    I did a system update which caused this error. After hours of searching and failing your tip has fixed this!

  6. #16
    Join Date
    Aug 2009
    Beans
    1

    Re: Fail to query the GLX server vendor

    Confusing!

    The post starts with a how to rollback from 185 to 180 and ends with steps on how to install 185.

    I have the following problem:
    Failed to load /usr/lib/xorg/modules/extensions//libglx.so'
    Googling I found this thread that may solve my problem.
    But I am confused. Should I install 185 then rollback to 180 or in my case 173.14.12

    Thanks.

  7. #17
    Join Date
    Aug 2009
    Location
    Israel
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fail to query the GLX server vendor

    Thanks Jefkin! I had a same problem with my NVIDIA Driver. I did exactly that you wrote. It works!!!

  8. #18
    Join Date
    Apr 2008
    Location
    Midwest usa
    Beans
    378
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fail to query the GLX server vendor

    Hi... All I've been for a few weeks now trying to get my card working and I've gotten to the point where I get the "Fail to query the GLX server vendor"
    I have a GeForce4 MX 420 and have tried both the 96.43.05 and 71.86.04 drivers.

    After much trying on my own without success, I emailed Nvidia and here is there reponse to the error report I embedded below.

    Here is the error:

    dlopen: /usr/lib/xorg/modules/extensions//libglx.so: undefined symbol: _nv001254gl

    This generally indicates that there is a version mismatch between two
    driver components, usually because the driver was installed
    incorrectly. I would recommend uninstalling any Ubuntu or Envy driver
    packages that might be installed and trying the .run installer from
    nvidia.com instead.
    I ran thru Jefkins July 2 instructions with the driver I needed and everything when like a charm.
    Thanks....
    Last edited by Jonas thomas; August 22nd, 2009 at 12:09 PM.

  9. #19
    Join Date
    Mar 2008
    Beans
    1

    Re: Fail to query the GLX server vendor

    Quote Originally Posted by irotsoma View Post
    I had a similar problem. I was getting lots of errors including both of the above issues since installing the latest NVidia drivers 180.51. I had to uninstall them and go back to the 180.44 drivers. Use this in the directory where you have the driver file downloaded:

    sudo sh NVIDIA-Linux-x86-180.51-pkg1.run --uninstall

    That totally fixed the problem for me. Nothing else seemed to work. I searched everywhere. There must be a problem with the 180.51 drivers and Ubuntu.



    worked for me..THANKS! I have a 9800M

  10. #20
    Join Date
    Sep 2009
    Location
    Santa Catarina, Brasil
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Fail to query the GLX server vendor

    I had exactly the same problem of #1 post, witch was completly solved by jefkin's July 2nd, 2009 04:48 PM post.

    My hardware is HP Pavilion dv2000 Nvidia Geforce 8400M GS, tried to install drivers with "system > administration > Hardware drivers", Envyng, synaptics and with the nvidia.com's driver. The difference between others attemps was:
    Code:
    sudo apt-get remove 'nvidia*'
    Thanks Jefkin!

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •