Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Activating swapfile swap [fail] after 9.04 upgrade

  1. #1
    Join Date
    Sep 2007
    Location
    Seattle, USA
    Beans
    116
    Distro
    Ubuntu 10.04 Lucid Lynx

    Activating swapfile swap [fail] after 9.04 upgrade

    Hello! Fresh off an upgrade from 8.10 to 9.04 (NOT wubi, just the regular updater) and I'm having an issue at boot. I have the pretty boot screen turned off, so I see all the various system checks as they progress. Everything is [OK] until I get to ...

    Activating swapfile swap ... [fail]

    So far it doesn't seem to affect usage of any software or system functionality, but obviously I do not like for things to fail at boot and I suspect not having a working swap file is going to be an issue sooner or later.

    Cheers in advance for any suggestions.
    "I take it from your glum demeanor that your ill-advised foray into time-travel destroyed yet another reality."

  2. #2
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    maybe the upgrade formatted the swap, changing the UUID..just a guess...

    Does swap entry in

    sudo blkid

    match that in /etc/fstab?

  3. #3
    Join Date
    Sep 2007
    Location
    Seattle, USA
    Beans
    116
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    Quote Originally Posted by logos34 View Post
    Does swap entry in
    sudo blkid
    match that in /etc/fstab?
    Cheers for the fast reply! Perhaps you're on to something; the UUIDs match but the drive does not. However, the drive identifier in fstab is just a comment, so I don't really understand how that could be the issue. Here's what I have (red shows different drive identifiers):

    blkid:
    Code:
    /dev/sdb5: TYPE="swap" UUID="3bcc00b8-6d9f-4f39-bf6a-aab6d7c8edce"
    fstab:
    Code:
    # Entry for /dev/sdc5 :
    UUID=3bcc00b8-6d9f-4f39-bf6a-aab6d7c8edce none swap sw 0 0
    Can I just run mkswap /dev/sdb5 or will I blow something up?
    "I take it from your glum demeanor that your ill-advised foray into time-travel destroyed yet another reality."

  4. #4
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    no, the drive letter change doesn't affect it since it's using the uuid to find the partition

    check here for possible solutions

  5. #5
    Join Date
    Sep 2007
    Location
    Seattle, USA
    Beans
    116
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    Thanks for the link. I don't know why I couldn't find that when I was searching for a solution earlier. Anyway, here's what ended up fixing the problem:

    Code:
    sudo swapoff -a
    sudo mkswap -U <UUID> /dev/sdb5
    sudo swapon -a
    Thanks again! Now if someone can tell me how to mark this [SOLVED] I'd be all done here.
    Last edited by daqron; May 2nd, 2009 at 08:32 PM. Reason: Can't spell.
    "I take it from your glum demeanor that your ill-advised foray into time-travel destroyed yet another reality."

  6. #6
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    Quote Originally Posted by daqron View Post
    Now if someone can tell me how to mark this [SOLVED] I'd be all done here.
    for some reason they removed that option from thread tools. dunno why

    good luck

  7. #7
    Join Date
    Feb 2009
    Beans
    8
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    so i just installed xubuntu and on start up it gets to "swapfile swap" and then it just stops

  8. #8
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    I also wound be interested how to solve the problem when I can not start the system due to this problem at all.

    It is nice to says enter sudo and what ever, but my system hangs during the boot and does not recover. I tried the recovery mode, also here nothing.

    How to continue and correct something here?

    I think this must be a big bug in the 9.04 version, since it comes again and again, even after a new installation, not more then abt 20 starts are possible, then all ends up in swap file.

    Installtion with wubi seems not to be possible for that either any more.

  9. #9
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    have just noticed:

    there is an infinite size swap file created on boot.

    After some trying, managed to delete it and create new one according to the hwto.
    But on next boot, again system will hang with activating swap file...

    and creating infinitely big file for swap, going for ever apparently.


    Please can somebody help me to stop this swapfile thing to enable me to boot into ubuntu again?

    I can only remove the file by boot from CD, then setting all up again, just to find that on next boot it is back where it was.

    Any help appreciated.
    Last edited by ottosykora; September 4th, 2009 at 01:08 PM.

  10. #10
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Activating swapfile swap [fail] after 9.04 upgrade

    so far steps I done:

    managed to run the repair mode. Th eonly way to start it was to press ctrl+alt+del when the activating swap came up.

    Somehow managed to delete the swap file.
    Followed howtos to create new swap file, format it and made sure it is so in the fstab.
    swapon gives however kind of loop for ever, it simply seems to never end.

    before free -m gives all 0

    on next boot again it seems that there is an huge swap file created.

    Pls help

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •