Results 1 to 3 of 3

Thread: how to enable compiz-fusion on ubuntu 9.04 [guest], virtualbox 2.2.2, Vista [guest]

  1. #1
    Join Date
    Apr 2007
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    how to enable compiz-fusion on ubuntu 9.04 [guest], virtualbox 2.2.2, Vista [guest]

    Hi,

    I am not able to enable desktop effects or compiz-fusion (using fusion-icon).

    I am running ubuntu 9.04 [guest] in Vista [host] using virtualbox 2.2.2 on dell inspiron 1525. I have enabled 3d acceleration in virtualbox, installed the virtualbox addons and following is my xorg.conf setting.

    Code:
     
    $ cat /etc/X11/xorg.conf
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
    	Identifier	"Configured Video Device"
            driver          "vboxvideo"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	SubSection 	"Display"
    		Depth 		24
    		Modes		"1280x800"
    	EndSubSection
    EndSection
    Please help me enable compiz-fusion.

    Thanks
    Last edited by nariknahom; May 2nd, 2009 at 06:16 PM.

  2. #2
    Join Date
    Apr 2009
    Location
    Tallahassee, Florida
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: how to enable compiz-fusion on ubuntu 9.04 [guest], virtualbox 2.2.2, Vista [gues

    Ya, I'm having the same exact problem as you. I tried everthing but I think there must be some sort of problem with the 3-d exc. and virtualbox.

  3. #3
    Join Date
    Aug 2007
    Beans
    46

    Re: how to enable compiz-fusion on ubuntu 9.04 [guest], virtualbox 2.2.2, Vista [gues

    I have compiz-fusion with wobbly windows, desktop cube, animations, etc. working with Ubuntu 9.04 guest and Vista host. It's not the fastest, but it works. I'm using Virtualbox 3.0.4 with guest additions installed and with this xorg.conf:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"vboxvideo"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    So try getting the latest virtualbox and using this xorg.conf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •