Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: LXDE Ubuntu wireless

  1. #1
    Join Date
    Oct 2007
    Beans
    20

    LXDE Ubuntu wireless

    Hi,
    I just installed LXDE to save some memory on my laptop, but the only thing I can't figure out is how to connect to the internet wirelessly. Unlike, gnome and xfce, it doesn't seem as simple as an icon on the tray.
    So how exactly do you connect wireless in LXDE?

  2. #2
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,543

    Re: LXDE Ubuntu wireless

    install "wicd" or "network-manager-gnome"

  3. #3
    Join Date
    Mar 2009
    Location
    Northern Alberta, Canada
    Beans
    109
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: LXDE Ubuntu wireless

    Even better yet, you probably already have at least one of them installed (probably network-manager) if you're getting wireless in Gnome & XFCE. All I think you'll have to do is run either of the above programs to connect.

  4. #4
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,543

    Re: LXDE Ubuntu wireless

    Quote Originally Posted by spillin_dylan View Post
    Even better yet, you probably already have at least one of them installed (probably network-manager) if you're getting wireless in Gnome & XFCE. All I think you'll have to do is run either of the above programs to connect.
    yeah, if you do have gnome installed, just put "nm-applet &" in your startup.

  5. #5
    Join Date
    May 2005
    Location
    Birmingham UK
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: LXDE Ubuntu wireless

    Quote Originally Posted by kerry_s View Post
    yeah, if you do have gnome installed, just put "nm-applet &" in your startup.
    Thanks for this thread. Lxde uses a bit more than half the start up memory that Xubuntu needs (72 vs 130Mb, both with system monitor running).

    How do I put nm-applet into my startup so the panel icon appears and lets wifi/ G3 modem networking 'just work'?

    Ta

    Added Monday: http://ubuntuforums.org/showthread.php?p=7210414
    My question has been answered.
    Last edited by keithpeter; May 4th, 2009 at 12:49 PM. Reason: question answered in another thread

  6. #6
    Join Date
    Nov 2008
    Location
    Albuquerque, NM
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: LXDE Ubuntu wireless

    I got wireless to work and allowed the user to select a wireless hotspot using these procedures:

    Using the menu, open Accessories --> LXTerminal
    Open the autostart file for LXDE:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    Add the following line to enable wireless features for the user:
    @nm-applet

    Save the changes and reboot the system.

    The applet will show up in the lower right of the panel. You should be able to select a hotspot and edit connections conveniently henceforth.

  7. #7
    Join Date
    Apr 2007
    Location
    Milan
    Beans
    22
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: LXDE Ubuntu wireless

    Network-related icons can be VERY CONFUSING in LXDE but I think got the hang of it.

    This is on a 10.04 Lucid Lynx default fresh install + LXDE added on:
    - the network manager GNOME APPLET icon is one thing
    - the network status monitor LXDE PLUGIN is another animal
    - but THE ICONS ARE IDENTICAL, a pair of up-down arrows.

    To make most changes you can right click on the corresponding item.

    NETWORK STATUS MONITOR
    On the LXDE "Panel" you can add as many instances of "Network Status Monitor" as you need.
    Once they're on, the options of EACH of them allow you to monitor an ethernet or wifi interface.
    All monitor interfaces icons have the basic "arrows" icon that blink on traffic.
    If an interface is wireless, it also has a non-blinking radio wave symbol on its right.
    (I have no Bluetooth, G3 connections to report on).

    NETWORK MANAGER APPLET
    This is an applet, not a LXDE panel plugin. So to be displayed it needs to be hosted INSIDE a LDXE panel plugin called "System Tray" in the panel preferences. That is on by default, but if the applet does not show, make sure it is.
    Its icon is the same pair of up-down arrows but static (no blinking)-
    However, if there are no applets running, the "System Tray" has nothing to show, and is empty and practically invisible. If it's turned off, applets may be running but remain invisible.
    This applet is not activated in the default install default and it takes a text editor running in sudo mode to add the "@nm-applet" line in the "/etc/xdg/lxsession/LXDE/autostart" file as deinerson1 says. [Thank you! I wasted an hour looking for the correct invocation!].
    It can also be started from a terminal as normal user - in which case you'll see a stream of interesting messages as you make it do various things.

    It took me quite a while to figure it out. I keep two NSM's on. I also keep the System Tray with the NMA well away from the NSM's

  8. #8
    Join Date
    Apr 2008
    Beans
    25

    Re: LXDE Ubuntu wireless

    Quote Originally Posted by deinerson1 View Post
    I got wireless to work and allowed the user to select a wireless hotspot using these procedures:

    Using the menu, open Accessories --> LXTerminal
    Open the autostart file for LXDE:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    Add the following line to enable wireless features for the user:
    @nm-applet

    Save the changes and reboot the system.

    The applet will show up in the lower right of the panel. You should be able to select a hotspot and edit connections conveniently henceforth.

    Thought I would go mad 'til I found this thread.

    Many thanks

    Derek

  9. #9
    Join Date
    Jul 2011
    Beans
    1

    Re: LXDE Ubuntu wireless

    Quote Originally Posted by kerry_s View Post
    install "wicd" or "network-manager-gnome"


    _____________________________



    wireless usb mouse wireless keyboards buy wireless router

    All I think you'll have to do is run either of the above programs to connect.

  10. #10
    Join Date
    Jun 2007
    Location
    Brittany France
    Beans
    561
    Distro
    Lubuntu 11.10 Oneiric Ocelot

    Question Re: LXDE Ubuntu wireless

    Quote Originally Posted by deinerson1 View Post
    I got wireless to work and allowed the user to select a wireless hotspot using these procedures:

    Using the menu, open Accessories --> LXTerminal
    Open the autostart file for LXDE:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    Add the following line to enable wireless features for the user:
    @nm-applet

    Save the changes and reboot the system.

    The applet will show up in the lower right of the panel. You should be able to select a hotspot and edit connections conveniently henceforth.
    Thanx for this, as I too was facing a bleak future using 11.04 + gnome on a 512MB system.

    Is there any lighter weight desktop than lxde ? I'm happy with it so far but have no metrics to decide on one, other than a subjective feel.
    jimbo

    There is no spoon
    Best ubuntu pocket guide
    Can't believe, i've just spent 50 years writing COBOL code - oh, and i still love it

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •