Results 1 to 5 of 5

Thread: mt-daapd transcoding problem

  1. #1
    Join Date
    Apr 2009
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    mt-daapd transcoding problem

    Hi all

    i'm using mt-daapd to share my music with my Soundbridge.

    Since migration to jaunty, my ogg files are not transcoded to wav anymore and cannot be played on the soundbridge.

    in syslog, I found these messages :

    Error loading plugin /usr/lib/mt-daapd/plugins/ssc-script.so: plugin declined to load
    Error loading plugin /usr/lib/mt-daapd/plugins/ssc-ffmpeg.so: /usr/lib/mt-daapd/plugins/ssc-ffmpeg.so: undefined symbol: avcodec_decode_audio


    Any idea ?

    Thanks.

  2. #2
    Join Date
    Apr 2009
    Location
    Toronto
    Beans
    188
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: mt-daapd transcoding problem

    I'm starting to think that mt-daapd is not compatible with Jaunty, because I've experienced a complete inability to run it properly. I'll keep looking!

  3. #3
    Join Date
    Apr 2005
    Beans
    15

    Re: mt-daapd transcoding problem

    I recently upgraded to Jaunty and finally got around to trying to get mt-daapd / Firefly set up again. What a pain this was. I always built Firefly from source in the past because the earliest versions in Ubuntu didn't handle ogg transcoding. This time, however, it looks like Firefly isn't being developed or even maintained much. I couldn't get it to configure due to an error about avcodec.h not being found. I told the configure script where to find it but still no joy.

    Soooo I decided to try installing from aptitude as I read about the version in the repositories being able to handle the transcoding. Installed it and ran into problems right off the bat. Fix the problems with avahi with the last two posts in this thread: http://ubuntuforums.org/showthread.p...ly#post7335179

    Then my soundbridge could see the server but it couldn't play any ogg files. Sooo, edit /etc/mt-daapd.conf and comment out the items in the plugin section so it won't try to use ffmpeg to do transcoding. That section looks like this now:
    [plugins]
    #plugin_dir = /usr/lib/mt-daapd/plugins
    #plugins = rsp.so,ssc-ffmpeg.so

    Then where it says that the transcoding script is not needed because of ffmpeg, uncomment the codectypes that need to be transcoded:

    # Not needed because ffmpeg is enabled (all file types transcoded to wav.
    # If this behavior is undesired, see the [plugins] section and disable it,
    # or selectively disable codecs below with the never_transcode option.)
    # -joshk
    ssc_codectypes = ogg,flac,alac

    Then uncomment the pointer to the transcoding script:

    ssc_prog = /usr/bin/mt-daapd-ssc.sh

    But wait, there is no transcoding script! You can either get it from firefly svn or, easier, from here: https://bugs.launchpad.net/ubuntu/+s...903/comments/6 . That also has the wavstreamer binary you need. So, from that zip file, put mt-daapd-ssc.sh and wavstreamer in /usr/bin.

    But wait, there's more! One of those wants to use an old version of flac, so create a link for it: sudo ln -s /usr/lib/libFLAC.so.8.2.0 /usr/lib/libFLAC.so.7

    After all of that, I now have the same functionality I had in Intrepid. That's progress for you isn't it? I hope this saves somebody some hair. I tried different media servers but couldn't get anything else to work. At least my soundbridge is no longer a paper weight.

  4. #4
    Join Date
    Mar 2007
    Location
    UK
    Beans
    70
    Distro
    Ubuntu Development Release

    Re: mt-daapd transcoding problem

    dontodd, thanks for your post it really helped me getting flac playable in iTunes again.

  5. #5
    Join Date
    Jun 2008
    Beans
    7

    Smile Re: mt-daapd transcoding problem

    It works!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •