Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Drive in /etc/fstab not mounting

  1. #11
    Join Date
    Apr 2008
    Beans
    11,630

    Re: Drive in /etc/fstab not mounting

    Not sure if this is helpful or not, but in Ubuntu I always install pmount from synaptic which makes mounting usb drives a snap!

  2. #12
    Join Date
    Jun 2006
    Location
    $ pwd _
    Beans
    3,999
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Drive in /etc/fstab not mounting

    Quote Originally Posted by kansasnoob View Post
    Not sure if this is helpful or not, but in Ubuntu I always install pmount from synaptic which makes mounting usb drives a snap!
    Can pmount be used with fstab or mount devices at boot? The OP needs some partitions mounted on boot.

  3. #13
    Join Date
    Apr 2006
    Location
    Londrina, Brasil
    Beans
    200
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Drive in /etc/fstab not mounting

    Herewith a slight modification of fstab, with auto on one usb drive and not on the other:

    # External ext3 250 GB USB drive mounted as ext3backup
    UUID=0e6fb1ec-8847-4214-8834-1de48a9fb37a /media/ext3backup ext3 user,auto 0 0
    # External ext3 120 GB USB drive mounted as ext3backup2
    UUID=485f3260-d7be-4765-ae0d-43c5d9226546 /media/ext3backup2 ext3 user 0 0

    However, as I expected (as auto is the default) neither mounts at boot. Using sudo mount -a after boot does, however, mount them both.

    Thus, it is still a mystery....
    Aridus

  4. #14
    Join Date
    Nov 2006
    Location
    India
    Beans
    1,246
    Distro
    Ubuntu Development Release

    Re: Drive in /etc/fstab not mounting

    Quote Originally Posted by aridus View Post
    Herewith a slight modification of fstab, with auto on one usb drive and not on the other:

    # External ext3 250 GB USB drive mounted as ext3backup
    UUID=0e6fb1ec-8847-4214-8834-1de48a9fb37a /media/ext3backup ext3 user,auto 0 0
    # External ext3 120 GB USB drive mounted as ext3backup2
    UUID=485f3260-d7be-4765-ae0d-43c5d9226546 /media/ext3backup2 ext3 user 0 0

    However, as I expected (as auto is the default) neither mounts at boot. Using sudo mount -a after boot does, however, mount them both.

    Thus, it is still a mystery....

    Try this
    Code:
    UUID=485f3260-d7be-4765-ae0d-43c5d9226546 /media/ext3backup2 ext3 defaults 0 0

  5. #15
    Join Date
    Apr 2008
    Beans
    81

    Re: Drive in /etc/fstab not mounting

    i was just curiuos what is this uuid thing ?

  6. #16
    Join Date
    Nov 2006
    Location
    India
    Beans
    1,246
    Distro
    Ubuntu Development Release

    Re: Drive in /etc/fstab not mounting

    Guaranteed solution

    sudo sh -c "echo usb_storage >> /etc/modules"

    or add usb_storage manually to /etc/modules

    Reboot and all will be fine.

    Thanks to this thread http://ubuntuforums.org/showthread.php?t=1128849

  7. #17
    Join Date
    Apr 2006
    Location
    Londrina, Brasil
    Beans
    200
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Drive in /etc/fstab not mounting

    Many thanks, but if only! I read the thread, and it makes sense that this could be the problem. However, usb_storage is now in /etc/modules, but after a reboot sudo mount -a is still required to mount the drives.
    Aridus

  8. #18
    Join Date
    Apr 2006
    Location
    Londrina, Brasil
    Beans
    200
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Drive in /etc/fstab not mounting

    Quote Originally Posted by me.translucent View Post
    i was just curiuos what is this uuid thing ?
    A Universally Unique Identifier (UUID) is an identifier standard used in software construction, standardized by the Open Software Foundation (OSF) a... (http://en.wikipedia.org/wiki/UUID), which I found by reading https://help.ubuntu.com/community/Fstab, which is useful but doesn't help mount my usb drives automatically....
    Aridus

  9. #19
    Join Date
    Apr 2008
    Beans
    81

    Re: Drive in /etc/fstab not mounting

    thnx dude .. i think that can fix my problem with permissions in mounted ntfs volume

  10. #20
    Join Date
    Apr 2006
    Location
    Londrina, Brasil
    Beans
    200
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Drive in /etc/fstab not mounting

    Excellent.. but does anybody yet have a solution to ensure that usb drives in /etc/fstab mount? Thanks!
    Aridus

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •