Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

  1. #11
    Join Date
    Oct 2007
    Location
    West Virginia
    Beans
    593
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    I'm just happy I'm able to give back to the forums that have helped me so much.

    I thought I'd take a moment to explain why the procedure is as long as it is ...

    Removing the nvidia packages - Pretty self-explanatory, gives a fresh slate to work with.

    The packages listed to install - These come from nvidia's instructions (or they did at the time I first did this). They assure if you have a kernel change, packages needed to rebuild the drivers are available.

    Xorg,conf - One of the biggest problems. This file never seems to get automatically done correctly. People with dual monitors (with or without SLI) absolutely need to edit this. I found this info in another post here on the forums.

    And, as mentioned previously, using the repositories and not doing a manual install allows Ubuntu to upgrade automatically if your kernel upgrades.

    Here's hoping Linux spreads faster than the swine flu!!!
    Learn something new and have fun every day! Ubuntu!

  2. #12
    Join Date
    May 2009
    Beans
    13

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Hey, I am pretty new to linux and I had a good system up and running on a computer I was borrowing. However after a fresh install of 8.04 on my old crappy emachines computer, I have been unable to install the nvidia driver. I have been trying to figure it out for almost a week now and have tried several how tos on the forums where other people seemed to be having success. I had the most success following the instructions of this thread: http://ubuntuforums.org/archive/index.php/t-763236.html I was able to install the driver provided on the nvidia website and had 3D graphics enabled, however once I rebooted I got nothing but a blank screen at login.

    I found this how to and got excited since it had instructions I hadn't seen on others, namely installing module assistant and identifying the busID. I thought for sure this was going to solve my problem but low and behold, once I rebooted I was once again greeted with the nasty blank screen that I have come to hate so much. I'm beginning to think that there is something very simple that I am overlooking or something I simply don't know that is causing my problem.

    Can any body out there please help me? I am about to throw my computer out the window (I would but I am too broke right now to buy a new one).

    Cheers

  3. #13
    Join Date
    May 2009
    Beans
    13

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    PS
    I followed the instructions here once with no success. Then a second time after upgrading to Jaunty, still no success.

  4. #14
    Join Date
    May 2009
    Beans
    13

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    here is my current xorg.conf:

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    BusID "PCI:00:05:0"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

  5. #15
    Join Date
    Dec 2007
    Location
    Southport, W.Lancs., UK.
    Beans
    16
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Can I just confirm a couple of my thoughts? I'm running a Geforce4 MX460, quite an old card, but using the normal Nvidia driver X hangs at the login. So using this method sounds good and looking forward to trying it.

    But.... the Hardware Driver says that 96.43.10 is my recommended driver for this graphics card, so I presume I let it go ahead with that?

    I looked up the wiki for SLI and presume I don't need to put that line in for my card?

    As you can perhaps tell I'm quite a newb, and this is the only thing that doesn't work on 9.04.... otherwise, loving Ubuntu!

    Unh.
    Last edited by Unhban; May 7th, 2009 at 11:33 AM. Reason: spelling correction!

  6. #16
    Join Date
    Jan 2006
    Beans
    266
    Distro
    Ubuntu

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    am working with
    GeForce 6100 nForce 405.

    The system reads the driver. Gives the correct display but unable to save to xorg.conf.

    Am working on it.

    btw, jaunty usb stick is cool.

  7. #17
    Join Date
    Dec 2007
    Location
    Southport, W.Lancs., UK.
    Beans
    16
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Well I went ahead with my presumptions, but... computer says no - X and the whole machine hung again at the login (actually the 9.04 backdrop login image starts to load then it all hangs, so I wonder if that is affecting it somehow!). So anyone with comments would be greatly appreciated!

    BTW ed-koala, there's a small typo in your original post - the line should be:

    nvidia-180-libvdpau not nvidia-180-lidvdpau

    and I seem to have picked up the idea that with gedit you should use gksu and not sudo because sudo uses user permissions and not root permissions which can screw things up when saving, apparently!

    Unh.
    Last edited by Unhban; May 7th, 2009 at 12:10 PM. Reason: Bad grammar.

  8. #18
    Join Date
    Jul 2008
    Beans
    218

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Quote Originally Posted by rmedved View Post
    here is my current xorg.conf:

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    BusID "PCI:00:05:0"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection
    You might double check that pci line. you can use nano to edit the xorg.conf file if you have no gui.

    Code:
    sudo nano /etc/X11/xorg.conf
    good luck
    -=Mark=-
    GigaByte Z68MA-D2H-B3 (Rev. 1.0) F9 * i3-2100T * 8GB (2 x 4GB Ripjaws) * Powercolor HD 5670 * Ubuntu 11.10 64-bit

  9. #19
    Join Date
    Dec 2007
    Location
    Southport, W.Lancs., UK.
    Beans
    16
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Thanks for the good wishes Mark, I need em!

    My xorg.conf is:

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    BusID "PCI:1:0:0"
    Driver "nvidia"
    EndSection
    ----------------------

    The BusID line concurs with what I got when running the command sudo lspci | grep VGA to find out about the MX460.... I got:

    01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 460] (rev a3)

    I just wonder about:

    Option "AddARGBGLXVisuals" "True"

    Unh.
    Last edited by Unhban; May 7th, 2009 at 05:20 PM. Reason: To add a bit more detail...

  10. #20
    Join Date
    Jul 2008
    Beans
    218

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Did you try removing that line? also, with that old of a card you may not need the BusID line if you want to give that a try.

    Not sure what else to suggest to try. I'm still a linux newb and wouldn't have gotten my card working without this thread.

    -=Mark=-
    GigaByte Z68MA-D2H-B3 (Rev. 1.0) F9 * i3-2100T * 8GB (2 x 4GB Ripjaws) * Powercolor HD 5670 * Ubuntu 11.10 64-bit

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •