Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

  1. #1
    Join Date
    Oct 2007
    Location
    West Virginia
    Beans
    593
    Distro
    Ubuntu 9.10 Karmic Koala

    Talking Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    I've seen a number of people who had this problem, so here is a solution that worked for me, tho it is involved ...

    My equipment:

    Asus M3N72-D motherboard
    AMD Phenom 9950 Quad-Core Processor
    8 gb RAM
    2 Samsung HD501LJ 500gb hard disks
    Dual GeForce 9800 GTX+ video cards

    First, open Synaptic and make sure the following packages are installed:

    make
    gcc
    build-essential
    dkms
    linux-headers-2.6.28-11.42 (assumes you use the current kernel)
    linux-headers-2.6.28-11.42-generic
    linux-generic
    linux-headers-generic
    module-assistant

    Next, make sure the following are NOT installed, and use the "Mark for complete removal" option if any need to be removed:

    ALL nvidia pkgs (search for nvidia)
    Any old kernel pkgs, ie linux-headers-2.6.27-X and earlier
    (This might not be necessary, but I did it anyway)


    Now, perform the following command in a terminal:

    sudo lspci | grep VGA

    The output will look something like this:

    02:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GTX (rev a2)
    03:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GTX (rev a2)

    Write down the number begining each line (the 02:00:0 and 03:00:0 or whatever your output shows).

    Go to System-Administration-Hardware Drivers and choose 180.44 and activate the driver - DO NOT REBOOT yet!!!

    <If you have nothing to activate in hardware drivers, then go to Synaptic and install:>

    nvidia-180-lidvdpau
    nvidia-180-kernel source
    nvidia-settings
    nvidia-common


    Open terminal and type:

    sudo gedit /etc/X11/xorg.conf

    Replace the graphics "Device" section with the following:

    Section "Device"
    Identifier "Configured Video Device"
    BusID "PCI:1:0:0"
    Driver "nvidia"
    EndSection

    Edit the BusID line to reflect the number you wrote down earlier (for me, that would be "PCI:2:0:0". ***MAKE SURE*** you use all colons as shown (the original line you copied had a period before the last zero), and add the PCI part as shown.

    If you have sli, add the following line after the driver line:

    Option "sli" "auto"

    Save the file, reboot and you should have 3d graphics working.

    ***NOTE*** - for dual graphic card PCs, you may boot to a black screen but you'll hear the normal boot sounds. If that happens, use the other number you got from earlier OR plug your monitor into the other card.


    This got Nvidia's restricted driver working for me after a number of other solutions failed. After this, upgrading within Jaunty releases should go smoothly, but save this in case the next OS update screws you again.
    Learn something new and have fun every day! Ubuntu!

  2. #2
    Join Date
    Apr 2009
    Location
    Alabama
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    You are such the man. I followed this to a T and got my SLi setup working like a champ. May all your days be filled with the same happiness your knowledge has given me.

    Thanks a ton

  3. #3
    Join Date
    Oct 2007
    Location
    West Virginia
    Beans
    593
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    I'm glad it helped. I'm not sure all that is absolutely necessary, but it does work, and your PC can see the restricted drivers, AND it should update fine in the future.
    Learn something new and have fun every day! Ubuntu!

  4. #4
    Join Date
    Jul 2008
    Beans
    218

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Sweet, I got it to work just fine after only a dozen reinstalls and a whole day. here's a couple things I did differently.

    I used a shortcut I learned when having issues to uninstall all the nvidia programs from synapic package manager with this terminal command:
    Code:
    sudo apt-get purge nvidia*
    I downloaded and installed the latest nvidia drivers from nvidia's website (182.51), instead of installing the built in Hardware Drivers.

    Thanks much
    -=Mark=-
    GigaByte Z68MA-D2H-B3 (Rev. 1.0) F9 * i3-2100T * 8GB (2 x 4GB Ripjaws) * Powercolor HD 5670 * Ubuntu 11.10 64-bit

  5. #5
    Join Date
    Apr 2009
    Location
    Vancouver, Canada
    Beans
    76
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Quote Originally Posted by rmjohnson144 View Post
    I downloaded and installed the latest nvidia drivers from nvidia's website (182.51
    Where are you getting the 182.51 Driver from?

    I can only find v.180.51...

  6. #6
    Join Date
    Apr 2009
    Beans
    4

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Hello All,

    This is my first time posting here in Ubuntu forums and first time using Ubuntu..

    Im not even sure if i should post my question here:

    Anyway just installed 9.0.4 and everything works fine.. My question is how do i know that my SLI is already enabled?

    I mean everything is fine like i can browse internet, watch movie but i dont know if Dual SLI is already enabled..

    Is there a way to know this?

    Thanks to All

  7. #7
    Join Date
    Oct 2007
    Location
    West Virginia
    Beans
    593
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    I downloaded and installed the latest nvidia drivers from nvidia's website (182.51), instead of installing the built in Hardware Drivers.
    The reason I don't recommend using the Nvidia site's driver is if you do that install manually, when your kernel upgrades you have to reinstall it, it won't update automatically. Using the repo solves this.

    As for how to check sli, if you peek in your etc/X11/xorg.conf file, you may see a line like this:

    Code:
    Section "Device"
         Identifier      "Configured Video Device"
         BusID           "PCI:1:0:0"
         Driver          "nvidia"
         Option          "sli" "auto"      <<===========================II
    EndSection
    If it's not there, you can add it and reboot, then it'll be working if it's hardware enabled. You can check it by going to Systen - Administration - NVIDIA X-Server Settings
    Learn something new and have fun every day! Ubuntu!

  8. #8
    Join Date
    Jul 2008
    Beans
    218

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Quote Originally Posted by ed-koala View Post
    The reason I don't recommend using the Nvidia site's driver is if you do that install manually, when your kernel upgrades you have to reinstall it, it won't update automatically. Using the repo solves this.
    I didn't know this. Maybe I'll use the repo next time.
    although reinstall of driver is really painless if it doesn't screw up all these quirks that were fixed and it is nice having the latest drivers.

    As for how to check sli, if you peek in your etc/X11/xorg.conf file, you may see a line like this:

    Code:
    Section "Device"
         Identifier      "Configured Video Device"
         BusID           "PCI:1:0:0"
         Driver          "nvidia"
         Option          "sli" "auto"      <<===========================II
    EndSection
    If it's not there, you can add it and reboot, then it'll be working if it's hardware enabled. You can check it by going to Systen - Administration - NVIDIA X-Server Settings
    Maybe that's why I needed to add the BusID line on my system. I use my rig mainly for folding as it's my backup machine. or maybe the release didn't put this feature in by mistake and is the main cause of issues?

    anyway, thanks again
    -=Mark=-
    GigaByte Z68MA-D2H-B3 (Rev. 1.0) F9 * i3-2100T * 8GB (2 x 4GB Ripjaws) * Powercolor HD 5670 * Ubuntu 11.10 64-bit

  9. #9
    Join Date
    Apr 2006
    Location
    Mancland
    Beans
    164
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Cracking post mate, sorted it for me. I'll just add the following so searches will find this thread - many people I think like me didn't realise it's the SLI that is causing the problem, and get the following error when trying to boot:

    Kinit: name_to_dev_t(/dev/disk/by-uuid/3c7a8f65-b709-494a-92f1-318a38220def)= sda5(8,5)
    kinit: No resume image, doing normal boot...


    And googling that doesn't suggest anything about the SLI fix, so hopefully this thread will bring the two problems together for SLI users.

  10. #10
    Join Date
    Jul 2008
    Beans
    218

    Re: Enabling nvidia drivers in Jaunty - Fixes crash to terminal

    Quote Originally Posted by jonboy99 View Post
    Cracking post mate, sorted it for me. I'll just add the following so searches will find this thread - many people I think like me didn't realise it's the SLI that is causing the problem, and get the following error when trying to boot:

    Kinit: name_to_dev_t(/dev/disk/by-uuid/3c7a8f65-b709-494a-92f1-318a38220def)= sda5(8,5)
    kinit: No resume image, doing normal boot...


    And googling that doesn't suggest anything about the SLI fix, so hopefully this thread will bring the two problems together for SLI users.
    I don't run SLI, but I have two video cards I do folding at home. I left the sli part out. so it seems with any dual card setup, this may be the solution.
    GigaByte Z68MA-D2H-B3 (Rev. 1.0) F9 * i3-2100T * 8GB (2 x 4GB Ripjaws) * Powercolor HD 5670 * Ubuntu 11.10 64-bit

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •