Results 1 to 4 of 4

Thread: Function Keys not working

  1. #1
    Join Date
    Apr 2009
    Beans
    26
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Function Keys not working

    Hi,
    I am using Intrepid on my Toshiba Satellite L305.

    The issue with my laptop is that all the function keys are not working. Do I need to change some setting or will it never work with Ubuntu?

    Thanx

  2. #2
    Join Date
    Feb 2009
    Beans
    211

    Smile Re: Function Keys not working

    Try out:

    System > Preferences > Keyboard

    Check that the LAYOUT and KEYBOARD MODELS are correct, as specific to your hardware.

    Adios

  3. #3
    Join Date
    Apr 2009
    Beans
    26
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Function Keys not working

    Quote Originally Posted by KhurramM View Post
    Try out:

    System > Preferences > Keyboard

    Check that the LAYOUT and KEYBOARD MODELS are correct, as specific to your hardware.

    Adios
    I dont have the same model as mine, but I do have a Toshiba S3000. Still no function keys.

  4. #4
    Join Date
    Aug 2007
    Location
    Greeley, CO
    Beans
    52
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Function Keys not working

    I've got a Toshiba Satellite L305-S5891, and my function keys don't work, either. I've done a ton of independent research on my laptop and have come to the conclusion that, for one reason or another, Ubuntu doesn't realize that the function key (fn) is being pressed at all. I don't know how to fix that.

    I ended up developing my own workaround for it. Instead of using the fn key I use the super (Windows) key, so for example for brightness down, usually fn+F6, I now press super+F6 and achieve the same result.

    The workaround is definitely some effort, but the basics is that you install xbindkeys (which allows you to bind key combinations to different actions) and keytouch (which installs acpi related programs, I think, that interface with the brightness events.)

    The steps are:
    1. Change keyboard settings to allow use of the super key, using xmodmap
    2. Use xbindkeys to map super+F keys to desired commands. For example, the command for brightness is acpi_fakekey [keycode]. You can install the lineakd package and use evtest to figure out what the keycode that changes brightness is.
    3. Set xbindkeys to run (as root) when the computer boots. You have to start it as root because acpi_fakekey has to have root privileges.


    I wrote a more in-depth blog post about it which can be found at http://swinky-linuxblog.blogspot.com...lite-l305.html. Admittedly the directions are a little rough, I wrote it while exhausted (I had spent the previous three or so hours trying to finish my workaround), and am working on making it a little easier to follow, especially for those who have slightly different models of L305s.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •