Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Possible to blacklist lp module? Causing 3 minute boot delay!

  1. #1
    Join Date
    Mar 2007
    Location
    UK
    Beans
    20
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Possible to blacklist lp module? Causing 3 minute boot delay!

    I have a fresh install of Ubuntu 9.04 on an Acer Aspire 9110 laptop. Previous versions of Ubuntu (& derivatives) have been fine, but this one takes forever to boot. Here is an excerpt from dmesg:
    Code:
    [ 11.110893] EIP: [<f7fa52c0>] saa7134_board_init2+0x140/0x710 [saa7134] SS:ES
    P 0068:f619bc54
    [ 11.110906] ---[ end trace 9bd66193deb28a9c ]---
    [ 11.500080] Clocksource tsc unstable (delta = -341257333 ns)
    [ 11.588074] usb 4-2: new full speed USB device using uhci_hcd and address 2
    [ 11.759586] usb 4-2: configuration #1 chosen from 1 choice
    [ 11.790916] Bluetooth: Generic Bluetooth USB driver ver 0.3
    [ 11.791032] usbcore: registered new interface driver btusb
    [ 189.996709] lp: driver loaded but no devices found
    [ 190.062114] Adding 506008k swap on /dev/sda5. Priority:-1 extents:1 across:5
    06008k
    As you can see, there is a 3 minute wait whilst the lp module searches for devices. I believe that lp is associated with parallel ports, but I don't have any.
    I have created a file called 'blacklist-parallel.conf' and placed it in /etc/modprobe.d. The file contains 3 lines:
    Code:
    blacklist lp
    blacklist parport
    blacklist ppdev
    but lsmod shows that all 3 modules are loaded.
    How can I prevent this 3 minute search at boot? If I am going about it the wrong way, then please advise. Is this a kernel bug perhaps?

    Many thanks in advance.

    Cheers, Beastie.

  2. #2
    Join Date
    Oct 2008
    Location
    Canada
    Beans
    Hidden!

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    After creating a blacklist file, such as blacklist.local in /etc/modprobe.d/ you need to update the boot image.
    Code:
    sudo dpkg-reconfigure linux-image-$(uname -r)
    A towel is about the most massively useful thing for fixing computers. Use it to muffle your screams when you mess up, or to dry your tears if it's broken beyond repair. When all else fails, use it to cover up the useless machine, then walk away.

  3. #3
    Join Date
    May 2009
    Beans
    1

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Hi, did this fix work for you?

    I'm having the exact same problem with 9.04 and have also tried creating a blacklist file under /etc/modprobe.d/blacklist.conf, where I'm blacklisting lp, ppdev and parport.

    I've tried running

    sudo dpkg-reconfigure linux-image-$(uname -r)
    and have also tried removing them before rebooting (using rmmod) but each time the delay still occurs and when I type lsmod it shows all three have been started.

    Can anyone think of anything else I need to try?

    Thanks

  4. #4
    Join Date
    Oct 2008
    Location
    Canada
    Beans
    Hidden!

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Blacklisting only prevents the modules from being loaded at boot time, however, modules may still be loaded via other processes, like HAL if you should plug a device in.

    Check to ensure that you have blacklisted the modules correctly. The form is:

    Code:
    blacklist pcspkr
    Then update the initramfs file. A warning message occurs if you do not end the file name in .conf

    pcspkr is a good one to test with. Try the following sequence:
    Code:
    lsmod | grep pcspkr
    You should see it pop up in the terminal. Now do:
    Code:
    gksudo gedit /etc/modprobe.d/blacklist_custom.conf
    Then cut and paste this in there:
    Code:
    blacklist pcspkr
    Then update the initramfs by doing:
    Code:
    sudo dpkg-reconfigure linux-image-$(uname -r)
    Now reboot, the in a terminal do:
    Code:
    lsmod | grep pcspkr
    You shouldn't see anything. However, you can still load it by doing:
    Code:
    sudo modprobe pcspkr
    Now again do:
    Code:
    lsmod | grep pcspkr
    And you should see it once more. However, when you reboot it will not be loaded automatically.

    If you have done this experiment to prove to yourself that this method works, and you are still having problems with blacklisting the modules you desire, then what is likely happening is that the modules are not being loaded by the kernel at boot, but are being loaded by some other process later in the startup, perhaps by HAL or printing or some such.
    A towel is about the most massively useful thing for fixing computers. Use it to muffle your screams when you mess up, or to dry your tears if it's broken beyond repair. When all else fails, use it to cover up the useless machine, then walk away.

  5. #5
    Join Date
    Mar 2007
    Location
    UK
    Beans
    20
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    To cure the problem, I took the rather drastic step of compiling a new kernel with all modules relating to parallel ports disabled. This has worked for me and I now have no boot delay.
    Compiling and installing a custom kernel was much easier than I expected. It can even be automated for the most part. Do a search for KernelChecker.

    Hope you cure your problem.

    Cheers, Beastie.

  6. #6
    Join Date
    Oct 2008
    Location
    Canada
    Beans
    Hidden!

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    I have the following entries in my blacklist.conf file"
    blacklist joydev
    blacklist e100
    blacklist mii
    blacklist serio_raw
    blacklist pcspkr
    blacklist psmouse
    blacklist lp
    blacklist parport
    After updating my boot image and restarting, only lp and parport are loaded. Something else is loading them during the startup process, likely the printing configuration.
    A towel is about the most massively useful thing for fixing computers. Use it to muffle your screams when you mess up, or to dry your tears if it's broken beyond repair. When all else fails, use it to cover up the useless machine, then walk away.

  7. #7
    Join Date
    Nov 2008
    Location
    New Hampshire
    Beans
    395
    Distro
    Ubuntu Development Release

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Not nearly as bad as the OP's issue, but ppdev is causing a 7 second delay in my karmic boot. Other than by compiling a custom kernel without lp, ppdev and parport, has anyone had any success in blacklisting them by any other method?

  8. #8
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Have you tried blacklisting them and then running:
    Code:
    sudo update-initramfs -u
    It will update the boot information so that it knows that it needs to blacklist those items also.

    I am not for sure what ppdev does though so I am not for sure what will happen when it is blacklisted.

  9. #9
    Join Date
    Jul 2006
    Location
    Here
    Beans
    11,190

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Quote Originally Posted by tekstr1der View Post
    Not nearly as bad as the OP's issue, but ppdev is causing a 7 second delay in my karmic boot. Other than by compiling a custom kernel without lp, ppdev and parport, has anyone had any success in blacklisting them by any other method?
    make sure you don't have cups installed.

  10. #10
    Join Date
    Dec 2007
    Location
    Galway, Ireland
    Beans
    316
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Possible to blacklist lp module? Causing 3 minute boot delay!

    Quote Originally Posted by kerry_s View Post
    make sure you don't have cups installed.
    but if i do this will i still be able to configure/use my network printers?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •