Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: ATI Driver woes...

  1. #1
    Join Date
    Dec 2008
    Beans
    13

    ATI Driver woes...

    Ok, so in intrepid ubuntu recognized my ATI Card right away.

    Now that I upgraded to jaunty, it can't find the damn thing anymore.

    i know this might not be at all helpful, because i forget what exactly my card is outside of it's probably a Radeon x300 128mb card, that's what i believe.

    this is so sad, because jaunty runs TEN TIMES better than intrepid, so this is really the only hiccup in the system.

    oh and i checked ATI's website and apparently they have become legacy drivers and were all bundled into one bulky pack. after executing it in terminal i get this:

    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
    correctly set by --iscurrentdistro

    any help would be greatly appreciated.

  2. #2
    Join Date
    Sep 2008
    Beans
    11

    Re: ATI Driver woes...

    Same here... got ati x300 and it doesn't work anymore on jaunty... no 3D acceleration, wrong max resolution


    the driver provided at the ati website do only support the old xorg, before the 1.6...


    somebody help us

  3. #3
    Join Date
    Apr 2009
    Beans
    2
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: ATI Driver woes...

    Exact same problem here. Please help.

  4. #4
    Join Date
    Jul 2006
    Location
    Colorado
    Beans
    119
    Distro
    Kubuntu

    Re: ATI Driver woes...

    Yes my card has issues too. Here is what I see in LSPCI
    Code:
    monsuco@Earthbound:~$ lspci
    00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
    00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)                                             
    00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)                                       
    00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)                                       
    00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)                                       
    00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA                                                         
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
    01:05.2 Audio device: ATI Technologies Inc Radeon X1200 Series Audio Controller
    08:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 2a08 (rev 03)
    0e:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    monsuco@Earthbound:~$
    I used to use the normal ATI driver provided for me by restricted drivers manager, but this time it doesn't seem to provide them in the manager. I can't do anything in 3D without those, this won't work.

    Is this some issue with Kubuntu, or does Ubuntu have this problem too?
    This signature is in Spanish when your not looking.

  5. #5
    Join Date
    Apr 2009
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: ATI Driver woes...

    I have mobility x2300 card and same troubles with driver. Compiz work perfectly, but game performance is horrible, also i have screen filled with tildes when shut down or re-login.
    Install of ati-driver-installer-9-3-x86.x86_64.run from ati.amd.com gives this:
    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
    correctly set by --iscurrentdistro
    Begging for some help with this

  6. #6
    Join Date
    Apr 2009
    Beans
    1,173

    Re: ATI Driver woes...

    There are several thread about this. ATI has moved a large number of cards, some relatively recent, to the "legacy" category and they are not supported in Catalyst 9.4 (see which cards at http://support.amd.com/us/gpudownloa...1&lang=English). If you have one of these cards then Ubuntu should install one of the older, open source drivers appropriate to your card - but you will see a decline in speed and some features will not be supported.

    If you attempt to install Catalyst 9.3 or earlier (as some people have) then it will probably break your Ubuntu 9.04 and give you a black or garbled screen.

    If you have not upgraded to Ubuntu 9.04 then burn a Live CD and test the performance with glxgears, video playback, YouTube etc before proceeding to replace an earlier distribution.

  7. #7
    Join Date
    Sep 2008
    Beans
    93

    Re: ATI Driver woes...

    I have an ati mobility radeon 9600 and stupidly upgraded to jaunty without knowing about the issues related to this. My system is practically unusable. My background image is coming through clean, but all the icons and programs are blurred by black pixels. This is what used to happen to me when I tried to enable compiz on intrepid, however i do not have any effects enabled.

    Does anyone know of a way to get around this?

  8. #8
    Join Date
    Sep 2008
    Beans
    93

    Re: ATI Driver woes...

    OK so i can watch avi files with M Player and it is coming through clearly, this is strange

  9. #9
    Join Date
    Apr 2009
    Beans
    1,173

    Re: ATI Driver woes...

    Quote Originally Posted by notanerd View Post
    I have an ati mobility radeon 9600 and stupidly upgraded to jaunty without knowing about the issues related to this. My system is practically unusable. My background image is coming through clean, but all the icons and programs are blurred by black pixels. This is what used to happen to me when I tried to enable compiz on intrepid, however i do not have any effects enabled.

    Does anyone know of a way to get around this?
    You need to sudo apt-get remove xorg-driver-fglrx:

    http://ubuntuforums.org/showthread.p...ght=fglrx+sudo

  10. #10
    Join Date
    Sep 2008
    Beans
    93

    Re: ATI Driver woes...

    i have already removed it, thanks for your help though

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •