Page 1 of 8 123 ... LastLast
Results 1 to 10 of 73

Thread: HowTo fix Intel video in Jaunty (alternative way)

  1. #1
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    HowTo fix Intel video in Jaunty (alternative way)

    *Updated 28/04/09

    A new version of Intel driver has been released through PPA.
    This driver really improve performances with Jaunty upstream.
    The page/repos are here:
    https://edge.launchpad.net/~ubuntu-x...ive/x-updates/

    1) Add the PPA repo to the end of your APT sorces.list
    Code:
    sudo gedit /etc/apt/sources.list
    and add the following lines:
    2) Add the gpg key of this PPA repo
    Code:
    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com AF1CDFA9
    2) Upgrade the drivers:
    Code:
    sudo apt-get update && sudo apt-get dist-upgrade
    3) Modify your Device section in xorg.conf
    Code:
    sudo gedit /etc/X11/xorg.conf
    Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
    Option "AccelMethod" "UXA"
    EndSection
    4) Reboot

    * END UPDATE =============

    Hi all.
    I'm writing this HowTo in order to give a different way to fix the issues for Intel video cards on Jaunty.

    The way showed here is lighter than the one described here:
    http://ubuntuforums.org/showthread.php?t=1130582
    and I suggest to give a try to this one -before- approaching the one posted by psyke83, that involving the substitution of drivers (xorg-hedgers repository) and kernel (vanilla 2.6.30rc2).

    What will follow worked for my Intel card and uses the default Jaunty packages and kernel.
    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    I think that on other Intel cards should work as well. Feedbacks are welcome.

    1)
    Discovering the memory of your card; do this command:
    Code:
    lspci -vv
    and search in the output for the block regarding VGA; in my case:
    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    Subsystem: Fujitsu Siemens Computers Device 106a
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
    Latency: 0
    Interrupt: pin A routed to IRQ 16
    Region 0: Memory at d8000000 (32-bit, prefetchable) [size=128M]
    Region 1: Memory at e0380000 (32-bit, non-prefetchable) [size=512K]
    Region 2: I/O ports at ec00 [size=8]
    Capabilities: <access denied>
    Kernel modules: intelfb
    In red you can see the amount of the memory that your card can manage and in blue the non-prefetchable memory. In order to use the video card memory in the correct way, you can use Videoram option in xorg.conf; but we must calculate the ram from MB to KB in order to use it in Videoram option; here the table:
    16 -> 16384
    32 -> 32768
    64 -> 65536
    128 -> 131072
    256 -> 262144
    Now we have to subtract the value of non-prefetchable to our amount of ram; in my case:
    131072 - 512 = 130560
    2)
    As soon as you calculate your video ram minus the non-prefetchable memory, you can modify your xorg.conf in the device section:
    Code:
    sudo gedit /etc/X11/xorg.conf
    In my case the device section is configured like this:
    Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
    Option "AccelMethod" "UXA"
    VideoRam 130560
    EndSection
    Please be sure that VideoRam matching the ram of Video card based on what you calculate above. Of course the option UXA is mandatory too.
    Save xorg.conf

    3)
    If you are using Compiz, please modify these settings using Compiz manager:
    Code:
    ccsm
    Choose General options -> General -> remove the flag on Unredirect Fullscreen Windows
    Choose General options -> Display Settings -> remove the flag Sync To VBlank
    Close ccsm

    4)
    Reboot your box

    Hope this help
    Last edited by dentaku65; April 28th, 2009 at 11:47 AM.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  2. #2
    Join Date
    Dec 2007
    Beans
    6

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Thanks dentaku65

    This has worked for me although for 2D only. Still get "Desktop effects could not be enabled" (Compiz). Output of
    Code:
    lspci -nn | grep VGA
    gives
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)

  3. #3
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Quote Originally Posted by SquiffSquiff View Post
    Thanks dentaku65

    This has worked for me although for 2D only. Still get "Desktop effects could not be enabled" (Compiz). Output of
    Code:
    lspci -nn | grep VGA
    gives
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
    Did you tried with a 3d game like Ppracer?
    Code:
    sudo apt-get install planetpenguin-racer
    ..just to know if is a 3d issue or compiz issue.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  4. #4
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HowTo fix Intel video in Jaunty (alternative way)

    dentaku,

    Precisely what issue does your method fix? I don't think your proposed VideoRam option makes any difference at all, sorry.

    Code:
    conn@inspiron:/var/log$ cat /var/log/Xorg.0.log | grep -i videoram
    (WW) intel(0): VideoRam configuration found, which is no longer recommended.
    (II) intel(0): Continuing with default 131072kB VideoRam instead of 130560 kB.
    (**) intel(0): VideoRam: 131072 KB
    Performance is equal to before. In ppracer - with EXA, about 19-20fps; with UXA, about 25fps. Applying the MTRR fix improves framerate slightly, but not as good as with kernel 2.6.30-rc2 and newer drivers.

    P.S. Tested this xorg configuration on kernel 2.6.28-11-generic and the official Jaunty versions of all packages. Also tested using newer kernel and xorg-edgers packages - no difference.
    Last edited by psyke83; April 25th, 2009 at 02:52 PM.

  5. #5
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Quote Originally Posted by psyke83 View Post
    dentaku,

    Precisely what issue does your method fix? I don't think your proposed VideoRam option makes any difference at all, sorry.

    Code:
    conn@inspiron:/var/log$ cat /var/log/Xorg.0.log | grep -i videoram
    (WW) intel(0): VideoRam configuration found, which is no longer recommended.
    (II) intel(0): Continuing with default 131072kB VideoRam instead of 130560 kB.
    (**) intel(0): VideoRam: 131072 KB
    Performance is equal to before. In ppracer - with EXA, about 19-20fps; with UXA, about 25fps. Applying the MTRR fix improves framerate slightly, but not as good as with kernel 2.6.30-rc2 and newer drivers.

    P.S. Tested this xorg configuration on kernel 2.6.28-11-generic and the official Jaunty versions of all packages. Also tested using newer kernel and xorg-edgers packages - no difference.
    I have good performances indeed; unfortunately I cannot post FPS of ppracer because "ppracer -a" give me this:
    get fences failed: -1
    param: 6, val: 0
    Benchmark error: unable to set course:
    without -a switch is playable very good in fullscreen too

    Glxgears give me this:
    1396 frames in 5.0 seconds = 279.030 FPS
    1412 frames in 5.0 seconds = 282.383 FPS
    1427 frames in 5.0 seconds = 285.396 FPS
    1423 frames in 5.0 seconds = 284.433 FPS
    1427 frames in 5.0 seconds = 285.277 FPS
    1420 frames in 5.0 seconds = 283.888 FPS
    1426 frames in 5.0 seconds = 285.185 FPS
    Last edited by dentaku65; April 25th, 2009 at 03:06 PM.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  6. #6
    Join Date
    Dec 2008
    Location
    European Land of Bananas
    Beans
    123
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo fix Intel video in Jaunty (alternative way)

    it seems your stuff can work better on i8xx cards rather on i9xx ones

    have you upgraded your Gnome Mplayer to 0.9.5 ? It solved my awful video output when using UXA with fairly new 2.7.0 driver (GMA950) ....
    My favourite userbars: #1, #2, #3, #4
    Help me, pls!!!! Click here.

  7. #7
    Join Date
    Apr 2008
    Beans
    10

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Fantastic, your quick fix worked. Many thanks.

    After checking the automatic upgrade option in package manager I have had a terrible 24 hours. I lost the upgrade completely. Had to download the "full Jaunty" and start over.

    Compiz was jumpy and opening any window was slow.

    My experience with automatic upgrades are over. I wish Canonical or the developers of new releases would disable that feature until they are sure it works for all platforms. After my upgrade my system would not boot into a gui or terminal. The safe mode did not fix anything because the eth0 couldn't be enabled to download the broken packages.

    My system:
    Toshiba Satellite P105 w/ 4Gig memory/ Intel graphics/

    This is my Xorg.conf file that I changed with your instructions.

    Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
    Option "AccelMethod" "UXA"
    VideoRam 261888
    EndSection

    Again Thanks, Mucho Gracias,

  8. #8
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Quote Originally Posted by rnrover View Post
    Fantastic, your quick fix worked. Many thanks.

    After checking the automatic upgrade option in package manager I have had a terrible 24 hours. I lost the upgrade completely. Had to download the "full Jaunty" and start over.

    Compiz was jumpy and opening any window was slow.

    My experience with automatic upgrades are over. I wish Canonical or the developers of new releases would disable that feature until they are sure it works for all platforms. After my upgrade my system would not boot into a gui or terminal. The safe mode did not fix anything because the eth0 couldn't be enabled to download the broken packages.

    My system:
    Toshiba Satellite P105 w/ 4Gig memory/ Intel graphics/

    This is my Xorg.conf file that I changed with your instructions.

    Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
    Option "AccelMethod" "UXA"
    VideoRam 261888
    EndSection

    Again Thanks, Mucho Gracias,
    Good
    Can you post your card model, please?
    Code:
    lspci |grep VGA
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  9. #9
    Join Date
    Apr 2008
    Beans
    10

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Quote Originally Posted by dentaku65 View Post
    Good
    Can you post your card model, please?
    Code:
    lspci |grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

    Here you go

  10. #10
    Join Date
    Mar 2009
    Beans
    3

    Re: HowTo fix Intel video in Jaunty (alternative way)

    Thanks much, dentaku65. Your fix also worked perfectly for me. I have an older Compaq desktop.

    brw@brw-desktop:~$ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

Page 1 of 8 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •