Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

  1. #1
    Join Date
    Apr 2006

    Question Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    I've just did a clean install of Jaunty on my HP notebook. The notebook has a Broadcom BCM4306 wireless card which worked prior to my reinstall.

    So I installed Jaunty, hard-wired the notebook and updated then upgraded. Then I rebooted, went into the Hardware manager and enabled the B43-fwcutter driver (and the nVidia 96 driver) and then rebooted again. The driver loads fine (no error messages in dmesg) and I can see the MAC address in ifconfig.

    Problem is that it doesn't "see" any wireless networks, and if I tell it to connect to my hidden network and give it the correct WPA key, it just churns trying to connect but ultimately failing.

    Anyone know of any issues with 9.04 and Broadcom's restricted driver? Like I said, previous versions didn't have this issue (or if it did, when I rebooted the issues resolved themselves).

    Thanks for any help you can offer.

    ~$ uname -a
    Linux bpat-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
    ~$ ifconfig
    wlan0     Link encap:Ethernet  HWaddr 00:90:4b:a3:2d:80  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    ~$ dmesg
    [   18.321069] b43-phy0: Broadcom 4306 WLAN found
    [   18.369034] phy0: Selected rate control algorithm 'pid'
    [   18.558815] Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
    [   18.574331] ACPI: PCI Interrupt Link [LACI] enabled at IRQ 21
    [   18.574337] Intel ICH 0000:00:06.0: PCI INT A -> Link[LACI] -> GSI 21 (level, low) -> IRQ 21
    [   18.574529] Intel ICH 0000:00:06.0: setting latency timer to 64
    [   18.684029] AC'97 0 analog subsections not ready
    [   19.036038] floppy0: no floppy controllers found
    [   19.252039] intel8x0_measure_ac97_clock: measured 55431 usecs
    [   19.252043] intel8x0: clocking to 48000
    [   19.395061] lp0: using parport0 (interrupt-driven).
    [   19.476113] Adding 2963952k swap on /dev/sda5.  Priority:-1 extents:1 across:2963952k
    [   20.016325] EXT3 FS on sda1, internal journal
    [   21.173809] type=1505 audit(1240542822.227:2): operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" name2="default" pid=2001
    [   21.220505] type=1505 audit(1240542822.275:3): operation="profile_load" name="/sbin/dhclient-script" name2="default" pid=2005
    [   21.220671] type=1505 audit(1240542822.275:4): operation="profile_load" name="/sbin/dhclient3" name2="default" pid=2005
    [   21.220720] type=1505 audit(1240542822.275:5): operation="profile_load" name="/usr/lib/NetworkManager/nm-dhcp-client.action" name2="default" pid=2005
    [   21.220767] type=1505 audit(1240542822.275:6): operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" name2="default" pid=2005
    [   21.355406] type=1505 audit(1240542822.407:7): operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" name2="default" pid=2010
    [   21.355639] type=1505 audit(1240542822.407:8): operation="profile_load" name="/usr/sbin/cupsd" name2="default" pid=2010
    [   21.385769] type=1505 audit(1240542822.439:9): operation="profile_load" name="/usr/sbin/tcpdump" name2="default" pid=2014
    [   25.042615] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   25.042618] Bluetooth: BNEP filters: protocol multicast
    [   25.099027] Bridge firewalling registered
    [   27.239111] agpgart-amd64 0000:00:00.0: AGP 2.0 bridge
    [   27.239131] agpgart-amd64 0000:00:00.0: putting AGP V2 device into 4x mode
    [   27.239180] nvidia 0000:01:00.0: putting AGP V2 device into 4x mode
    [   30.945079] eth0: link down
    [   30.945381] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   31.092265] input: b43-phy0 as /devices/virtual/input/input9
    [   31.156046] b43 ssb0:0: firmware: requesting b43/ucode5.fw
    [   31.296580] b43 ssb0:0: firmware: requesting b43/pcm5.fw
    [   31.332545] b43 ssb0:0: firmware: requesting b43/b0g0initvals5.fw
    [   31.458625] b43 ssb0:0: firmware: requesting b43/b0g0bsinitvals5.fw
    [   31.604048] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [   31.685906] Registered led device: b43-phy0::tx
    [   31.685924] Registered led device: b43-phy0::rx
    [   31.685940] Registered led device: b43-phy0::radio
    [   31.720043] b43-phy0: Radio turned on by software
    [   31.720370] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   74.704115] ppdev0: registered pardevice
    [   74.752049] ppdev0: unregistered pardevice
    [   76.147180] ppdev0: registered pardevice
    [   76.201096] ppdev0: unregistered pardevice
    [   76.969283] ppdev0: registered pardevice
    [   77.021693] ppdev0: unregistered pardevice
    [  174.370888] eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
    [  174.371454] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [  185.288032] eth0: no IPv6 routers present
    ~$ lscpi | grep "Wireless"
    02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    UPDATE: This has been solved (at least for me). You can read my solution in post #7
    Last edited by bpat1434; April 25th, 2009 at 12:22 AM. Reason: Posting solution link

  2. #2
    Join Date
    Apr 2007
    Mount Horeb, WI
    Kubuntu Development Release

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    Have you tried taking it out of hidden mode to see if you can connect?

  3. #3
    Join Date
    Apr 2006

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    There are other wireless networks around me (like 4 or 5) some hidden, some not, some encrypted, other not. No wireless networks are being listed and the "strength" of my hidden one is 0.

  4. #4
    Join Date
    Mar 2009
    Mammoth Lakes, CA
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    glad to know this.

  5. #5
    Join Date
    Apr 2007

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    I have a HP Compaq Presario R3000
    I'm having the same problem.

    8.10 worked great but a clean install of 9.04 shows no wireless networks.

    In some digging it should I'm not claimed or unclaimed but disabled. How do I enable it? (and I don't mean the little check box that is enabled it just finds no networks)

    I have 3-4 wireless networks around me broadcasting. In windows on the same computer it works fine.

    I'm sure my wireless card is turned on as in windows its workign fine.

  6. #6
    Join Date
    Apr 2009

    Unhappy Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    I have the same problem.

    I have a HP Pavilion 6005us that was running 8.10 with no problems what so ever including wireless. I know everything was working just fine until I did the upgrade to 9.04 last night. After the update was finished I did get en error about fwcutter but I didn't know what that was. It was too late anyhow as the the upgrade was finished.

    I did find this site and I believe the problem has to do with the firmware.

    Here is my machine is showing:

    llspci -vnn | grep 14e4
    Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03)

    According to the docs on the site above 14e4:4320 is not supported.

    I can't afford to be without my laptop as I removed Windows sometime ago. Hopefully they will be a fix for it soon as this is a VERY popular wireless card. I as going to have to go back to 8.10 until then.
    Last edited by WhoDoTech; April 24th, 2009 at 08:54 PM.

  7. #7
    Join Date
    Apr 2006

    Smile [SOLVED] Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    Glad to see I'm not the only one having issues with it. I'll keep digging some this weekend, but hopefully there's something.

    I did notice that in looking through all my logs, I found only one possible explanation:

    Apr 23 23:08:46 bpat-laptop[3548]: Cannot find  firmware file 'b43/ucode5.fw'
    Apr 23 23:08:46 bpat-laptop[3574]: Cannot find  firmware file 'b43/ucode5.fw'
    Apr 23 23:14:37 bpat-laptop hp: io/hpmud/pp.c 627: unable to read device-id ret=-1 
    Apr 23 23:14:38 bpat-laptop python: io/hpmud/pp.c 627: unable to read device-id ret=-1
    So I googled the above, and read through this thread at Linux forums. So I said well why not... and just ran
    ~$ sudo /usr/share/b43-fwcutter/
    and it ran, then I checked for wireless networks and voila! I can now see wireless networks. I'm not sure what it did, but it works!

    As a side note, I did notice that when the restricted driver was activated, it never did the "Do you want to extract the firmware" confirmation like 8.10 did. So possibly this is the issue.

  8. #8
    Join Date
    Apr 2009

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306


    I had the same problem. I tried your solution and it worked. But after some time it disconnects. And then connects again. And again disconnects. Sometimes forever until you reboot or repeat the whole process.

    I would appreciate if you can post any further insight in this thread


  9. #9
    Join Date
    Nov 2008
    Ubuntu 9.10 Karmic Koala

    Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    I have the same problem. My machine is a Dell Studio 1735 laptop. I made the update from Ubuntu 8.10 to 9.04 yesterday.

    I also have a Broadcom. Mine is BCM4322. Wireless networks are not showing either.

    The weird part is that in "Hardware drivers" the driver is active but says: "it's not currently in use".

    If I boot the Jaunty using the 2.6.27-11 kernel, the wifi works fine, just as it did in Intrepid.



  10. #10
    Join Date
    May 2005

    Smile [SOLVED] Re: Wireless fails in 9.04 (Jaunty) with Broadcom 4306

    Same problem here (ASUS A6RP-AP069).

    Installing the b43-fwcutter package (use Synaptic or apt-get to do it) and rebooting the computer solved the problem.
    Last edited by chopeen; May 6th, 2009 at 09:11 AM.

Page 1 of 4 123 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts