Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 79

Thread: cannot shutdown / reboot laptop on 9.04

  1. #61
    Join Date
    Jun 2009
    Beans
    2

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by hyapadi View Post
    I'm using Acer Aspire 4520 ( AMD Turion, Nvidia 7000m, Broadcom Wireless ) and Ubuntu 9.04 with nvidia 180.x and broadcom wireless driver.

    Ocassionally, the shutdown process doesn't not shut off the laptop. The progress bar does move and finished. But in the end, the computer still running and show blank.

    My temporary workaround was to press enter during that "blank" session. The computer will then shut off.

    I did experience this in Ubuntu 8.10 and Ubuntu 9.04. I don't really remember how it was with the older release of Ubuntu since I wasn't really using it.
    I've had the same problem and same laptop as you are. after few workaround I eventually solve it with upgrading my kernel to linux-image-2.6.30-8-generic and install other packages that related: linux-headers-2.6.30-8 and linux-headers-2.6.30-8-generic. from karmic download page... finally it shuts down properly...

    note : you might have to reinstall the NVIDIA driver...




    Last edited by kemanamana; June 11th, 2009 at 12:57 PM.

  2. #62
    Join Date
    Apr 2008
    Beans
    204
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: cannot shutdown / reboot laptop on 9.04

    Make the option persistent between kernels with:

    acpi=force in the "defoptions" line eg:

    #defoptions=quiet acpi=force splash
    Ktechman

  3. #63
    Join Date
    Jun 2009
    Beans
    1

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by RichardG891 View Post
    You need to insert it into the boot line.

    open a terminal and type

    gksu gedit /boot/grub/menu.lst

    (that's an L not a number one)

    That gives you access to the grub bootloader (Be VERY careful)

    scroll down all the commented instructions and you'll get to the menu list. Edit the top (default) one by inserting your code anywhere on the first line:

    ## ## End Default Options ##

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet acpi=force splash
    initrd /boot/initrd.img-2.6.24-24-generic
    quiet

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic (recovery mode)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro single
    initrd /boot/initrd.img-2.6.24-24-generic

    title Ubuntu 8.04.2, kernel 2.6.24-23-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet splash
    initrd /boot/initrd.img-2.6.24-23-generic
    quiet

    save, close and reboot. If you've got an HP/compaq laptop (like mine) I had more success with "hpet=disable". If you have problems during reboot, select the (unedited) recovery option, boot as normal and remove the command.
    Thank you for this solution. Worked great. I wouldn't have had a clue on my own.

  4. #64
    Join Date
    Nov 2005
    Beans
    522
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: cannot shutdown / reboot laptop on 9.04

    I've been following this thread as I had a Dell XPS M1210 that wouldn't shut down. I'm running 9.04 64-bit.

    However, the problem seems to have gone with the latest kernel update to 2.6.28-13-generic. Has this fixed it for anyone else?

  5. #65
    Join Date
    Jul 2007
    Beans
    8

    Re: cannot shutdown / reboot laptop on 9.04

    Same problem here on a Lenovo W500. Adding acpi=force to menu.lst in /boot/grub appears to have fixed the problem. New install of 9.04 with all updates applied.

  6. #66
    Join Date
    Apr 2008
    Location
    Oslo
    Beans
    36
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by sleepyenglish View Post
    Exact same issue here except im running a Dell XPS m1530
    Same here, but I think i got rid of it by booting in recovery-mode, took the option about xconfig, but i got it back? right now dual screen on my xps 1530. I have experienced it come and go.
    Whats next?

    dell XPS m1530, 4G ram, nvidia 8600m gs
    ubuntu mostly trying the latest release

  7. #67
    Join Date
    Jul 2009
    Beans
    3

    Re: cannot shutdown / reboot laptop on 9.04

    I went to the end of the threads hoping to find a solution to this problem. My experience so far my laptop will only boot and shut down properly when plugged in and for all programs to properly function needs ac. This defeats the purpose of a laptop.

    I have an HP pavillion dv6910 amd turion 64x2, nvidia graphics ((GeForce Go 7150M graphics), generously stocked with 3g ram.

    Any suggestions? I would like to run on battery power.

    Thank You

  8. #68
    Join Date
    Apr 2009
    Beans
    82

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by hesapotman View Post
    In MY case, I remove both "ipw3945" and "iwl3945" modules. In YOUR case, you'll need to find out the module names being used by your wireless device.
    Ok, how can I tell the name of the drivers that my wireless is using. My wireless worked out of the box, so I did not have to mess with it. The code "modprobe -l" gives a very long list of stuff.

  9. #69
    Join Date
    Aug 2009
    Beans
    2

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by RichardG891 View Post
    You need to insert it into the boot line.

    open a terminal and type

    gksu gedit /boot/grub/menu.lst

    (that's an L not a number one)

    That gives you access to the grub bootloader (Be VERY careful)

    scroll down all the commented instructions and you'll get to the menu list. Edit the top (default) one by inserting your code anywhere on the first line:

    ## ## End Default Options ##

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet acpi=force splash
    initrd /boot/initrd.img-2.6.24-24-generic
    quiet

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic (recovery mode)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro single
    initrd /boot/initrd.img-2.6.24-24-generic

    title Ubuntu 8.04.2, kernel 2.6.24-23-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet splash
    initrd /boot/initrd.img-2.6.24-23-generic
    quiet

    save, close and reboot. If you've got an HP/compaq laptop (like mine) I had more success with "hpet=disable". If you have problems during reboot, select the (unedited) recovery option, boot as normal and remove the command.
    Worked for me. Thank you.

    Before I try the above, I tried to turn off my wireless card before restart or shutdown, perfectly worked. I am sure it has to be the system failed to shutdown the wireless device.

    acpi=force does the job for me. However, could anyone tell me what's the side effect of it, to my understanding it has to be a reason why ubuntu does not come with this configuration to avoid such common problem.

  10. #70
    Join Date
    Jul 2006
    Location
    Aruba
    Beans
    189
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by RichardG891 View Post
    You need to insert it into the boot line.

    open a terminal and type

    gksu gedit /boot/grub/menu.lst

    (that's an L not a number one)

    That gives you access to the grub bootloader (Be VERY careful)

    scroll down all the commented instructions and you'll get to the menu list. Edit the top (default) one by inserting your code anywhere on the first line:

    ## ## End Default Options ##

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet acpi=force splash
    initrd /boot/initrd.img-2.6.24-24-generic
    quiet

    title Ubuntu 8.04.2, kernel 2.6.24-24-generic (recovery mode)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro single
    initrd /boot/initrd.img-2.6.24-24-generic

    title Ubuntu 8.04.2, kernel 2.6.24-23-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=3be998e1-d3ed-4dfb-869d-8b2010c5babf ro quiet splash
    initrd /boot/initrd.img-2.6.24-23-generic
    quiet

    save, close and reboot. If you've got an HP/compaq laptop (like mine) I had more success with "hpet=disable". If you have problems during reboot, select the (unedited) recovery option, boot as normal and remove the command.

    FWIW, this solved my Vaio FW's failure to shutdown/reboot. Thanks!

Page 7 of 8 FirstFirst ... 5678 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •