Results 1 to 5 of 5

Thread: 9.04 open source ati driver is slow

  1. #1
    Join Date
    Jul 2008
    Beans
    16

    9.04 open source ati driver is slow

    I just upgraded to 9.04 and was dismayed that I the ati driver it comes with is slow. I tried upgrading to the catalyst 9.4 driver but it doesn't work and it took me an hour or two to downgrade properly.

    With the xserver-ati driver I see the screen tear every once in a while, especially while watching youtube videos. The whole system feels a bit slower than when I was using 8.04 with some catalyst driver.

    Is there something I can do to speed things up? Maybe put something in /etc/X11/xorg.conf?

    glxgears gives me about 300fps. Some more stuff
    Code:
    $ glxinfo | head
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    Code:
    $ lspci | grep -i radeon
    01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

  2. #2
    Join Date
    Aug 2006
    Location
    england
    Beans
    783

    Re: 9.04 open source ati driver is slow

    unfortunatly the x series and older are no longer supported by ati so this is why there are no catalyst drivers on jaunty.
    your options are to go back to intrepid or use the open driver which is as you have found poor

  3. #3
    Join Date
    Feb 2005
    Beans
    33

    Re: 9.04 open source ati driver is slow

    Same problem on a IBM T42

    lspci | grep -i radeon
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

    Found a partial solution here
    http://ubuntuforums.org/showthread.php?t=1108844&page=2

    and the bug report here
    https://bugs.launchpad.net/ubuntu/+s...ti/+bug/363238
    Last edited by anthony_barker; April 24th, 2009 at 03:12 AM.

  4. #4
    Join Date
    Jul 2008
    Beans
    16

    Re: 9.04 open source ati driver is slow

    Thanks for the links. I tried the changes to xorg.conf and things seem a bit better now. I commented in the bug report as well.

  5. #5
    Join Date
    Jan 2009
    Beans
    3

    Re: 9.04 open source ati driver is slow

    I had similar problems with my ATI card which was probably due to a conflict with the proprietary drivers. I just ran
    Code:
    $ sudo apt-get remove --purge xorg-driver-fglrx
    in the terminal and the problem was solved. I found this in
    https://help.ubuntu.com/community/RadeonDriver

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •